RE: HDR on Linux
Posted in 2000
After you do the 'ontape -p' restore on the secondary, go over to the
primary and do:
onmode -d primary <secondary-instance-name>
then go back to the secondary and do:
onmode -d secondary <primary-instance-name>
Note that the onmode command on each server references the instance on the
OTHER server, so that it knows who its replication partner is. I assume
that you've already made sure that your primary- and
secondary-instance-names are both in the sqlhosts file on each server, that
they reference network (i.e., not shared memory) connections, and that the
two Linux servers are "trusted" to each other (via hosts.equiv or .rhosts).
HTH,
Paul Mosser
-----Original Message-----
From: Nigel Canning [mailto:michael.latimer@cognito.co.uk]
Sent: Friday, January 14, 2000 2:35 AM
To: 'informix-list@iiug.org'
Cc: 'john.horton@cognito.co.uk'
Subject: HDR on Linux
Hi
I am currently in the process of porting processes from an HP to a linux
box.
I tried to set up Data Replication on the Linux box (RH 5.2) using Informix
7.3.
I performed an archive of the linux box that was to be the primary server
using an ontape -s
I set this server to be the primary with onmode -d primary <my server name>
On the linux box (identical set up (I think?)) I performed an ontape -p.
However, after the load of the dataspaces, the message ,unable to connect to
primary server , was displayed and the secondary remained in quiescent mode.
I was unable to access the data at all.
How to I set up data replication?? I have done everything in the book but am
more than a little flumuxed :)
Thanks in advance for any helpfull hints or any comforting words
John H