Re: Problems with migration b/w 7.12 and 7.30
Posted in 1998
Something to try......
select a.serialv
from sysptnhdr a, systabnames b
where a.partnum = b.partnum
and b.tabname = <your table name>
and b.dbsname = <your db name>
Should return the last serial values for the table from the partition
header. What happens if you update this value?
Just an idea...don't blame me if it breaks something...:)
Idiot
Greg McGregor wrote in message <7175db$sb9$1@news.xmission.com>...
>
>All,
>
>Having some problems migrating data from Informix 7.12 UC3 to
>an Informix 7.30 UC2.
>
>Firstly, performing a dbexport of a db from 7.12 environment and
dbimporting into
>a 7.30 environment. As I'm aware there is no clear path to migrate b/w
7.12 and 7.30 therefore why my choice of tool for migration.
>One of the tables within the db being migrated has a field which is of type
serial. It just so
>happens that any new row insert into this table fails with a 239 error -
duplicate key.
>
>This table has three indices, two unique and one duplicate. I have
verified the two unique
>indices are definitely not causing any problems.
>
>I need some advice on this problem.
>
>TIA
>
>Greg McGregor
>System Admin/DBA
>gregm@kew.starway.net.au
>~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>
>