Re: plagued by err. 246 (even with 200K locks)
Posted in 2000
You could also try setting the table to row level locking if it is not set so already. Rudy Fernandes wrote: > Error 246 (Could not do an indexed read to get the next row) is not going to > go away by adding locks. It is related to lock interaction between sessions - > more than 1 session wants a resource that is already "in use" - rather than a > resource overflow. > > Secondly, isolation levels only affect locking behaviour of SELECT statements. > A row that is inserted, updated or deleted is ALWAYS locked for the duration > of the transaction. > > What you should be looking at is > > 1. Reduce, if possible, the length of each session's transactions and the > number of rows affected (and, therefore, locked). > 2. Allow sessions to wait for a locked resource (the default behaviour is to > return an error without waiting) by using the SET LOCK MODE TO WAIT statement > in the application code. (Examine the manual for details). > 3. Make sure that the tables' being hit are indexed appropriately to support > quick responses to your application requests. > > HTH > Rudy > > > > > > > > plagued by err. 246 (even with 200K locks) > > > > > > Hi, > > > We have this problem when doing a update with dirty isolation mode. > > > I have searched the archives and found out that increasing locks might > > help. > > > But it doesn't look that's helping me. Please suggest on how to overtake > > > error 246. I have also read about this being a bug. But I am not sure. > > > > > > IDS 5.10.UC3 > > > DEC OSF1 > > > > > > > > > > > > Thanks, > > > Sunil