Re: Sudden Increase in Checkpoint Lengths
Posted in 2009
Topics: Performance & Tuning, Logging & Checkpoints
2009/8/11 LIGHT SCANS <light_scans@yahoo.com>: > Hello Keith, > > All the suggestions above are good. Let me just add these commands: > > errpt -a | pg > vmstat 5 5 > > The "errpt" shows hardware and software errors. Look for a change > when your system started slowing down. > > The "vmstat" shows a current overview of O.S. performance. Run it > when your system is running at its worst. The "r" should be below 10 > (l like it below 4). The "pi" should be 0. The "wa" should be "0". > Any other column with a high number is worth looking into. > > -L.S. > _______________________________________________ > Informix-list mailing list > Informix-list@iiug.org > http://www.iiug.org/mailman/listinfo/informix-list > All Following a disk change and investigations on fibre cards, no hardware fault was found and the issue was unresloved. The engine was rebooted but failed to restart :-((( network port issue. Server restarted followed by successful engine restart (with TRACECKPT set). Checkpoints have all been 0 seconds since restart !!! :-))) Keith
On 12 Aug, 10:21, Keith Simmons <smile...@googlemail.com> wrote:
> 2009/8/11 LIGHT SCANS <light_sc...@yahoo.com>:
>
>
>
> > Hello Keith,
>
> > All the suggestions above are good. Let me just add these commands:
>
> > errpt -a | pg
> > vmstat 5 5
>
> > The "errpt" shows hardware and software errors. Look for a change
> > when your system started slowing down.
>
> > The "vmstat" shows a current overview of O.S. performance. Run it
> > when your system is running at its worst. The "r" should be below 10
> > (l like it below 4). The "pi" should be 0. The "wa" should be "0".
> > Any other column with a high number is worth looking into.
>
> > -L.S.
> > _______________________________________________
> > Informix-list mailing list
> > Informix-l...@iiug.org
> >http://www.iiug.org/mailman/listinfo/informix-list
>
> All
>
> Following a disk change and investigations on fibre cards, no hardware
> fault was found and the issue was unresloved. The engine was rebooted
> but failed to restart :-((( network port issue. Server restarted
> followed by successful engine restart (with TRACECKPT set).
> Checkpoints have all been 0 seconds since restart !!! :-)))
>
> Keith
Next time the longer checkpoints appear run onstat -g stk all and send
the results...could be something in a critical section for a long
time.
Related threads
- Posting from the Informix-list
- Migrating from IDS 9.40.UC6 to 11.50.UC3
- Ip for a network session
- questions onstat -g