FW: Have you seen this?
Posted in 2005
Topics: Backup & Restore, Storage & Space Management, Server Administration
Anyone out
there able to answer what is happening here?
=20
=20
+ oninit -iy
oninit: Not enough room in ROOT DBspace.
Requested 180638K, ONCONFIG value 'ROOTSIZE' 100000K.
oninit: Fatal error in shared memory initialization
=20
The Tech Svcs store restore process executes oninit -iy to initialize
the database prior to ontape -r. The ontape failed to restore the DB
after the oninit error. All config files on the box define rootsize at
100000K or less. Any idea what is requesting 180638K?
=20
I ran ontape -r and the database restored without issue. So this is
just a follow up root cause analysis.
=20
Thanks,
Kate Tomchik
Kate-
Check your LOGFILES parameter in your onconfig. It's probably
something like 150 (a wild guess from the size it requested), but your
rootdbs only has room for a smaller number. When oninit -i is run it
looks at that onconfig parameter and tries to create that many logs in
rootdbs. I'm assuming your logs don't ordinarily live ther. Also
unless your using cooked files (maybe you're on Windoze), there should
be no reason to run oninit -i before your restore. The ontape -r will
just write over the old structures and recreate them anyway.
If you do need to run the oninit -i, try noting down the
LOGFILES parameter and changing it back to the default of 6. Then run
your restore and change the parameter back to what it was. Best
practice, however is to not run oninit -i unless you really need to.
--EEM
> -----Original Message-----
> From: Tomchik, Kate [mailto:Kate_Tomchik@homedepot.com]
> Sent: Friday, July 15, 2005 3:26 PM
> To: ids@iiug.org
> Subject: FW: Have you seen this? [5447]
>
> Anyone out there able to answer what is happening here?
> =20
> =20
> + oninit -iy
> oninit: Not enough room in ROOT DBspace.
> Requested 180638K, ONCONFIG value 'ROOTSIZE' 100000K.
> oninit: Fatal error in shared memory initialization
>
> =20
> The Tech Svcs store restore process executes oninit -iy to initialize
> the database prior to ontape -r. The ontape failed to restore the DB
> after the oninit error. All config files on the box define rootsize
at
> 100000K or less. Any idea what is requesting 180638K?
> =20
> I ran ontape -r and the database restored without issue. So this is
> just a follow up root cause analysis.
> =20
> Thanks,
> Kate Tomchik
>
It cleary states what the error is :
" Requested 180638K, ONCONFIG value 'ROOTSIZE' 100000K "
Do you still need help ?
Ravi Thero.
Everett Mills <eemills@nationalbeef.com> wrote:
Kate-
Check your LOGFILES parameter in your onconfig. It's probably
something like 150 (a wild guess from the size it requested), but your
rootdbs only has room for a smaller number. When oninit -i is run it
looks at that onconfig parameter and tries to create that many logs in
rootdbs. I'm assuming your logs don't ordinarily live ther. Also
unless your using cooked files (maybe you're on Windoze), there should
be no reason to run oninit -i before your restore. The ontape -r will
just write over the old structures and recreate them anyway.
If you do need to run the oninit -i, try noting down the
LOGFILES parameter and changing it back to the default of 6. Then run
your restore and change the parameter back to what it was. Best
practice, however is to not run oninit -i unless you really need to.
--EEM
> -----Original Message-----
> From: Tomchik, Kate [mailto:Kate_Tomchik@homedepot.com]
> Sent: Friday, July 15, 2005 3:26 PM
> To: ids@iiug.org
> Subject: FW: Have you seen this? [5447]
>
> Anyone out there able to answer what is happening here?
> =20
> =20
> + oninit -iy
> oninit: Not enough room in ROOT DBspace.
> Requested 180638K, ONCONFIG value 'ROOTSIZE' 100000K.
> oninit: Fatal error in shared memory initialization
>
> =20
> The Tech Svcs store restore process executes oninit -iy to initialize
> the database prior to ontape -r. The ontape failed to restore the DB
> after the oninit error. All config files on the box define rootsize
at
> 100000K or less. Any idea what is requesting 180638K?
> =20
> I ran ontape -r and the database restored without issue. So this is
> just a follow up root cause analysis.
> =20
> Thanks,
> Kate Tomchik
>
__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com
Check out the Physical Log as well.
Onconfig parameter - PHYSFILE
HTH,
Zev Berezin
Date sent: Fri, 15 Jul 2005 16:54:42 -0400 (EDT)
To: ids@iiug.org
From: "Everett Mills" <eemills@nationalbeef.com>
Subject: RE: Have you seen this? [5448]
> Kate-
> Check your LOGFILES parameter in your onconfig. It's probably
> something like 150 (a wild guess from the size it requested), but your
> rootdbs only has room for a smaller number. When oninit -i is run it
> looks at that onconfig parameter and tries to create that many logs in
> rootdbs. I'm assuming your logs don't ordinarily live ther. Also
> unless your using cooked files (maybe you're on Windoze), there should
> be no reason to run oninit -i before your restore. The ontape -r will
> just write over the old structures and recreate them anyway.
> If you do need to run the oninit -i, try noting down the
> LOGFILES parameter and changing it back to the default of 6. Then run
> your restore and change the parameter back to what it was. Best
> practice, however is to not run oninit -i unless you really need to.
>
> --EEM
>
> > -----Original Message-----
> > From: Tomchik, Kate [mailto:Kate_Tomchik@homedepot.com]
> > Sent: Friday, July 15, 2005 3:26 PM
> > To: ids@iiug.org
> > Subject: FW: Have you seen this? [5447]
> >
> > Anyone out there able to answer what is happening here?
> > =20
> > =20
> > + oninit -iy
> > oninit: Not enough room in ROOT DBspace.
> > Requested 180638K, ONCONFIG value 'ROOTSIZE' 100000K.
> > oninit: Fatal error in shared memory initialization
> >
> > =20
> > The Tech Svcs store restore process executes oninit -iy to initialize
> > the database prior to ontape -r. The ontape failed to restore the DB
> > after the oninit error. All config files on the box define rootsize
> at
> > 100000K or less. Any idea what is requesting 180638K?
> > =20
> > I ran ontape -r and the database restored without issue. So this is
> > just a follow up root cause analysis.
> > =20
> > Thanks,
> > Kate Tomchik
> >
>
>
>
>