HPL and ER. Informix Case# 938796
Posted in 2000
Background information.
We were running 7.30.uc6 on 3 servers running replication, update anywhere,
on them.
We used HPL to load with the following command :
onpload -p load_cc -m load_cc -d load_cc -falcN -l onpload.`date
+%m%d%H%M%S`
This would allow us to load data in deluxe mode and not replicate.
This worked fine.
Current Scenerio.
We upgraded to 7.31.uc5 on the 3 servers.
If I attempt to run the onpload command before any ER transactions it works
fine.
After any replication has taken place HPL fails with the following message.
Tue Feb 29 14:51:10 2000
SHMBASE 0x30000000CLIENTNUM 0x49010000
Session ID 40
Load Database -> class
Load Table -> S_cc
Device Array -> load_cc
Record Mapping -> load_cc
Cannot start violations table for 'S_cc', SQL error -242, ISAM error -106
Cannot set mode of indexes objects '"informix".ui_ns_inv2,
"informix".ui_ns_cc2' to enabled mode,
SQL error -242, ISAM error 0
Cannot set mode of constraints objects '"informix".pk_s_cc2' to enabled
mode,
SQL error -242, ISAM error 0
Cannot re-enable all objects, 0 violations detected,
check for violations in violations table ''
and diagnostics table ''
Database Load Completed -- Processed 0 Records
Records Inserted-> 0
Detected Errors--> 0
Engine Rejected--> 0
Tue Feb 29 14:51:11 2000