Re: ODBC Informix SE 7.23
Posted in 2003
Topics: Installation, Setup & Upgrades, Connectivity: ODBC / JDBC / .NET, Platform-Specific Issues
Chad Lemmen <chad@lemmen.com> wrote:
> I have Informix SE 7.23 on a SCO OpenServer 5.0.5 server and I'm trying to
> connect to this database from a client running Linux kernel version 2.4.2.
> On the Linux box I have installed IBM Informix Client Software Development
> Kit csdk-2.80.UC2-1 and unixODBC 2.2.5.
> When I run the demo program dbcreate I get this:
> $ /opt/informix/demo/cli/dbcreate
> Using default DSN : odbc_demo
> STEP 1 done...connected to database server
> STEP 2 done...Database Version -- 07.23.0000 UC13
> Creating non-UDO database
> Executing stmt 1
> ERROR: -554: HY000 : [Informix][Informix ODBC Driver][Informix]Syntax disallowe
> d in this database server.
> Error in Step 3 -- SQLExecDirect failed
I talked with IBM support and they told me that I need to get at least
SE version 7.25 for this to work. The problem is that it seems almost
impossible to get this. I've talked to several people at IBM and just
keep getting passed off to someone else, my calls and emails don't get
returned either. I've done some internet searches and can't find anyone
that sells SE. It seems like IBM is trying to phase out Informix. Does
anyone have SE version 7.25 that they would sell me so that I can upgrade
my SE version 7.23. Is 7.25 the latest version of SE?
I have 7.24 SE for SCO Unix and 7.25 for Unixware. Also 7.25 exist for
Linux and
is available (I belive) from iiug. You could also consider moving up to
IDS Workgroup edition (SCO or not) and leave connectivity problems behind.
E-mail me if you need more info (remove NO SPAM) from the address.
Best Regards,
Michael
Chad Lemmen wrote:
>Chad Lemmen <chad@lemmen.com> wrote:
>
>
>
>>I have Informix SE 7.23 on a SCO OpenServer 5.0.5 server and I'm trying to
>>connect to this database from a client running Linux kernel version 2.4.2.
>>On the Linux box I have installed IBM Informix Client Software Development
>>Kit csdk-2.80.UC2-1 and unixODBC 2.2.5.
>>
>>
>
>
>
>>When I run the demo program dbcreate I get this:
>>
>>
>
>
>
>>$ /opt/informix/demo/cli/dbcreate>>
>>
>
>
>
>>Using default DSN : odbc_demo
>>STEP 1 done...connected to database server
>>STEP 2 done...Database Version -- 07.23.0000 UC13
>>Creating non-UDO database
>>Executing stmt 1
>>ERROR: -554: HY000 : [Informix][Informix ODBC Driver][Informix]Syntax disallowe
>>d in this database server.
>>Error in Step 3 -- SQLExecDirect failed
>>
>>
>
>
>I talked with IBM support and they told me that I need to get at least
>SE version 7.25 for this to work. The problem is that it seems almost
>impossible to get this. I've talked to several people at IBM and just
>keep getting passed off to someone else, my calls and emails don't get
>returned either. I've done some internet searches and can't find anyone
>that sells SE. It seems like IBM is trying to phase out Informix. Does
>anyone have SE version 7.25 that they would sell me so that I can upgrade
>my SE version 7.23. Is 7.25 the latest version of SE?
>
>