Sysadmin Database Errors
Posted in 2009
Topics: Installation, Setup & Upgrades, Storage & Space Management, Error Codes & Troubleshooting, Platform-Specific Issues
I was not at this particular client when they upgraded to 11.0 (now at 11.5.FC5, AIX 5.3); however, these errors continuously show up in their online.log: 01:00:00 SCHAPI: Error -214 Cannot remove file for table (informix.aus_command). 01:00:00 SCHAPI: Error -710 Table (informix.aus_command) has been dropped, altered or renamed. 01:00:00 SCHAPI: Type: TASK, Name: Auto Update Statistics Evaluation, Location: NULL. 01:00:00 SCHAPI: Type: TASK, Name: Auto Update Statistics Refresh, Location: NULL. 01:00:00 SCHAPI: Error -106 ISAM error: non-exclusive access. 01:00:00 SCHAPI: Type: TASK, Name: Auto Update Statistics Evaluation, Location: NULL. 01:00:00 SCHAPI: Type: TASK, Name: Auto Update Statistics Evaluation, Error Message: Unable to execute function [ aus_evaluator(integer,integer) ] . 01:00:00 SCHAPI: Type: TASK, Name: Auto Update Statistics Refresh, Error Message: Unable to execute function [ aus_refresh_stats(integer,integer) ] . 01:00:01 SCHAPI: Error -710 Table (informix.aus_command) has been dropped, altered or renamed. 01:00:01 SCHAPI: Type: TASK, Name: Auto Update Statistics Refresh, Location: NULL. 01:00:01 SCHAPI: Type: TASK, Name: Auto Update Statistics Refresh, Error Message: Unable to execute function [ aus_refresh_stats(integer,integer) ] . I just read where this database should never be dropped or altered; however, would a reset of this database clean up these issues? Is it possible to reset this database into the same dbspace where it currently exists? Thanks in advance. Clifton _________________________________________________________________ Hotmail: Trusted email with Microsofts powerful SPAM protection. http://clk.atdmt.com/GBL/go/177141664/direct/01/
Upgrades from pre-11.10 engines to early 11.10 releases often had problems
with the copy of sysadmin that was installed during the upgrade. Here are
the steps to rebuilt sysadmin without restarting the engine (you can always
just drop the database - after saving any site specific data first - and
bounce the instance. The engine will rebuilt sysadmin automatically on
startup if it is not there:
Here is an example of rebuild sysadmin database manually:
1. cd$INFORMIXDIR/etc/sysadmin
2. dbaccess -db_create.sql
3. dbaccess sysadmindb_install.sql
4. dbaccess sysadminsch_tasks.sql
5. dbaccess sysadminsch_aus.sql
6. dbaccess sysadminsch_sqlcap.sql
7. dbaccess sysadminstart.sql
If you encountered any problem during above mentioned process, restartingIDS
automatically rebuild sysadmin database.Considering
'$INFORMIX/etc/sysadmin/stop' file is not exists.
Art
Art S. Kagel
Oninit (www.oninit.com)
IIUG Board of Directors (art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Oninit, the IIUG, nor any other organization
with which I am associated either explicitly or implicitly. Neither do
those opinions reflect those of other individuals affiliated with any entity
with which I am affiliated nor those of the entities themselves.
On Wed, Oct 14, 2009 at 2:55 PM, Clifton Bean <clifton_bean@hotmail.com>wrote:
> I was not at this particular client when they upgraded to 11.0 (now at
> 11.5.FC5, AIX 5.3); however, these errors continuously show up in their
> online.log:
>
> 01:00:00 SCHAPI: Error -214 Cannot remove file for table
> (informix.aus_command).
> 01:00:00 SCHAPI: Error -710 Table (informix.aus_command) has been dropped,
> altered or renamed.
> 01:00:00 SCHAPI: Type: TASK, Name: Auto Update Statistics Evaluation,
> Location: NULL.
> 01:00:00 SCHAPI: Type: TASK, Name: Auto Update Statistics Refresh,
> Location:
> NULL.
> 01:00:00 SCHAPI: Error -106 ISAM error: non-exclusive access.
> 01:00:00 SCHAPI: Type: TASK, Name: Auto Update Statistics Evaluation,
> Location: NULL.
> 01:00:00 SCHAPI: Type: TASK, Name: Auto Update Statistics Evaluation, Error
> Message: Unable to execute function [ aus_evaluator(integer,integer) ] .
> 01:00:00 SCHAPI: Type: TASK, Name: Auto Update Statistics Refresh, Error
> Message: Unable to execute function [ aus_refresh_stats(integer,integer) ]
> .
> 01:00:01 SCHAPI: Error -710 Table (informix.aus_command) has been dropped,
> altered or renamed.
> 01:00:01 SCHAPI: Type: TASK, Name: Auto Update Statistics Refresh,
> Location:
> NULL.
> 01:00:01 SCHAPI: Type: TASK, Name: Auto Update Statistics Refresh, Error
> Message: Unable to execute function [ aus_refresh_stats(integer,integer) ]
> .
>
> I just read where this database should never be dropped or altered;
> however,
> would a reset of this database clean up these issues?
>
> Is it possible to reset this database into the same dbspace where it
> currently
> exists?
>
> Thanks in advance.
>
> Clifton
>
> _________________________________________________________________
> Hotmail: Trusted email with Microsofts powerful SPAM protection.
> http://clk.atdmt.com/GBL/go/177141664/direct/01/
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--0015175d046c4048710475e9d112