Hi all,
I'm having an ongoing encounter with an error that I have not yet been able to
resolve. The error itself is -254, which is "Too many or too few host varibles
given". The error text goes onto explain that this problem occurs when using
question marks as variable place-holders for sql statements to be prepared.
The puzzling part is that this error occurs on an INSERT that is done directly
with no preparing!?! I take this to mean that there is some other problem and
that internally informix is confused about what that problem is (in otherwords,
an informix bug). Has anyone else run across this or similar problems? The
only clue I have to date relates to table locking...
When a user is updating a specific record, we first lock only that record (at
least we try to lock just that record...indiviual record locking is another
matter where we have had only limited success...somtimes the entire table ends
up locked). It appears that this error (-254) happens when the table becomes
locked by another user. Not every time, just sometimes...
Any help would be appreciated.
Thanks in advance,
Chris S.