On-Bar / Legato question
Posted in 2000
Topics: Installation, Setup & Upgrades
Hi all! I am trying to install the Legato module for Informix to work with On-Bar, and I have succesfully been able to backup and restore an instance. My next test is to backup an instance from one server, and restore it onto another instance. Can anyone point me to a step-by-step document on how to best achieve this? I have already tried putting the ixbar.SERVERNUM file in place, as well as the oncfg_SERVERNAME.SERVERNUM file in place (thanks to a fellow listmember, Clifton Bean - "you are the man!!!"), but still can't get the restore to work. I have also ensured that there are links to all of the needed filesystems. Any help would be greatly appreciated Thanks in advance, Sean sean.murphy@banctec.com murphy.sean@gte.net
On your Secondary instance set up links to the chunks, exactly as in your
primary instance.
Note the following Legato variables your Primary instance uses to backup
it's database :
-------------------------
NSR_DATA_VOLUME_POOL
NSR_LOG_VOLUME_POOL
NSR_SERVER
NSR_CLIENT
Back up your primary instance using onbar -b -L 0.
After the backup finishes, the following files need to be ftp'ed to your
machine where your secondary instance will reside. The files are located in
the $INFORMIXDIR/etc directory of your primary instance and need to go into
the $INFORMIXDIR/etc directory of your secondary instance :
$ONCONFIG
oncfg_{instance name}.{server num}
ixbar.{instance num}
Log onto your secondary instance and set the Legato variables above to
exactly what you primary server uses.
Then issue onbar -r.
I get some error messages in my bar activity log during the restore, but the
restore works :
------------------------------------------------------------------
2000-07-14 11:14:43 10181 10180 /informix/DEV/bin/onbar_d -r
2000-07-14 11:14:43 10181 10180 WARNING: BAR_BSALIB_PATH is undefined;
trying default path.
2000-07-14 11:14:44 10181 10180 ERROR: Unable to start logical log
salvage: .
2000-07-14 11:15:01 10181 10180 Successfully connected to Storage Manager.
2000-07-14 11:15:49 10181 10180 Begin cold level 0 restore rootdbs.
2000-07-14 11:16:07 10181 10180 Completed cold level 0 restore rootdbs.
2000-07-14 11:16:11 10181 10180 Successfully connected to Storage Manager.
2000-07-14 11:16:39 10181 10180 Begin restore logical log 9.
2000-07-14 11:16:39 10181 10180 XBSA Error (BSAEndData):
A system error occurred. Aborting XBSA session.
2000-07-14 11:16:39 10181 10180 Completed restore logical log 9.
"Sean Murphy" <murphy.sean@gte.net> wrote in message
news:3975EDC4.B5FEEE3D@gte.net...
>
> Hi all!
>
> I am trying to install the Legato module for Informix to work with
> On-Bar, and I have succesfully been able to backup and restore an
> instance.
>
> My next test is to backup an instance from one server, and restore it
> onto another instance.
>
> Can anyone point me to a step-by-step document on how to best achieve
> this? I have already tried putting the ixbar.SERVERNUM file in place, as
> well as the oncfg_SERVERNAME.SERVERNUM file in place (thanks to a fellow
> listmember, Clifton Bean - "you are the man!!!"), but still can't get
> the restore to work. I have also ensured that there are links to all of
> the needed filesystems.
>
>
> Any help would be greatly appreciated
>
> Thanks in advance,
>
> Sean
>
> sean.murphy@banctec.com
> murphy.sean@gte.net
>