Re: Dbexport failure
Posted in 2004
This is a multipart message in MIME format.
--=_alternative 0077BB0786256E93_=
Content-Type: text/plain; charset="US-ASCII"
Thanks folks for your responses.
We don't use the environment variables suggested by Savio, and I do not
have a separate dbspace for indexes. I purchased more ram and will be
installing it this weekend. I think there is a definite problem with lack
of it, as I changed one of our previous failing very long-running nightly
processes so that it would use an odbc connection to the db instead of
shared memory. It now runs successfully. I'll let you know if the dbexport
on Saturday still doesn't work.
Thanks much.
C Geier
System Admin/IS support
St. Paul, MN
(The Holy Bible, Proverbs 3:13-17)
roeferr@ig.com.br (Ferronato)
Sent by: owner-informix-list@iiug.org
05/13/2004 02:04 PM
Please respond to
roeferr@ig.com.br (Ferronato)
To
informix-list@iiug.org
cc
Subject
Re: Dbexport failure
Hi all,
TO Savio Pinto: voce fala portugues ??
Well, I use RS/6000 boxes with AIX 4.3.3 and AIX 5.2 and I had the
same problem some months ago and I discovered a bug (reported to IBM
Informix support group) and they repaired it, in recently versions of
IDS 7.31.
I now using 7.31.UD6X5 (a special patch for us, ~cause they solved
other problem - bug - with GateWay - DRDA ).
The problem was when dbschema - it runs under dbexport tool - find a
table that has the data dbspace separated of index dbspaces.
I mean:
create table1 (col1 <datatype>, col2 <datatype>, col....)
in dbspace1 extent .... next .... lock mode .... ;
create index ix1tab1 on table1 (col1, col2) in dbspace_ix ;In the newest version of IDS 7.31.UD6W8 or later as 7.31.UD7 , the
problem is solved.
Have you possibility to update uour RDBMS ?
I hope it helps you !
BR . R. Ferronato
"Savio Pinto (s)" <spinto@cap.org> wrote in message
news:<c7or5u$u0a$1@terabinaries.xmission.com>...
> This message is in MIME format. Since your mail reader does not
understand
> this format, some or all of this message may not be legible.
>
> ------_=_NextPart_001_01C436D1.F5E978C0
> Content-Type: text/plain;
> charset="iso-8859-1"
>
> were there any changes to the environment variables?, make sure
FET_BUF_SIZE
> or BIG_FET_BUF_SIZE environment variables are not set when you do a
> dbexport.
>
> i used to get some errors with dbexport on HP UX and informix 9.3, it
turned
> out that dbexport utility was sensitive to the above env variables, had
to
> unset these environment variables before doing a dbexport of the
database.
>
>
> -----Original Message-----
> From: owner-informix-list@iiug.org
[mailto:owner-informix-list@iiug.org]On
> Behalf Of CKGeier@nwc.edu
> Sent: Monday, May 10, 2004 2:14 PM
> To: informix-list@iiug.org
> Subject: Dbexport failure
>
>
>
> I tried to dbexport the database (has always run successfully in the
past
> )and received an error message.
> While looking through the dbexport.out and db.sql output files I saw the
> following information. I also saw that the dbexport.out text stopped
where
> the next statement outputted to the dbexport.out/db.sql files would have
> been a "create index" line, and the previous line it seemed possibly to
> succeed at was a "revoke all on tablename from public" statement.
> Aix 5.1
> Informix IDS 7.31 UD6
>
____________________________________________________________________________
> _
> *** Error fetching data row
>
> 408 - Invalid message type received from the sqlexec process.
>
> -404 - The cursor or statement is not available.
> -349 - Database not selected yet.
>
____________________________________________________________________________
> __
> It appears as if the process lost connection to the db or died...? and
while
> we suspect memory issues, I had just rebooted the server and it appeared
as
> if we had enough memory.
>
> C Geier
> System Admin/IS support
> St. Paul, MN
>
>
>
>
>
> ------_=_NextPart_001_01C436D1.F5E978C0
> Content-Type: text/html;
> charset="iso-8859-1"
>
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
> <HTML><HEAD>
> <META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
>
>
> <META content="MSHTML 5.50.4731.2200" name=GENERATOR></HEAD>
> <BODY>
> <DIV><SPAN class=681234220-10052004><FONT face=Arial color=#0000ff
size=2>were
> there any changes to the environment variables?, make sure FET_BUF_SIZE
or
> BIG_FET_BUF_SIZE environment variables are not set when you do a
> dbexport.</FONT></SPAN></DIV>
> <DIV><SPAN class=681234220-10052004><FONT face=Arial color=#0000ff
> size=2></FONT></SPAN> </DIV>
> <DIV><SPAN class=681234220-10052004><FONT face=Arial color=#0000ff
size=2>i used
> to get some errors with dbexport on HP UX and informix 9.3, it turned
out that
> dbexport utility was sensitive to the above env variables, had to
unset
> these environment variables before doing a dbexport of the
> database.</FONT></SPAN></DIV>
> <DIV><SPAN class=681234220-10052004><FONT face=Arial color=#0000ff
> size=2></FONT></SPAN> </DIV>
> <BLOCKQUOTE>
> <DIV class=OutlookMessageHeader dir=ltr align=left><FONT face=Tahoma
> size=2>-----Original Message-----<BR><B>From:</B>
owner-informix-list@iiug.org
> [mailto:owner-informix-list@iiug.org]<B>On Behalf Of
> </B>CKGeier@nwc.edu<BR><B>Sent:</B> Monday, May 10, 2004 2:14
PM<BR><B>To:</B>
> informix-list@iiug.org<BR><B>Subject:</B> Dbexport
> failure<BR><BR></FONT></DIV><BR><FONT face=sans-serif size=2>I tried
to
> dbexport the database (has always run successfully in the past )and
received
> an error message.</FONT><FONT size=3> </FONT><FONT face=sans-serif
> size=2><BR>While looking through the dbexport.out and db.sql output
files I
> saw the following information. I also saw that the dbexport.out text
stopped
> where the next statement outputted to the dbexport.out/db.sql files
would have
> been a "create index" line, and the previous line it seemed possibly
to
> succeed at was a "revoke all on tablename from public" statement.
<BR>Aix
> 5.1</FONT><FONT size=3> </FONT><FONT face=sans-serif
size=2><BR>Informix IDS
> 7.31 UD6</FONT><FONT size=3> </FONT><FONT face=sans-serif
>
size=2><BR>_____________________________________________________________________________</FONT><FONT
> size=3> </FONT><FONT face=sans-serif size=2><BR>*** Error fetching
data
> row</FONT><FONT size=3> <BR></FONT><FONT face=sans-serif
size=2><BR>408 -
> Invalid message type received from the sqlexec process.</FONT><FONT
size=3>
> <BR></FONT><FONT face=sans-serif size=2><BR>-404 - The cursor or
statement is
> not available.</FONT><FONT size=3> </FONT><FONT face=sans-serif
> size=2><BR>-349 - Database not selected yet.</FONT><FONT size=3>
</FONT><FONT
> face=sans-serif
>
size=2>