Informix CLI problem
Posted in 1999
Topics: Internationalization & Character Sets
Hi all, I have a problem with connecting to Informix Online 7 server using CLI 2.80 (WinNT4/SP4). While testing connection with ILogin I got -23101 error (unable to load locale categories) everytime. What values should I put in setnet32? Particularly, should CLIENT_LOCALE and DB_LOCALE be set so some values? I am trying to connect to polish database: language & territory mark is "pl_pl" and codepage is "Latin-2". Thanks in advance ---- Maciek Mastalarczuk mmastalar@zrit.lublin.tpsa.pl
I have already solved the problem. Works now. Thanks anyway. Cheers, ---- Maciek Mastalarczuk mmastalar@zrit.lublin.tpsa.pl
(1) Hi I have same problem as yours. Can you please let me know how did you resolve this problem. (2) I am also getting another error on NT machine using VB 6.0 when I use execute method of connection. I try to execute sql "SET ROLE ENGINEER" and I get informix driver error: Runtime error '-2147467259(80004005) [Intersolv][odbcInformixDriver][Informix] Can not open file 'mls2.iem' In article <37BAA262.D477ED62@zrit.lublin.tpsa.pl>, Maciej Mastalarczuk <mmastalar@zrit.lublin.tpsa.pl> wrote: > Hi all, > > I have a problem with connecting to Informix Online 7 server using CLI > 2.80 (WinNT4/SP4). While testing connection with ILogin I got -23101 > error (unable to load locale categories) everytime. What values should I > put in setnet32? Particularly, should CLIENT_LOCALE and DB_LOCALE be set > so some values? I am trying to connect to polish database: language & > territory mark is "pl_pl" and codepage is "Latin-2". > > Thanks in advance > > ---- > Maciek Mastalarczuk > mmastalar@zrit.lublin.tpsa.pl > > Sent via Deja.com http://www.deja.com/ Share what you know. Learn what you don't.
> (1) Hi I have same problem as yours. Can you please let me know how > did you resolve this problem. Hi, I just set variables CLIENT_LOCALE and DB_LOCALE in Setnet32 to "pl_pl.852" (852 is the codepage number for Latin-2 polish character set). > (2) I am also getting another error on NT machine using VB 6.0 when I > use execute method of connection. I try to execute sql "SET ROLE > ENGINEER" and I get informix driver error: > Runtime error '-2147467259(80004005) > [Intersolv][odbcInformixDriver][Informix] > Can not open file 'mls2.iem' I have no idea. I don't have mls2.iem file in my Informix-CLI directory, but still I can execute any SQL query using VB5 and MS Access Basic. The other *.iem files are located in subdirectories named as teritory marks such as "en_us" for English. If you use other locale and mls2.iem file exist in your en_us directory try to copy its (directory) contents into a folder named as your teritory mark. Regards, P.S. I don't read this newsgroup regularly, so please respond to my e-mail. ---- Maciek Mastalarczuk, mmastalar@zrit.lublin.tpsa.pl