Re: Empty onconfig file
Posted in 1999
Topics: Backup & Restore, Server Administration, Logging & Checkpoints, Jobs, Consulting & Announcements
For those who were thinking about responding, please don't.
The problem was that the backup logs were full, due to the inability
of the backups to kick in. All the errors were being recorded in the error
log, thus my logs grew. I ended up with no room/space in that file system.
This resulted in the onconfig file being wiped out... go figure!
The moral of the story, I guess, is keep an eye on your file systems,
because the most expendable thing in the search for space is the config
file :-<< I think this is rather curious?
>>> "Kudzi Muchaka" <KMuchaka@HAFresno.org> 12/27/99 11:29AM >>>
Online Version 7.23 UC1
AIX 4.3.2
RS6000 J30
I have continuous log backup going at all times. On Wed, last week I
presumed that logical log backup had been stopped, CNTRL-C. But, alas
this had not happened. Our nightly backup is done via a cronjob. We were
closed Thurs & Friday.
I checked the backups this morning and found that the backups had not
been done. Continuous backup was still going on. Stopped continuous
backup and tried manual backup. First error was "Could not write". Checked to see processes that were running. Three backup processes
had been spawned. Killed those processes (softly :->>) and tried to do a
manual backup (ontape -s). I got an error "Empty config file is not allowed"
Yes my onconfig is indeed empty!!!!!! Wow!!! HOW could this have
happened????
No, I was'nt (was not - for the purists) editing my onconfig file. And
fortunately I have my OS backup - yech. HOW does an onconfig file
suddenly become empty???? Appreciate any insights into this miracle.
TIA
-kudzi
Kudzi Muchaka wrote: > The problem was that the backup logs were full, due to the inability > of the backups to kick in. All the errors were being recorded in the error > log, thus my logs grew. I ended up with no room/space in that file system. > This resulted in the onconfig file being wiped out... go figure! > > The moral of the story, I guess, is keep an eye on your file systems, > because the most expendable thing in the search for space is the config > file :-<< I think this is rather curious? It isn't "the most expendable thing"; the onconfig file is kept open by OnLine and written back to disk when OnLine is shut down. When writing back to disk, if the disk is full, you will have this problem. Neither OnLine nor Unix will drop your files searching for space. June -- june_t@hotmail.com Back from the dead, resuscitated by Godiva chocolates... Please do not send Informix questions to this account.