IDS 12.10.FC12
Solaris 10 1/13
We have a database with a table that contains CLOBs.
How can I copy it to another Informix Server?
"SELECT * FROM <database>@<instance>:<table> INTO <new_table>" fails with an
error message that CLOBs are not supported for distributed queries.
dbexport is for databases, not tables.
onunload/onload do not support smart large objects.
How can one copy to a remote server a table that contains smart large objects?
(That is, how does one backup and restore a table containing CLOBs?)
Thank you.
DG
↪ replying to DAVID GROVE
I found that the SQL commands UNLOAD and LOAD work with CLOBs.
It is not a "one-step" solution, but is works. First, UNLOAD the table. Then,
move the resulting file to the new server. Then LOAD the new table (CREATE it
first).
I find there are several Informix features that do not work with smart large
objects. Smart Large Objects were introduced as a big deal, as I recall.
Informix was the "Object Relational Database". Etc. But, what is it, 10 years
later. Maybe more. And Informix still doesn't fully support large objects.
(Distributed queries fail. onunload/onload fail to support objects. Etc.)
DG