Threads from 2018
Browse by month: Jan · Feb · Mar · Apr · May · Jun · Jul · Aug · Sep · Oct · Nov · Dec
New releases of utils2_ak and myexport
Art Kagel <art.kagel@gmail.com> 5:36 PM (6 minutes ago) to IIUG, ids@iiug.org Folks: During December I have uploaded updated versions of myexport/myimport and of the dostats_ng.ec and myschema code in utils2_ak to my website (www.askdbmgt.com/my-utilities.html). I thought I'd k…
Number and size of chunks
Hi, I have an instance with 528 chunks running on IDS 11.70 The server is a HP-UX 11.31 with KAIO enabled and with raw devices and lvols. The disk are SAN, aprox 25 LUNs in a combination of 30, 60 and 90 GB in size. All chunks are 2 GB in size. The CLEANERS parameter is 120. I …
SQL question
Hi, I am newbie about SQL and I would like to have 2 sql statements joined on same query. The second one only execute if table exists on database, I am using shell code for it but it takes some time to get results... My code: select x0.sid, x0.username, x0.hostname, x1.sqs_dbna…
Stress over system tables
Hi, I have one server with informix 12.10.FC10, it have more than 100 databases but we only use about [20-30] concurrent connections. Anyway I verify that when I try to read system tables like syslocks or others it takes long time. Is this a problem or my configuration error? I …
load from external table whith blob
Hi! We are trying to do some table movements using external tables, but when we try to load some records from an external table with blob, we caught this error: -26214 Cannot perform this operation on an external table. script: CREATE EXTERNAL TABLE table_ext SAMEAS table USI…
Windows User Authentication
Hi all I need help with user authentication with an Informix Server 12.10.FC12 on windows 2016 server. I wonder why I do _not_ need a windows user to connect to a database on that informix server. I have granted the user, let's name him "xxx", connect to the on and only databa…
IBM Informix RFE gone?
Hi, Where we should request new features? Informix just vanishes from IBM RFE pages. There is no option to filter or submit new RFE. Regards…
Re: onmode -z doesn't work
If the instance is blocked and you are sure that it's not still rolling back after "onmode -z" or "Long Transaction Aborted": 1) get the user thread address from "onstat -u"; 2) use that to get the transaction address from "onstat -x"; 3) try terminating the transaction with "on…
retiring a result-set from regex_split function
Hi, I have a list of integers stored in a column "1,2,3,4,5,6,7". Using execute function regex_split('1,2,3,4,5', ',',) I am getting the output as below 1 2 3 4 5 I am using IDS 12.X e.g. - Column user_list has data as = 1,2,3,4,5 select name from user e inner join ( select…
Aborting long transaction doesn´t rollback tx
Hi, Today we had the following messages in the log: Aborting Long Transaction: tx: 0xc0000003d86ea0a8 username: xxx uid: nnn Next, onstat -m showed : On-Line (LONGTX) The sessions seemed to continue working normally. For example, I verified that one table inserted new records.…
User authentication /Windows
We are running Informix 11.70 on a Windows Server 2008. Connecting to the server is working from the command line interface (DBACCESS -e dbname), but when trying to connect (for example) from Server Studio (on the same Windows server) using a userid and password we get -951 : i…
Table Privileges
I have "inherited" a database, with a script somewhere, that does this crazy privilege grants on some of our tables. First question: How do I Clear the below privileges on existing tables - for example, if you look at the last 3 lines, user "sasuser" has both All and None privil…
Maximum of 16,777,215 pages per Table
What happens when you reach this limit ? maximum of 16,777,215 pages per table Does that table stop working (no more inserts allowed) .... so basically your DB "goes down" ? IDS 12 AIX 7 Dirk…
Updating onunload/onload
Hi All, I just submitted an RFE to update onunload/onload to support Blade technology, specifically the BTS blade. If you'd like to Vote it UP, here is the Info: Headline: onunload & BTS and other blades ID: 127371 Thanks, Michael Hoffman…
Locked tables over 12.10
Hi, I am having some difficulties to identify locked tables and records over my instance. I have looked over onstat -k and onstat -g opn results, but results are not very easy to understand. Can someone give some help with some code/script to identify those situations on readabl…
New release of utils2_ak
Folks: I have released an update to my utils2_ak package. The November 7, 2018 release contains a new feature in myschema to support new functionality in the .xC8 and later releases that permits one to rename system generated indexes. When a constraint is created that does not …
SQL error (-959) Assert Failed during add column
Hello we migrated to Informix version 12.10 FC11 last week and since then we can no longer create a column in tables We have a assert failed when we run "alter table ma_table add (mon_champ varchar (8));" 15:52:20 Assert Failed: No Exception Handler 15:52:20 IBM Informix Dynam…
Page Limit
I have a table reaching it's number of pages limit. Informix limit from the manual: Data pages per fragment 16,775,134 I was thinking of using the "alter fragment" option to "defrag" this table (lessen the number of pages, or "reorg" the table basically). I read that the alter…
How to copy table w/ CLOBs to another IFMX server?
IDS 12.10.FC12 Solaris 10 1/13 We have a database with a table that contains CLOBs. How can I copy it to another Informix Server? "SELECT * FROM <database>@<instance>:<table> INTO <new_table>" fails with an error message that CLOBs are not supported for distributed queries. d…
Column name using keyword.
IBM Informix Dynamic Server Version 12.10.FC8 7.1.3.45 TL03 - AIX Kernel Version I have a table already created in one of the databases with the following. create table "informix".t_table_1234 ( rowid integer, dateid varchar(8), divisionnum integer, sellingbranchnum integer…
Informix 4GE
Hey guys, Does anyone know a way to figure out what version of Informix 4gl was used to compile a 4ge? We are looking at trying to use code compiled on RHEL4 and running it on RHEL7. Does that work? Has anyone tried it? I found a note that said you could use compiled code from …
Take Primary and RSS down and up, w/o reinitialize
IDS 12.10.FC12 Solaris 10 1/13 Consider an RSS setup with a primary and one RSS. Suppose I want to take both the primary and the RSS offline to do a little sork. Then, I want to bring them both back online without losing replication. (That is, without having to re-initialize rep…
output from onstat -x
Hi all onstat -x shows the running transactions. What does the following output mean? See the decreasing negative times at the end of the rows and the increasing number of locks. Also the flags (A-B----). What is implied? Are we running in a Long Transaction? B40DBS0S-db1:/home…
Informix 12 with Online replication
Hi We have db server running IDS 12 on RH7.5 in VMWare in HQ Data Centre. There is a requirement to do online replication to DRC which was located 300km from the DC HQ. Online replication mean any data been update/modify/add in HQ DC will be sync against DRC. At the moment we o…
Re: IDS 12.10 - temporary dbspaces locked
If temporary dbspace operations are a bottleneck for that server workload, then yes, using a ram disk will speed up things. I have not done it in production, but the following articles may be of help: https://www.oninitgroup.com/ram-disk-and-informix http://www-01.ibm.com/suppo…
Set tables in memory
Hi, I work with Informix Server and I'm looking for a way to put some tables of much use in memory and I found this syntax in an old document: set table <table> memory_resident When I executed i get: Memory resident status changed But in manuals of 11.70 and 12.10 I didn't fo…
Informix Enterprise gateway Manager
Good evening to everybody, IHAC who claims that since he upgraded to ORACLE12 from ORACLE10, Informix Enterprise gateway Manager 7.31 is not working. Configuration: Informix Dynamic Server 11.50 (32 bits) running on RedHAt Linux 6.9 (64 bits). The question is: Does IEGM 7.31…
IDS 12.10 - temporary dbspaces locked
Hi, I have repaired that my systems have several locks over temporary dbspaces on syslocks. I have seen some information about using RAMDISK to improve performance. Can somebody give some help about this? How to do it and if it is the case, how can I detect that kind of concurre…
IDS 11.70 - Archive detects that page is corrupt
Hi, Our database have error during backup. we find this message on af file. Archive detects that page 11:2897308 is corrupt. 22:22:41 IBM Informix Dynamic Server Version 11.70.FC1 Software Serial Number AAA#B000000 22:22:41 Assert Warning: Archive detects that page 11:2897308…
ONMODE -Y on the client side
Hi everyone, I'm interesting on making a script who emules the "onmode -Y" for one sessión, but just in a machine which has only installed the IDS client(Version 12.10). Does anyone know how to do it? Best regards.…
Table extents differences on recreate
When I recreate a table using the 'create table....as select from...' syntax, the new table gets created with the extent size/next size of 16/16. The original table has 13 extents, however, the new table is in 2 extents. This would not surprise me if the original table was small.…
Replication (RSS) instance it not coming up
Hi All, I an new to the Informix anf getting below error. Please help IDS version : 12.1 OS : SUSE Linux Host Name : Server1 Server1 is hosting 17 informix RSS replication instance. we have create 1 replication instance around 1 month back. it was running fine. On one file day …
RAID10 vs RAID60
I am working with my network team to replace some 5+ year old hardware for my Informix/Webserver environment. We are running IDS 12.10 on SLES 11 in a virtual (VMWare) environment. Our dbspace is approximately 250GB and accessed pretty heavily from a cluster of load balanced Apac…
Where Did the Doc Go?
Folks, All of my links to IBMs knowledge base where they kept the Informix family documentation now come up as empty pages. Can someone please point me to the doc set? thanx, dan…
Activate RSS Encryption?
IDS 12.10.FC12 Solaris 10 1/13 What is the specific procedure (sequence of events) to activate encryption between a primary and an RSS? I believe one need only set the ENCRYPT_SMX parameter. I think it needs to be set on both ends (but don't know for sure). I don't know if the …
Backup mode
Hi, Quick question partly to satisfy my curiosity and also to make sure we cover all bases: could anyone explain what "backup mode" means in the context of return code 3 from "onstat -"? It does not appear to be documented or mentioned elsewhere. As in: https://www.ibm.com/supp…
High CPU Utilization
We have two environments which are the "same" that are both running Informix 12.10. The databases are replicated. One of the servers is experiencing extremely high cpu utilization. The cpu utilization started to increase in the middle of September. It is now nearly running at cap…
Archecker problems
Hi, I'm trying to restore a table into a temporary table, but i'm having one error, and i can not find information about it. This is the log: STATUS: Arguments [-bdvs -X -f file.cmd] STATUS: AC_STORAGE /tmp STATUS: AC_MSGPATH /tmp/ac_msg.log STATUS: AC_VERBOSE on STATUS: AC_TA…
onsocssl problem
Hi, I am trying to test SSL connection over informix, I have create the certificate: gsk8capicmd_64 -keydb -create -db $INFORMIXDIR/ssl/$SERVER_NAME.kdb -pw $MYPASSWORD -type cms -stash gsk8capicmd_64 -cert -create -db $INFORMIXDIR/ssl/$SERVER_NAME.kdb -pw ${MYPASSWORD} -label $…
listener-thread: err = -951
Good Day , IDS 11.7FC8 HP-UX 11.31 We have set up a completely new server(hardware&OS) and installed IDS 11.7FC8. When the users try to log on we get the following error in the online.log: " listener-thread: err = -951: oserr = 0: errstr = user@server : Incorrect password or u…
IBM Data Server Provider for .NET HDR Failover
We are using the IBM Data Server Provider for .NET with our Windows client applications and are trying to configure it to use the Connection Manager to handle auto fail-over when our primary goes down. With the Informix .Net Provider one may configure a fail-over server group na…
blocked records
Hi, I have frequent problems with locked tables, the curious is that on onstat -u don't show any locks and over syslocks don't find useful information. How can I identify what and who is locked on my databases (table, record and session). Thanks for any help, SP…
Where do errors go when archive fails?
When an archive fails, is this the only thing that happens? In our message log, I am seeing: Archive on rootdbs,physdbs,logdbs1,logdbs2,appdbs2 ABORTED. Aborted by client. I "think" our backup volume is running out of space and causing the backup to fail. Are there any other lo…
How to speed up a query using function and indexin
Good Morning, I need to speed up this query: set isolation to dirty read; SELECT NVL(hr_dati1, '---'), NVL(cm_t_stoc, -1) as type, LPAD(cm_mod,3, 0)||LPAD(cm_col,3, 0) as coord, NVL(cm_segmento, 0) as seg, NVL(cm_lres, 0) FROM informix.artind, informix.coordman LEFT OUTER JOIN i…
ontape restore problem
A customer want to restore the data from the tape, the date of backup file is about 2002. and No one remember the informix version, How to know the informix version from the backup file? thanks for your help.…
201 Syntax Error
Does anyone know what the 2 does in this code or where my syntax error issue is coming from? I'm trying to figure out where the syntax error is. I ran the code directly with dbaccess, and it doesn't mention any issues. Here is the code: #!/bin/ksh . /home/informix/informix.env …
Updatable Secondary (RSS)
Informix 12.10.C3 Solaris 10 1/13 I would like to make a read-only RSS updatable, so I can do a dbexport. I have done this in the past. However, this time, I can't seem to make it updatable. I do the following: 1) Take the read-only RSS offline. 2) Edit UPDATABLE_SECONDARY par…
how to change the default location of rootdbs
I have installed innovator-c 11.7 with default settings. when I do onstat -d /usr1/Informix/ol_informix1170/dbspaces/rootdbs /usr1/Informix/ol_informix1170/dbspaces/plogdbs /usr1/Informix/ol_informix1170/dbspaces/llogdbs /usr1/Informix/ol_informix1170/dbspaces/datadbs /usr1/Infor…
How does "Server Generated" differ from NULL?
IDS 12.10.FC3 Solaris 10 1/13 A table in our production system has a SERIAL column. So, I think it can't be NULL. But, if I execute the following: "SELECT * FROM <table> WHERE <serial_col> IS NULL, I get a couple thousand rows in which that column seems, effectively, to be NULL.…
Cannot find source of email in Informix
We took over an existing Informix 12 instance. The logs are showing an email is being sent out after an update statistics job runs through a cronjob. I had a look at the script in the cronjob, and nothing is in there. Where would the configuration be for such a thing?…
rootdbs full
Hi, I have rootdbs full with sysmaster, only 4% free. There is anything I can clean? Or I have to increase rootdbs size? Informix version 12.10.FC10, OS CentOS 7 Thanks for any help, SP…
Problem connecting to database
HP-UX 11.31 on PA-RISC (I know, dead-end hardware) Informix 11.50.FC6 (I know, EOL) Genero 2.50.46 (I know, needs to be upgraded) Our application received number a -908 Attempt to connect to database server (servername) failed, followed by a reason -107 ISAM error: record is loc…
Users using temporary dbspaces
Hi, I need to know a list of users who are using a temporary dbspace in a moment. I have tried with combination of "onstats" and a SMI's sentences, but i can't find the way to do it, if it is possible...Can anyone help me? Regards…
HCL Informix vs. IBM Informix
I'm just mildly unclear on what is happening with Informix. Is IBM in process of slow-motion divestment? I now see a mix of references to the product. For example, for AWS, I see "HCL Informix". Also, tech support comes from HCL. But, I still see references to "IBM Informix". …
Moving a file from one server to another server
Hi, i m trying to code a stored procedure in informix, from which i m trying to move a file from a directory from one server to a directory on another server. Is there any built in functionality in informix which i can use in my stored procedure. or is there any other techniqu…
informixHQ dead?
Hi, I am developing over customers several HDR solutions, in the past I used OAT for management and also give some visual environment. As OAT was stopped, I start using informixHQ that also seems dead now [all links off]. There is other tool for management similar to these ones?…
dbschema UNIX to LINUX
Hi, We are running Informix 12.10.FC9W1 on Solaris. I am trying to get all the DB objects, tables, permissions indexes, stored procedures, functions, triggers, synonyms, sequences etc... from an Informix server on Solaris and recreate all the objects for a DB on an Informix serv…
dbspace limitation innnovator-c 12.10
Help, Is there a dbspace limitation of 8GB on innovator-c 12.10? I was able to create dspace of 10 GB but will problem arise once past 8GB? I was told that innovator-c 17.7 does not have this limitation. I was told that innovator-c 12.10 has 8GB dbspace limitation. The database…
dbexport lock question
IDS 12.10.FC3 Solaris 10 1/13 I attempted to use dbexport to get an ASCII dump of a database from an RSS. (I first set STOP_APPLY to 1.) I executed 'dbexport -ss <database>'. About 50 minutes into the export, dbexport crashed. Here is 'tail' of the dbexport.out: informix@ifmx-p…
email to/from this group working?
It seems there some problem with the email for ids@iiug.org forum. As my attempt to email the forum never got there and I didn't get a bounce message. Also since July sometime the emails from the forum have been few and far between, but if I log onto the web interface I see lots…
what is happing with InformixHQ
I was going to install InformixHq to replace our OAT install, but when I went to the link I had for the downloads I get file not found errors. And the github site has message about under review for business and legal reasons. John David Adamski, Sr. Network Specialist Graceland …
systemd centos7
Hi All, we configured systemd on CentOs7 to start and stop informix server 12.10.FC10. Im not sure of the type of the service so I tried oneshot, simple and forking. Informix starts in all cases. I see no difference. But we have an issue: If starting informix via systemd, the …
How to DROP unlogged table on RSS?
IDS 12.10.FC3 Solaris 10 1/13 I have an unlogged table in an RSS. I would like to DROP it. But, I cannot access it to DROP it. I can see it in Server Studio and dbAccess, but cannot execute a DROP TABLE command on it (because it is inaccessible because it is raw). I have alread…
Using BSON without utf8 as charset.
I am trying to use BSON/JSON functionality with a database set to de_de.8859-1 as locale. When converting a row to BSON like this: SELECT genbson(testing) from testing; I do get "9660: The database server operation failed due to an invalid JSON document." as soon as I do have u…
12.10.FC11 GRIPE & WHINE
12.10.FC11 Solaris 10 1/13 We upgraded from FC3 to FC11. One of our SPLS broke as a result. Opened tech support case. Tech support informed us that a feature added in 12.10.XC6 causes some multi-table, ANSI notation JOINS to fail. Tech support supplied an ONCONFIG parameter (SQ…
Convert BSON to real JSON
Hi there, I am evaluating the BSON data types in informix and want to process the data further in my application. Sadly a query like this select first 1 genbson( ROW(some_date), 1, 1 )::json from some_table results in: {"some_date":ISODate("1980-07-18T00:00:00.000Z")} Is the…
SQL Plan Management in Informix
Are there any SQL plan management like SQL Baseline in Oracle for Informix?…
25582 error on high volume of short live trans
Hi IIUG, Trying to find why my DB blows up to high CPU. it has 62 physical cores (x4 smt) on AIX machine P8 running 11.70 IDS. We are getting -25582 error after putting significant load of transactions. The volume of transactions is big but short live. Here's the config below:…
IIUG discussion forums?
Hi, I get emailed messages from various discussion forums on IIUG. A month or two back we were asked to confirm our email address due to system changes (?) or something. Since then the volume of messages has dropped to almost nothing, previously it was really quite busy. I was j…
Informix CSDK- End of Support
I would like to know the End of Support date for Informix CSDK 3.70xC5 specifically. In general, a link to End of Support dates for Informix Servers and Tools would be helpful…
Letters in SQL Flipping When Using Java
I have an odd situation. I have an HP_UX 11.31 Server with 12.10FC6 IDS on it and suddenly one of my users is reporting 217 errors (column not found). Looked at the error message he receives and it shows the letters "Q" and "A" are sometimes flipping. So a column named "Stat_mark…
onrestorept vs. onmode -b?
IDS 12.10.FC3 Solaris 10 1/13 I am preparing to do an in-place upgrade from 12.10.FC3 to 12.10.FC11. (I have completely separate directories for existing 12.10.FC3 and the new 12.10.FC11.) In the event of a failed upgrade, is "onrestorept" the recommended first line of attack? …
Ideal chunk auto extend size
Hello all! I'm playing with the idea of setting up chunk/dbspace auto extend, and I was wondering about a few things: Keeping in mind that Informix has a global auto extend policy, I was wondering: 1. What's the ideal starting size for an extendable chunk? 2. What's the ideal …
Fix oncheck -pT WARNING messages?
IDS 12.10.FC3 Solaris 10 1/13 This thread follows from a previous thread: http://members.iiug.org/forums/ids/index.cgi/read/41114 in which there was an issue of Server Studio space usage reporting that I didn't understand, and output of oncheck -pT that I also didn't understan…
Where to download OAT?
I've tried searching the DeveloperWorks website, as well as doing a Google search, looking for Informix OAT. All that I can find is documents on how to use it or how to do various tasks within it, but I can't find where to download it. Does anyone have the address of the current …
Chunks are changing ownership to root disk
We are on Informix 12.10FC10. We have a primary and HDR setup to a secondary. When we patched last night and rebooted the two servers, the secondary came back up with all the chunks changing to root disk. It happened to us a few weeks ago, also, when we wanted to make a few chan…
log usage difference insert vs update
I created a table as: create table t1(c char(5120)); loaded a file of about 5 thousand lines (on average string of 25 bytes). It consumed around 5MB log space. But if i update these records update t1 set c=c||c where 1=1; then log space consumption is around 1.15 MB (roughly 23%)…
12.10.xC12
An "IBM My Notifications" email was in my inbox this morning: it looks like 12.10.xC12 has popped up on Passport Advantage in the last few days. It's not on Fix Central yet. Fix information: http://www-01.ibm.com/support/docview.wss?uid=ibm10717445 What's new: http://informix.h…
Bufferpool configuration
Hi informix community, on a SPARC M10-1 Server we have a informix 12.10FC10 instance. Currently this instace use a buffer pool with around 7GB. Now i have the chance to configure the buffers up to 40GB. I would like to use the following configuration of the buffer pool: BUFFER…
Versioning or IDE of some kind?
Some of our developers are asking whether there is an SPL versioning tool for Informix. Or some kind of IDE like thing that would provide convenient version control of individual SPLs. I am aware of Sentinel Server. Are there others? Thank you. DG…
ifxjdbcx.jar
Anybody knows what happened to ifxjdbcx.jar file since 4.10.JC8? JDBC installation since JC8 does not include this file. However, it is still present in documentation: http://informix.hcldoc.com/help/topic/com.ibm.jdbc.doc/ids_jdbc_027.htm?resultof =%22%69%66%78%6a%64%62%63%78%2…
Update to the utils2_ak package is available
Folks: I have posted an updated release of my utils2_ak package. There is one updated feature in myschema: Enhanced the --passwd option. If password passed to this option (or using the PASSWD environment variable) begins with the at sign (@) character the rest of the string is …
skip fragment question,SQL EXPLAIN differen
Hi, in the ESQL application, the application use host variable, the SQL take about 3s, the expalin show it scan all fragment.In dbaccess I replace host variable with real values, the SQL take about 3ms, the explain show it skip fragment. Why? Do it due to the host variabl…
Error -172
Hi all, with one of our 4gl-programs we occaisonally get the following errors: Program stopped at "//home/projekte/qualifiziert/qualifiziert_5.0/qual_del.4gl", line number 1606. Date: 13.07.2018 Time: 19:43:30 Program error at "//home/projekte/qualifiziert/qualifiziert_5.0/qual…
No e-mails from IIUG SIG any more
Since we had to validate our e-mail address in June 2018 I do not receive any mails from the e-mail lists (sigs). My status of the membership area show up as follows: Current status of OPT-IN or OPT-OUT of IIUG emails CURRENTLY you have OPTed IN Number of IIUG SIG lists you are …
partition 'testdbs:informix.TBLSpace' no more page
I received the following message in online.log WARNING: partition 'testdbs:informix.TBLSpace': no more pages I resolved the issue by adding another dbspace and moving databases to that new dbsapce. What i cant figure out is how to determine how many pages i have available now as…
Informix Page Lock
Hi, I know this is somewhat a newbie question but may I ask how do you measure whether or not the table must use Page lock? I mean do you compute the number of rows? number of pages? How can one definitively say that his/her table should be page locked? Thanks,…
-272 No SELECT permission for sysdistrib.ninserts
Hello Informix Fans, We've encountered the above error on 12.10.FC11X1. SCHAPI: [Auto Update Statistics Evaluation 55-4] Error -272 No SELECT permission for sysdistrib.ninserts. It seems to be a known issue that's supposed to be fixed in 11.70.xC8. IC92183: CONVERSION ADDING …
New blog post and PlanetIDS no more
I was slightly surprised to find out that Informix Zone and PlanetIDS are no more: https://herber-consulting.de/informix-zone I found PlanetIDS particularly useful as single point for knowing when someone had blogged about Informix and it's a shame it's gone. Its demise seems to…
Informix binding problems
Hi, I'm using Informx IDS 12.10.TC5W1 on Windows 2012 R2 with two network interfaces. When I start Informix, its always starts in the second network card with port 9088. But I need to start it in the first network card. I already tried to change Windows Network Bindings, metrics…
Informix Binaries get corrupted
Hi, Can anyone assist me with the issue below: We are currently building Test Informix server on HP-UX B.11.31 and Informix version is 11.70.FC8W1.The issue that we are facing is after ontape restore complete running , Informix binaries get corrupted while the DB is still on fa…
OPEN ADMIN TOOL
Hello, May anybody tell me where is OPEN ADMIN TOOL for windows nowadays? I installed CSDK_4_10_FC11 and 3_70_FC9 and it is not there !!!! Thanks a lot, Juan…
plogspace vs dbspace
Hi, I feel ashamed but I found out recently that the location of the physical log it is supposed to be a plogspace not a dbspace like I was using until now , as I was taught. Does someone know the benefits of using a plogspace over a dbspace beside the fact that the database serv…
Bad page address or checksum on page zero (primary
Hi, recently I saw this message when I initialized our informix instance. It starts up without any problem and the database is functioning well, anybody know what could this message mean?…
ph_task entries?
IDS 12.10.FC3 Solaris 10 1/13 I would like to replace some of my cron jobs with the Scheduler. I have not used it very much, and have found the documentation not fully clear. Also, at least in the documentation I have found, there aren't very many examples. I think I understand…
stopped recieving list emails
Starting about two weeks ago I stop receiving the email feed from all iiug lists. I have logged in and verified my subscription on iiug.org site. Even unsubscribed and re-subscribed. Tried sending test emails to the ids@iiug.org list. It seems nothing working. We are on the Educ…
RAU
Good Day, I saw a post regarding the computation of BR, BTR and RAU with below scripts select 'BR (Bufferwaits Ratio): [< 7%] ---> ' || trunc(100 * (select value from sysprofile where name='buffwts')/((select value from sysprofile where name='bufwrites')+(select value from sysm…
How to kill a session using SQL
Need assistance. From an Administrator SQL session need to kill client database sessions that meet certain criteria. Can do this in SQL Server and Oracle. Need a SQL command that can kill a session based upon the client IP address and port no. In reviewing the sysmaster table…
Ifmx on windows: create a custom instance
Hi, as many among us, I am not very much experienced with Informix on Windows, and the doc doesn't help a lot here This is about windows, Linux/Unix not concerned here. I will understand if you don't read further and switch to the next post :-) I am writing a tool that generat…
Update to the utils2_ak package is available
I have uploaded an update to my utils2_ak package to my web site. To download it go to www.askdbmgt.com/my-utilities Here are some highlights of whats new: New options: - --use-database-owner - Generate all objects owned by the current owner of the database. --use-table-owner…
informixhq on https
We are running informixhq server on http protocol with 2 agents connected(one agent per informix instance). Now we are trying to run the same setup using https. Sever is up and accessible over the network. But we are unable to connect agents with that server. Here are configurati…
Informix backup conversion tools
There is a requirement to move some of our databases from Informix 12.10.FC6 (hoping to upgrade to 12.10.FC9 in 2 months) on to SQL Server 2016. Here are some questions: 1. Is there a tool(s) that does this effectively? 2. Is there a tool(s) to convert Informix onunload or archi…
where is my point "." :)
Hi to all i'm trying to create a constaint ALTER TABLE mytable add constraint check ((mycol IN (0. ,1. )) ) constraint ck_mytable$mycol; but when i do a dbschema the "." doesn't appear, it s important for me .. .. check (actif IN (0 ,1 )) constraint ck_mytable$mycol, any ide…
SQL using the index
If I find one index has high buffer read, How to know which SQL use this index?…
How to tell if logs are caught up in HDR
Hi, we restored our secondary. How can I check to see if the logs are now caught up on the secondary?…
Informix JDBC 4.10.FC11 missing from maven repo
4.10.FC10 is available as 4.10.10 in http://repo1.maven.org/maven2/com/ibm/informix/jdbc/, but still no sign of 4.10.11. I guess it is HCL/IBM who are responsible for uploading the new version, and not the community? And the list of fixes (http://www-01.ibm.com/support/docview.w…
Release notes, new and changed, fix list
I just downloaded 12.10.FC11, and the release notes contains a link to a list of defect fixes, as well as a link to a document listing whats new and changed in this release. However, none of these documents contain any information regarding FC11. The latest version there is FC10.…
Restore secndary from primary fails
Hi, I'm trying to restore secondary from primary with ontape to STDIO piping through ssh to secondary where I run a script with ontape -p: ontape -s -L 0 -F -t STDIO | ssh secondary/home/informix/restore.sh; restore.sh >> #!/bin/bash . /home/informix/setenv.sh ontape -t STDIO -p …
Could not position with in a table
Im continuously facing an issue in our applications. You can find the Java Exception Errors in Application server log (attached). Please find the below sample Error: 2017-10-12 06:58:16,054 ERROR [STDERR] (http-0.0.0.0-8180-10) Caused by: java.sql.SQLException: Could not positi…
end license
Hello!! I have a doubt. What happens if the informix license is terminated. thanks in advanced,…
NEW RFE
I have entered a new RFE # 120783, described as: Headline: Need ability to alter timeseries container configuration Description: The ability to alter timeseries containers from using rolling windows to not using rolling windows and the reverse from non-windowed to windowed woul…
BUFFERPOOL Configuration
Hi, I saw an excellent video post from AdvancedDataTools https://www.youtube.com/watch?v=Wgw1bAWl_Hg regarding sample BUFFERPOOL configurations 1.3 GB Memory for Buffer - Linux OLTP System - BUFFERPOOL size=2k,buffers=1500000,lrus=32,lru_min_dirty=10,lru_max_dirty=20 2. 12 GB …
RSS Encryption Performance Hit?
IDS 12.10FC3 Solaris 10 1/13 Is there any significant performance hit to enabling encryption for RSS? Is enabling RSS encryption really as simple as just setting ENCRYPT_SMX (and any desired optional ENCRYPT_* parms) on both ends (we have only a primary and one secondary)? Tha…
Connection MAnager error
Hi, I am trying to create one connection manager with ClientSDK 4.10.FC10 and using one primary and one RSS, but I am having some errors 4001 and 1002 when I try to start it: ALARM 4001 unable to connect to Informix server srvinfx12_net from srvifxcm error -951 ALARM 1002 Error…
Current IDS Version?
How does one find the most current version of Informix? Recently, when I asked about upgrading, and referred to fix pack XC10, some folks let me know that XC11 is now out (I do appreciate that some folks took the time to let me know). But, I'm wondering how one can actually det…
New Informix Request for Enhancement
I have submitted a new RFE to request that reporting of Readahead be improved so that we can better monitor our servers' readahead performance and tune it as needed. Please vote for RFE # 120533. Here is a link: https://www.ibm.com/developerworks/rfe/execute?use_case=searchRFEs&…
Who shut down my Instance?
Is it possible to find out who or what shut down the instance? version 11.5 In the onstat - m log, I only see that it shut down on Friday at 11am. 10:56:43 Checkpoint Completed: duration was 0 seconds. 10:56:43 Fri May 25 - loguniq 13475, logpos 0x45f1018, timestamp: 0x711b88db…
Upgrading from 12.10.FC3?
I'm thinking that it's about time to upgrade. In the recent year, I've run into a couple things that tech support says are probably fixed in newer releases, plus tech support told me that they do not have access to 12.10.FC3, and, therefore, could not attempt to replicate an issu…
Don't Understand Table's Space Requirement
IDS 12.10.FC3 Solaris 10 1/13 Consider a table with 11 columns. 10 of the columns are various "usual" datatypes, and those 10 columns take 39 bytes. The eleventh column is type LVARCHAR(10000). The table contains 300,000 rows. In 99.9% of the rows (299,700), the LVARCHAR column…
12.10.xC11 release notes
Hi, Does anyone have or have a link to the 12.10.xC11 release notes? Looking in the usual places, the links on the IBM site seem to be in need of an update since they only go up to xC9: http://www-01.ibm.com/support/docview.wss?uid=swg27014361 and https://www.ibm.com/support/kn…
JDBC
Hi. I need you help. Where I can get these packages ? : IBM_Informix_GLS_InstallLog IBM_Informix_JDBC_Driver_InstallLog IBM_Informix_Software_Bundle_InstallLog Are they in the iconnect or SDK? but then, as they are called to look for them. thansk in advance for your help. f…
row limit for fragment table with rowids
Hi, What is number of rows limit for fragmented table created with rowids option? I'm using IDS 11.50FC. Regards, Direk…
SHARED MEMORY ALLOCATION
Hi, Can I ask your opinion regarding memory allocation in informix 12.10 running on AIX 7? Total Server Memory is 12 Gig I was planning on leaving 4 Gig on the server and 8 Gig to be put in Shared Memory SHMTOTAL = 8192000 BUFFERPOOL (50% of SHMTOTAL) = 4096000 SHMVIRTSIZE (25…
Recovery mode stucked
Hi All Informix experts. I am just starting to work with Informix. Our Informix was undergoing a reboot and I am trying to bring it up. I am running into the errors below, where the server is stuck in Recovery mode. Can someone please let me know what I would need to do to ove…
listener-thread@soc_be.c:3073: err = -25582:
Hi Folks, Recently we are getting this error at a random intervals . During this error the connection is lost from the client and it goes for a time out. Tried with onstat -g ntt,nta , netstat -an but no luck. Can anyone suggest how to find the root cause and fix the issue. …
Error 922
On one of our database servers, when going into DBACCESS, we get - 922: Cannot get name of current working directory. I checked the main directories, $INFORMIXDIR, and the basic subdirectories, and all SEEMS fine. Any ideas what to look for ? Version 12.10.FC9W1 AIX 1 6 00CC9…
Error 922
On one of our database servers, when going into DBACCESS, we get - 922: Cannot get name of current working directory. I checked the main directories, $INFORMIXDIR, and the basic subdirectories, and all SEEMS fine. Any ideas what to look for ? Version 12.10.FC9W1 AIX 1 6 00CC9…
unable to run restore
Good Day, Name:Zanele We are running Informix 11.7FC8W1 on Unix platform. We are currently doing fresh Informix installation on the new server which will be our development server, which installed successfully. Then we modified sqlhosts and onconfig file and .profile as we wil…
informixhq agent start problem
Hi, Concerning openadmintool is dead I try to install the new project informixhq [https://informix.github.io/informixhq-server/] The server started and is working but the agent is returning error referring that something is missing: INFO com.informix.hq.agent.WebSocketManager - …
Automatic reply: Digest 41086
I am out of the office today, I'll get back to you as soon as I can.…
Automatic reply: Digest 41086
I'm currently out of the office If you need immediate assistance please contact one of the other DBAs or the DIS Helpdesk at 682-4357.…
OnBar - Can anyone help me?
Dear colleagues: I have problems configuring the OnBar, it is the first time it happens to me, and I would need your help. When I execute the "ism_startup -init" command, the following appears: ism_startup is starting the ISM daemons ism_startup is initializing the ISM Server …
Optimizing your OS for the best Informix Performan
Folks, I will be doing our next two Informix Webcasts: Optimizing the Operating System (Unix, Linux) for best Informix Database Performance by Lester Knutsen - May 17 at 2:00pm EDT The Informix database depends on the operating system for the CPU, Memory, Disk and Network reso…
does uninstalling the Server delete the DB?
I have to replace a trial Informix server with a licensed copy. I have done a uninstallids on the trial server, and retained the database option. Will uninstallserver, to finish removing the trial server, wipe out the Database?…
cdr define shardCollection
I'm confused on the --versionCol=<field/column> switch for this command. That must be an existing field in the table, right? What data type is it supposed to be? It's just some housekeeping field used by ER, right, and not some actual column/field that is part of the table. Th…
HCL Informix on AWS
Anyone else played around with this yet? Andrew…
New Informix for Database Administrators Training
Folks, I am really excited to be teaching our next Informix Class, Informix for Database Administrators, on May 21-24, 2018. We still have two places left if you would like to attend. We have updated our Informix Training for Database Administrators with the latest version of I…
Re: Latest JDBC drivers
We continue to make difficult what should be brutally simple. You have two options: 1- If you're a customer you'll find it in Passport Advantage 2- http://repo1.maven.org/maven2/com/ibm/informix/jdbc/4.10.10.0/ Regards. On Sun, Apr 29, 2018 at 7:44 PM, MUKESH TANUKU <mukeshbt13…
IDS 12.10 EMC ver. 8
Hi, I just finshed upgrade informix from 11.50 to 12.10, thinks went ok. After the migrate the database, I did upgrade the nmda version from 1.1 to 8.2.2.0 and change my sm_version from 1|1.0.1|nwbsa|1 To 1|8.2.2|nwbsa|8.2.3.2 When I run the backup using onbar I get the same mes…
Re: Switching primary/mirror chunks (RFE)
Just discovered the HCL Informix documentation site: http://informix.hcldoc.com This shows the syntax for my feature here: http://informix.hcldoc.com/help/topic/com.ibm.admin.doc/ids_admin_toggle_primary _mirror.htm To swap a single mirrored chunk, use the following command: ex…
Re: Could not do a physical-order read to fetch ne
So a simple procedure like below will work right CREATE PROCEDURE public.sysdbopen() SET LOCK MODE TO WAIT 60; END PROCEDURE; do we need to manually execute the procedure or else automatically will it call once the user connects to the database?…
Configuring backups
Can anyone clarify me on how to configure an hourly backup. Like below: Level 0 on every monday Level 1 on Everyday Level 2 on every 2 hours…
Dbexport very slow
Dear colleagues: Since Monday I have noticed that the dbexport of my database takes much longer than usual. Last Saturday a process of massive insertion in the same has been executed, through the generation of invoices. Can the update statistics influence the slowness of the db…
IIUG World 2018 - Washington, DC - Oct 28 to Nov 1
Hey Everyone, I'm happy to announce that we are now accepting session proposals for this year's Informix event in Washington, DC to be held October 28 to November 1, 2018. As always, user speakers will be given a complimentary pass to attend the event as a thank you for your ti…
onmode bug discovered (-wf)
Hi All, ran across an interesting little bug today: we have several onconfig files for an instance, each with different TAPEDEV and LTAPEDEV settings, used for ontape backups and restores. For example: onconfig.serv-null has TAPEDEV set to /dev/null so we can run on-the-fly 'onta…
rootdbs is full message
hi I'm using informix 12.10 in HPUX I found message 'rootdbs is full' and 'tempdbs is full' in online.log but rootdbs was not full, and tempdbs also not full so I want to know, when tempdbs was full, is informix using rootdbs? and if informix using rootdbs instead of tempdbs…
HDR RSS reshuffle
IDS 11.70.FC7GE we have a HDR primary and secondary (ro) configuration in place. In prep for this weekends hardware migration I established a RSS server on new server1 and went to establish RSS on new server2 but RSS on server2 would not initialize , evidently with GE you can on…
Upgrade 11.70 to 12.10
Hi. We are running 11.70.FC8W1 on Linux in a Primary / SDS config. Everything works well. Now I'm planning to upgrade to the newest 12.10.FC10. I've been testing the upgrade process (on a restored instance without SDS) and we have run our application and everything seems to be O…
UDT to handle DateTimeZone data
Has anyone got a UDT to store and manage this date/time/zone format in Informix directly without having to manipulate the date : 2018-04-19T02:14:09.089473705-07:00 Product Management : Given the global nature of computing and IOT devices that are storing data in the cloud ther…
CLOB cloumn data not reflecting in HDR seconday
Im trying to retrieve data from one of the table consisting CLOB column, data is not populating in HDR server it is showing NULL values. But CLOB data is available in primary. IDS version : 12.10 FC8 OS : windows server 2012 R2 HDR enabled. output of onstat -g dri Primary: IB…
Re: ESQL/C program called from SPL with SYSTEM com
When running from ESQL/C directly from the command line is /proc/self/loginuid set? I would not say this is a PAM issue but instead it is that when oninit is called the caller has not set the login id. Quick workaround: From SPL call a script and have a wrapper script set the /…
RE: Need Help Please on Restore
Onclean -ky works well to kill off all pre-existing processes, shm segments, etc... -----Original Message----- From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of BENJI LONG Sent: Tuesday, April 17, 2018 6:59 PM To: ids@iiug.org Subject: Re: Need Help Please on…
Re: 12.10.FC9 1809 Error
It's a bit strange.... AFAICR, 1809 is only returned in PAM connections. Are you trying to connect through a PAM listener? If yes, forget about connecting locally with user informix as it bypasses the PAM authentication. If you're connecting through a PAM listener/port than you n…
Re: 12.10.FC9 1809 Error
Hi John, check the online.log for details, I believe the PAM configuration is not ok. If in doubt what to do, post the relevant lines from the online.log and your PAM config. hope this helps, Marcus Haarmann Von: "SMITH JOHN" <srafik0358@gmail.com> An: "ids" <ids@iiug.org> Ge…
12.10.FC9 1809 Error
Hi to All, I installed Informix 12.10.FC on AIX 7.2, everything is all right but i have a issue with connecting with a user that i created after installing et starting ids, i can connect with users of informix group, staff group but not with my user the error is 1809 can anyo…
Need Help Please on Restore
We are trying to do a restore of our primary on the secondary. Version 11.5 on Linux We took a backup on the primary. Moved it to the secondary. When we run ontape -p We get Continue restore y backup logs n oninit: Fatal error in shared memory creation. WARNING: server initial…
ESQL/C program called from SPL with SYSTEM command
Hi Informixers, please bear with me if the following sounds a little confusing. I am thoroughly confused myself. We're running IDS 12.10.FC8W1WE on SLES 12 SP1. The system is configured to authenticate users via local files (/etc/passwd) and sssd against an Active Directory dom…
Informix DBA Training - May 21-24
Folks, I will be teaching our next Informix Class, Informix for Database Administrators, May 21-24, 2018. We still have two places left if you would like to attend. We have updated our Informix Training for Database Administrators with the latest version of Informix, and we hav…
Re: New Informix Webcasts - Getting going with PSM
Folks, The Webcast replay is on our Website and YouTube for those who missed it. YouTube: https://youtu.be/v1xtnvhGv4o or http://advancedatatools.com/Informix/Webcasts.html Regards - Lester On 4/6/18 6:48 AM, Lester Knutsen wrote: > Folks, > > We have a new Informix Webcast n…
Fujitsu M10 + Informix 12.10FC10 + DR/DA
Hello my Friends Since nearly one Year we have trouble updating our Informix to the newest Version on some of our Servers. The Main Problem is, that after a update no more DR/DA Connections are possible. Sadly the Informix Support could also not help us to localice the Problem, …
Moving entire database from on server to another
Hi, we are planning to do monthly refreshes of our UAT environment from databases from production. Right now we are using dbexports but it is a slow process where: - if we import databases with dbimport -l buffered, we get long transaction errors. - if we import databases withou…
Data Archiving, moving historical data
need to move the historical data from a busiest table in production environment. Can anyone suggest a way to move the historical data to new table. I thought to write a procedure but there is lot of dependent tables and those are tightly related to each other and constraints enab…
New Informix Webcasts - Getting going with PSM and
Folks, We have a new Informix Webcast next week, Getting going with PSM and Informix 12 for backups by Thomas Beebe, #IBMChampion - 4/12/2018 at 2:00pm EDT For years Informix users who backup to local disks have been stuck with the limits of ontape or the tediousness and slowne…
Compressing a Busy Table
IDS 11.70.FC8 Linux GNU x86 I am wanting to bring compression into our environment and am wondering about when I am actually compressing or repacking, what kind of interference I can expect on my data being used at the time. I have played with this feature before but I know I wi…
sqexplain.out
When I run a query with set explain on avoid_execute, I get three different selects statements back that are each followed by what looks like is an execution plan in the sqexplain.out file Are these three select statements how the database engine is going to break the query dow…
restore question in RSS environment
Hi Below are the scene and steps . 1, do full instance backup in primary.Customer config log backup in the primary also. 2, RSS take over as primary, old primary became rss, and run the application in the new primary for some days. New primary always do log backup continuously.…
Re: Move sysadmin database
Im facing the same problem. can anyone please provide the solution and root cause for this error 17:30:36 SCHAPI Estimate Compression for sbspace1:"informix".LO_hdr_partn started 17:30:36 cc. 17:30:36 ERROR(ddopendb) Estimate FAILED for table 'sbspace1:"informix".LO_hdr_partn' -…
Free Webcast - Informix and PSM - 4/12/18 @ 2 PM E
Join us for the free webcast "Getting going with PSM and Informix 12 for backups", presented by Thomas Beebe on Thursday, 4/12/18 at 2 PM EDT. This webcast will show how to set up and use the Informix Primary Storage Manager (PSM) - the storage manager included with Informix 12.…
SET LOCK MODE TO WAIT
I have a question in mind where to set the lock mode. where to run this sql statement SET LOCK MODE TO WAIT 30; -> whether we need to run this sql statement in dbaccess before application is connection to database. -> or it should be set in data source file from application end.…
Which is best On-Bar and On-Tape
Friends, I need all your opinions on the best approach in configuring onbar and ontape backups. 1) Which is easy to configure. 2) Which type of backup is easy to restore. 3) Is retention enabled for both types. 4) which one is best to configure continuous logical logs. 5) how to…
ratios.shr
Hi Friends, Can anyone help me on this regarding ratios.shr I have downloaded the ratios.shr. how to use this in my enviroment im unable to find the steps. My environment is IDS 12.10FC8 in Linux. I have mode the file ratios.shr to the path where the IDS is running. Now what a…
partition limit
Hi, I have one server that my company use to give support to our clients. The server is using 12.10.FC10 version and we are facing one problem with partition limits. As we use one partition for all database and index also, the problem is that have dbspaces have less than 50% occ…
index compression on Version 12.10
If i want to compress the detached index, Do the create index command lock the whole user table ? it will affect the business. thanks.…
Upgrading Apache in OAT
Has anyone attempted to upgrade the Apache that drives OAT? Even the latest version of OAT comes with a vulnerability-riddled version of Apache I cannot use. This is on Linux. Thank you, Trent…
sysmaster:sysptnhdr
Hi, Could anyone given an opinion on whether I should expect sysmaster:sysptnhdr to return the same values on all nodes in an Informix HDR/RSS cluster? I notice that the primary, HDR and RSS servers in a cluster all return different values for ninserts, nupdates, ndeletes even t…
restoring to another server using psm
We are using informix IDS 12.10.FC7. We use ontpe for backup and trying to replace it with onbar. When we tried to restore the backup taken from one server to another server,we are facing issues like shown in below bar_act.log: ---------------------------------------------------…
Could not do a physical-order read to fetch next r
Dear Techies, As we are facing a serious issue in our production server this evening, which makes the transaction stop. Issue logged in application server: Java.sql.SQLException: Could not do a physical-order read to fetch next row. Impact: records are not inserting in the resp…
Connection Refused
Dear colleagues: I have the following problem: My PC has a 64-bit Windows 10 installed, and I have an Informix 7.31 TD6 engine installed, which works perfectly. I also have the SQL Editor installed, and it connects without any problem to said engine. As I also have to run a 16…
transation logs problem
Hi, I have todo some frequent changes to database structure, on some customers the operation hangs because the transaction logs became full. I am using /dev/null for LTAPEDEV and configured alarmprogram script to do backups, is anything missing? There is any option to disable it…
Issue with VERCOLS and external tables
IDS 11.50.FC5 (I know, near EOL) I have some tables that are defined WITH VERCOLS. If I do: CREATE EXTERNAL TABLE my_external_table SAMEAS my_table ... the external table includes the ifx_insert_checksum and ifx_row_version columns. But when I do: INSERT INTO my_external_tabl…
Can we expect IIUG Conference inINDIA?
Dear Friend, Can we expect IIUG Conference in INDIA in future?…
Issue with statistics
We have a primary and a secondary. The secondary is a reporting server, and when one of the report creators adds a table to the sql query, the performance of the report grinds to a halt. It ran fast before adding this table to the query. Is there some way I can check to see what…
Revoke privileges
Hi, IDS11.70. What does the following Warning mean? revoke all on mytable from public; Warning:Privilege not revoked. It seems the privileges was revoked , but confused by the warning . Thanks Frank…
Application or Internal User
I am suspecting this is a dumb question, and I'm actually hoping it is. Is there a way to tell which users that have access to a database are being used to connect to the database through an application and which ones are being used locally(someone logging into the box and then …
Re: Who is filling my Temp space ?
If youre on 12.10.xC8 or later the following query will return the size of temp tables for each active session SELECT i.sid, hex(i.flags) flags, hex(i.partnum) partition, trim(n.dbsname) || ":" || trim(n.owner) || ":" || trim(n.tabname) table, i.nptotal allocated_pages FROM sysm…
Who is filling my Temp space ?
I am trying to catch a session that fills up our TEMP spaces. I run queries against SYSMASTER, but ... these sysmaster queries are very slow. Often the space fills up, the sessions crashes, and space is released, before my sysmaster query returns a result. Is there a quicker way…
RE: Re: Users from a database Import [40822]
Benji, If you have many users it might be best to look a creating a role and the setting those use as that role due to the number of entries needed. Bruce Simms Data Base Services TALX, Provider of Equifax Workforce Solutions 2330 Ball Drive St. Louis, MO 63146 Phone (314) 214…
Encryption Key for Column-level Encryption
Hello All, We are potentially needing to implement column-level encryption for the first time, and I would appreciate some input from anyone currently using it. Can you give me an idea of how you are storing the password/encryption key? The manual states the below: "When you …
Users from a database Import
If I bring a database over from another server, the users come with it. Once I have a Linux admin make the user account on the new server, how do I map the OS user with the user that is already in the database?…
sides for last presentations
Hi, I am looking for the slides of last presentations from 2015, 2016 and 2017. Can anyone send or tell me where I can download them. Thanks, SP…
Find Columns with a Prefix
I am trying to identify all the columns that have been prefixed with '_'. This is the simplified version of my SQL. select tabname, colname from systables t, syscolumns c where colname like '^_%' and t.tabid = c.tabid and tabname not like '%sys%' --and tabname = 'cef_security' …
Adding a database user
Up until now, I have been concentrating on the admin side. I need to make a new user that has read/write for a database. Is that possible with Informix? From what I reading, I can see that you make a user have DBA, RESOURCE Or CONNECT. I think I need my user to have connect. C…
Long transaction aborted in alter table
H, I trying to add a column to a table but I get the long transaction aborted, what can I do? Thanks in advance.…
running out kaio
We are running informix 12.1 FC10 on Linux Red Hat 7 64-bit We enabled direct_io in informix configuration. But sometime instance restart fils and complaints about running out of KAIO processes. A message in online log is given below for reference: "requested number of KAIO event…
Informix DBA sought in the UK
Ardenta, now owned by the Claranet Group, seeks an experienced DBA in the UK. Job Post is here: http://members.iiug.org/jobs/job.cgi?action=view&job_no=333 (iiug.org webmaster might like to note that 2015 seems to be latest year selectable for "Start Date"!). Details also avai…
GLS Help
Can someone provide some advice please? I have an Informix database defined with en_US.819. I want to accept JDBC client connections that use UTF-8 but translate special characters on the way through. For example if the client connection sends an endash character I am quite happ…
Unloading Data to .csv Format
All, I am being asked if there is a way to export the contents of tables in an IDS10.0.FC4 database to a .csv format file. Does anyone know if this is available? Thanks. Pam…
SEQSCANS Counter in sysptprof
Hello IIUG Community We are running a hugh server with aprox 8TB attached Databases. In sum everything works very well and also the overall Performance is good. As we want to implent compression we have identified Tables with a high I/O impact. While searching for this, we have…
ONLOG command
Does anyone have a good link for me, where I can read more about the ONLOG command in detail, more about using it to interrogate logs ? Version 12.10.FC9W1 AIX 1 7 00CC95264C00 Regards Dirk…
Continous logical log backup stuck - primary
Hi, I remember having this issue before but just can't remember how I solved it: [informix@ids01ha ~]$ ontape -a -d Performing automatic backup of logical logs. Do you want to back up the current logical log? (y/n) n Program over. This happens in a second without any input f…