Re: error cdr define repl
Posted in 2005
Topics: High Availability & Replication, Versions, Editions & End-of-Life
yes, the errors were on the root server in online.log. In syscdr:cdr_error on root server i have no error in last days....there are old errors ... On the other servers- nonroot or leaf -don't appears any error but the replicate don't work because definition of replicate don't "arrived" here....I don't know why!!! ..the servers are connected...the old replicates works.... indeed, the root server is connected to 7 leaf nodes and to 15 nonroot nodes; the nonroot nodes are also connected with 63 leaf servers, other leaf servers that are connected with root server.... yesterday i tried to define the same replicate on one of nonroot servers( primary P is root server, R is one leaf server, replicate was defined on the nonroot server; then I used cdr change repl and I added all participants)..until now all works fine ...I inserted one row in the table on root server ... Result : with one leaf server connected directly with root server replication works...with other 6 leaf servers connected directly with root server replication don't works. the error in online.log : "CDR CDRDS: transaction aborted (Error in retrieving the replicate's attributes)" Replication works on 14 nonroot servers but in one nonroot server (and in leaf servers connected directly with this nonroot server) don't works...even if NO ERRORS found in online.log.... I don't understand why the replication works with some servers and with other servers don't work....I don't understand why I found any errors on some servers where replication don't works and on other servers where replication don't works I can't found errors.....especially if the replicates already defined works ok.... My fear is we must redefined whole replication system....I don't like this ...may appears some problems..and the activity is critical..I work in a bank and I can't break activity for a long period anyway in this year our intention is to migrate to IDS 9.4 and I hope some problems with replication system will be resolved.. Thank you Madison..I hope you understand what I want to say....
See below.. "cristizaharioiu" <cristizaharioiu@gmail.com> wrote in message news:1105517262.842212.62510@z14g2000cwz.googlegroups.com... > yes, the errors were on the root server in online.log. In > syscdr:cdr_error on root server i have no error in last days....there > are old errors ... On the other servers- nonroot or leaf -don't appears > any error but the replicate don't work because definition of replicate > don't "arrived" here....I don't know why!!! ..the servers are > connected...the old replicates works.... There was probably some issue with the propogation of the replication metadata. > > indeed, the root server is connected to 7 leaf nodes and to 15 nonroot > nodes; the nonroot nodes are also connected with 63 leaf servers, other > leaf servers that are connected with root server.... > > yesterday i tried to define the same replicate on one of nonroot > servers( primary P is root server, R is one leaf server, replicate was > defined on the nonroot server; then I used cdr change repl and I added > all participants)..until now all works fine ...I inserted one row in > the table on root server ... > Result : with one leaf server connected directly with root server > replication works...with other 6 leaf servers connected directly with > root server replication don't works. the error in online.log : "CDR > CDRDS: transaction aborted (Error in retrieving the replicate's > attributes)" This means that the replicate definition failed on the target node. The source is sending stuff to the target, but the target doesn't know what to do with it or how to apply it. > > Replication works on 14 nonroot servers but in one nonroot server (and > in leaf servers connected directly with this nonroot server) don't > works...even if NO ERRORS found in online.log.... > > I don't understand why the replication works with some servers and with > other servers don't work....I don't understand why I found any errors > on some servers where replication don't works and on other servers > where replication don't works I can't found errors.....especially if > the replicates already defined works ok.... I'd need to understand the topology better to answer that one. > > My fear is we must redefined whole replication system....I don't like > this ...may appears some problems..and the activity is critical..I work > in a bank and I can't break activity for a long period I don't think that's necessary. We may have to do a bit of work with the syscdr database, however. Who is your support team? I might be able to give them some suggestions as to how to resolve the problem. > > > anyway in this year our intention is to migrate to IDS 9.4 and I hope > some problems with replication system will be resolved.. > Thank you Madison..I hope you understand what I want to say.... >