Re: How to free pages?
Posted in 1999
Topics: Storage & Space Management, Migration, Import/Export & Data Conversion
Try:
ALTER FRAGMENT ON tabname INIT IN your_dbspacename
Hope it helps,
Octav
On Wed, May 05, 1999 at 12:12:10PM +0200, Wolf D. Pichler wrote:
> Colleagues!
>
> Because of an error one of our dbspaces became full. We deleted a huge
> amount of rows from the affected table but as you know the space remains
> allocated by this table.
>
> Question: Is there a way to free the space without unload/drop
> table/create table/load ??
>
> We use Online DS 7.23UC3.
>
> Thanks in advance
>
> Wolf Pichler
>
> --
>
> Remove the uppercase words from my e-mail address to reply.
>
--
Octav Chiriac Phone: (373) 2 21 20 96
NetInfo S.R.L. Fax: (373) 2 21 36 59
Chisinau (373) 2 24 00 83
Moldova, Republic of mailto:com@netinfo-moldova.com
That works .... Thanks!
Octav Chiriac wrote:
> Try:
>
> ALTER FRAGMENT ON tabname INIT IN your_dbspacename>
> Hope it helps,
> Octav
>
> On Wed, May 05, 1999 at 12:12:10PM +0200, Wolf D. Pichler wrote:
> > Colleagues!
> >
> > Because of an error one of our dbspaces became full. We deleted a huge
> > amount of rows from the affected table but as you know the space remains
> > allocated by this table.
> >
> > Question: Is there a way to free the space without unload/drop
> > table/create table/load ??
> >
> > We use Online DS 7.23UC3.
> >
> > Thanks in advance
> >
> > Wolf Pichler
> >
> > --
> >
> > Remove the uppercase words from my e-mail address to reply.
> >
>
> --
> Octav Chiriac Phone: (373) 2 21 20 96
> NetInfo S.R.L. Fax: (373) 2 21 36 59
> Chisinau (373) 2 24 00 83
> Moldova, Republic of mailto:com@netinfo-moldova.com
--
Remove the uppercase words from my e-mail address to reply.
On Wed, 5 May 1999 14:23:16 +0300, Octav Chiriac
<com@netinfo-moldova.com> wrote:
>
>ALTER FRAGMENT ON tabname INIT IN your_dbspacename>
>Hope it helps,
>Octav
>
>On Wed, May 05, 1999 at 12:12:10PM +0200, Wolf D. Pichler wrote:
>> Colleagues!
>>
>> Because of an error one of our dbspaces became full. We deleted a huge
>> amount of rows from the affected table but as you know the space remains
>> allocated by this table.
>>
>> Question: Is there a way to free the space without unload/drop
>> table/create table/load ??
>>
>> We use Online DS 7.23UC3.
Of course, if his dbspace is already full, the above ALTER FRAGMENT
statement will fail due to lack of space. The dbspace used would have
to be different than the dbspace currently seeing the space problem
for it to work. The table could then be moved back to the original
dbspace once the space was freed up.
Dave