RE: Question about Intersolv ODBC Drivers
Posted in 1998
We encountered similar errors when System variables and/or Informix Setnet
environment variables were not set properly.
On our Windows NT workstations, we use the following settings:
1. System variables on Settings -> Control Panel -> System -> Environment
INFORMIXDIR=c:\\Program Files\\INFORMIX
PATH=c:\\%SystemRoot%\\system32;c:\\%SystemRoot%\\c:\\ProgramFiles\\INFORMIX;...
2. Informix Environment settings: Programs -> Informix -> Informix Setnet32
CLIENT_LOCALE=EN_US.8859-1 DBLANG=EN_US.CP1252
INFORMIXDIR=c:\\Program Files\\INFORMIX
Informix also limits identifiers to a maximum of 18 characters.
Therefore, table names and column names cannot exceed 18 characters.
-----Original Message-----
From: Nicholas Palmer [mailto:nick@kcicorp.com]
Sent: Thursday, November 19, 1998 10:28
To: informix-list@iiug.org
Subject: Question about Intersolv ODBC Drivers
Hello,
Hopefully somebody here can help me with this problem. I'm trying to
use the Intersolv ODBC drivers to talk to my informix database. When I
use the Informix ODBC driver everything works fine, but when I try and
use the Intersolv drivers, either the 3.01 or the new 3.11 driver I get
the message back saying :
[INTERSOLV][ODBC Informix driver][Informix]Unable to load locale
categories.
I'm guessing that somehow the driver can't find the locale files, but
I'm not sure how to set this. The informix ODBC driver works fine, but
I'm having a problem creating a table with a column that has an
identifier longer than 18 characters. I was hoping to try the the
Intersolv driver to see if I could create this table under that driver.
Any help would be greatly appreciated. Thanks in advance.
Nick.
--------------------------------------------
Take off Late, Get Deep, Go Down Hard...
nick@kcicorp.com (Nick Palmer)
KCI Computing International