Re: Help!- unable to initialize security subsystem? -NT
Posted in 1998
marcd@webquiz.com wrote in message <35A27CD2.A5E18AE7@webquiz.com>... >I am running Informix On-line workgroup server v. 7.22 on NT 4.0 and >Netscape Enterprise Server 3.0. Running some web/database apps. >Everything is going fine for the past 6 months and then suddenly the >Informix services will not load with this error in the event log: >Could not initialize the security subsystem. Please ensure that this >account has the necessary privileges. >The account informix does have permissions to "run as a service", "act >as a part of >the operating system", and "create a token object". It is part of the >Informix-Admin >group. These are the requirements for the informix account according to >the manual. >The on-line center reports the database is off-line and when I try to >make it >on-line I get the same error message. I have tried: re-installing >informix, re-entering >the informix account and re-applying security permissions to the >informix directories. >Any help? Thanks. >Marc Doolittle >marcd@webquiz.com > There is a registry entry under key HKEY_LOCAL_MACHINE\\Software\\Informix\\OnLine\\CurrentVersion\\Security under this entry there are the following subkeys: IXAAO Group (Auditors) IXDBSA Group (Database administrators) IXDBSSO Group (Database Security officer) IXUSERS Group (Ordinary users) Under each entry there is a string value named "Name" that contains group name that are assigned to the appropriate functions. Under key IXDBSA group is also a string value named "Domain" that defines NT domain that all thesye groups come from. It can be either nape of NT server running Informix or normal domain name. Users should be members of appropriate groups, and user righst should be assigned on appropriate machine that is running Informix. Also, user account that is used to start engine should be defined in IXDBSA group. Also note that if you delete any of the groups or users, an then rectreate it (i.e. delete and then recreate user informix), this is NOT the same user for NT. During expermienting with Informix security, I producet exactly the same error as you mentioned, but I am not shure what was the combination of parameters (I thing that "Domain" value under IXDBSA key wa not specified or was invalid). Anyhow, first try to start engine or any utility manualy. If you got the same error then it is the problem with registry. Othervise check entries in service definition via control panel. ============================== Slobodan Zorko Alfatec Group 10000 Zagreb, Praska 5, CROATIA email: slobodan.zorko@zg.tel.hr begin 666 Slobodan Zorko.vcf M0D5'24XZ5D-!4D0-"E9%4E-)3TXZ,BXQ#0I..EIO<FMO.U-L;V)O9&%N#0I& M3CI3;&]B;V1A;B!:;W)K;PT*4D56.C$Y.3@P-S Y5#$Q,#(T,UH-"D5.1#I6 &0T%21 T* ` end