Re: ontape problems
Posted in 1995
Bob Baskett (inf_bb@hermes1.sps.mot.com) wrote:
: we are attempting to run ontape (level 0) on a sun sparc center 2000 running
: solaris 2.4 and online 7.10.UC1. it runs for about 3 hours before displaying
: the following message to the screen:
: 20 percent done. Archive failed - function write to tape failed code -1 errno 2
: Program over.
: the online log reports that the archive was aborted by client. the instance
: being archived is about 30 gig in size. for whatever reason, our sys admin
: swears there is a problem with getting messages written to the
: /usr/adm/messages file, so there are no system messages being logged. we
: have tried several different block sizes and as informix and root with the
: same results...
What's the size of your tape? I've had this happen when the tape hits EOT.
You may also be hitting a wall on the maximum size of a tape write. I've
seen this in 5.X on some Pyramid boxes. Easy thing to try is to cut the
tape capacity in half in the config file and see if it happens again. If
not, you're probably hitting EOT before hitting your tapesize param.
I've also seen this when using the wrong logical tape device, i.e. a
noncompressed vs a compressed device, but using the tapesize of the
compressed device.
Joe
--
---------------------------------------------------------------------------
Joe Lumbley(jlumbley@netcom.com) Dallas, Texas
----------------------------------------------------------------------------