import fails on linux red hat
Posted in 2012
Topics: Server Administration, Platform-Specific Issues, Versions, Editions & End-of-Life
Linux hvgreyst23 2.6.32-279.14.1.el6.x86_64 #1 SMP Mon Oct 15 13:44:51 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux /IBM Informix Dynamic Server Version 11.50.FC9TL Software Serial Number AAA#B000000 help please import is failing when it hits a line with ^M in it - is this new line Thinks there are more cols in import file than in table export was done on unix HPUX system I have ALLOW_NEWLINE 1 set in onconfig file on both systems. Thought this would stop this problem but does not
Hi.
I think you must enter into the export directory and run dos2unix
cd database.exp
dos2unix *
cd ..
Drop database and star again
Regards.
Luis Panozzo
On 27/11/2012, at 18:10, "KARL OLIVER" <karl.oliver@maf.govt.nz> wrote:
> Linux hvgreyst23 2.6.32-279.14.1.el6.x86_64 #1 SMP Mon Oct 15 13:44:51 EDT
> 2012 x86_64 x86_64 x86_64
> GNU/Linux
> /IBM Informix Dynamic Server Version 11.50.FC9TL Software Serial Number
> AAA#B000000
> help please
> import is failing when it hits a line with ^M in it - is this new line
>
> Thinks there are more cols in import file than in table
>
> export was done on unix HPUX system
> I have ALLOW_NEWLINE 1 set in onconfig file on both systems. Thought this
> would stop this problem but does not
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
The carriage returns (^M) in the .unl files should have been escaped. How did you create the export? Art Art S. Kagel Advanced DataTools (www.advancedatatools.com) Blog: http://informix-myview.blogspot.com/ Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on my employer, Advanced DataTools, the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Tue, Nov 27, 2012 at 5:10 PM, KARL OLIVER <karl.oliver@maf.govt.nz>wrote: > Linux hvgreyst23 2.6.32-279.14.1.el6.x86_64 #1 SMP Mon Oct 15 13:44:51 EDT > 2012 x86_64 x86_64 x86_64 > GNU/Linux > /IBM Informix Dynamic Server Version 11.50.FC9TL Software Serial Number > AAA#B000000 > help please > import is failing when it hits a line with ^M in it - is this new line > > Thinks there are more cols in import file than in table > > export was done on unix HPUX system > I have ALLOW_NEWLINE 1 set in onconfig file on both systems. Thought this > would stop this problem but does not > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --14dae9340bef626d6a04cf81b1f0
problem solved I was using my windows pc to tunnel files from unix to linux. Bad ol windows ! Used rsync for unix to linux instead and all files now ok