RE: Empty onconfig file
Posted in 2000
Topics: Server Administration
>===== Original Message From June Tong <june_t@hotmail.com> =====
>Kudzi Muchaka wrote:
>
>> The problem was that the backup logs were full, due to the inability
>> of the backups to kick in. All the errors were being recorded in the error
>> log, thus my logs grew. I ended up with no room/space in that file system.
>> This resulted in the onconfig file being wiped out... go figure!
>>
>> The moral of the story, I guess, is keep an eye on your file systems,
>> because the most expendable thing in the search for space is the config
>> file :-<< I think this is rather curious?
>
>It isn't "the most expendable thing"; the onconfig file is kept open by
OnLine and written back to disk when OnLine is shut down. When
>writing back to disk, if the disk is full, you will have this problem.
Neither OnLine nor Unix will drop your files searching for space.
>
>June
>--
>june_t@hotmail.com
>Back from the dead, resuscitated by Godiva chocolates...
>
>Please do not send Informix questions to this account.
If this is the case, why can I change my config file and bounce the engine?
The only thing I can think of that would do that would be if
onparams, onmonitor or something of that sort was used to
change the configuration, that might rewrite the config file
Will
------------------------------------------------------------
This e-mail has been sent to you courtesy of OperaMail, as a free service from
Opera Software, makers of the award-winning Web Browser, Opera. Visit us at
http://www.opera.com/ or our portal at: http://www.myopera.com/ Your free e-mail
account is waiting at: http://www.operamail.com/
------------------------------------------------------------
William Rice wrote:
>
> >===== Original Message From June Tong <june_t@hotmail.com> =====
> >Kudzi Muchaka wrote:
> >
> >> The problem was that the backup logs were full, due to the inability
> >> of the backups to kick in. All the errors were being recorded in the error
> >> log, thus my logs grew. I ended up with no room/space in that file system.
> >> This resulted in the onconfig file being wiped out... go figure!
> >>
> >> The moral of the story, I guess, is keep an eye on your file systems,
> >> because the most expendable thing in the search for space is the config
> >> file :-<< I think this is rather curious?
> >
> >It isn't "the most expendable thing"; the onconfig file is kept open by
> OnLine and written back to disk when OnLine is shut down. When
> >writing back to disk, if the disk is full, you will have this problem.
> Neither OnLine nor Unix will drop your files searching for space.
> >
> >June
> >--
> >june_t@hotmail.com
> >Back from the dead, resuscitated by Godiva chocolates...
> >
> >Please do not send Informix questions to this account.
>
> If this is the case, why can I change my config file and bounce the engine?
>
> The only thing I can think of that would do that would be if
> onparams, onmonitor or something of that sort was used to
> change the configuration, that might rewrite the config file
Naw, but the engine checks to see if the file has been updated since it was
read in before overwriting it.
Art S. Kagel