How to manage multiple sqlexec daemons?
Posted in 2000
Topics: Stored Procedures & SPL, Connectivity: ODBC / JDBC / .NET, Java & JDBC Development
We wrote a little HTML front-end to a bunch of stored procedures in SE and use the jdbc driver to interact with our SE (v7.24) server. One of our routines drops and re-creates a table, and it has been failing with the reason listed as a lock existing on the table. We thought the existence of a bunch of sqlexec daemon processes might contribute to the existence of a lock condition on this table when the SP tries to perform its refresh action (DROP, CREATE, LOAD). How does Informix decide to shut down the sqlexec process on the server side? Is there a flag for a time-out setting, or should we arbitrarily kill processes in the middle of the night? TIA.
I would suggest setting your OS's idleout time so that users get kicked out if they haven't been doing anything for an hour or two. Those sqlexec processes are users connected to the database. You _can_ kill them if you have to, but it would be difficult to tell what the result to the data would be. In article <3936C1EB.5939C131@cornercap.com>, Bradford Young <byoung@cornercap.com> wrote: > We wrote a little HTML front-end to a bunch of stored procedures in SE > and use the jdbc driver to interact with our SE (v7.24) server. One of > our routines drops and re-creates a table, and it has been failing with > the reason listed as a lock existing on the table. We thought the > existence of a bunch of sqlexec daemon processes might contribute to the > existence of a lock condition on this table when the SP tries to perform > its refresh action (DROP, CREATE, LOAD). > > How does Informix decide to shut down the sqlexec process on the server > side? Is there a flag for a time-out setting, or should we arbitrarily > kill processes in the middle of the night? > > TIA. > -- # unrm / ksh: unrm: not found # man cpio Sent via Deja.com http://www.deja.com/ Before you buy.