Re: Installing IDS 7.30 on NT
Posted in 1999
Topics: Installation, Setup & Upgrades, Versions, Editions & End-of-Life
Grraaaah, Informix and NT, still trying... I reinstalled the IDS Server, setup a completely new NT Server with no other applications - just to be sure - and still have no success. The installation is set up with all default values then offers to start the IDS server but this fails. *NO* messages in the event viewer and just a start and stop hint in the dbserver.log. Starting the service with "-iy" gives the error message "Error 2140 internal NT error"... great...really :-((( Any hints for me? Desperately Axel
Post version info. What IDS version, including maintenance version (ie like 7.30TC2) and WinNT version and Service Packs. For one thing there are only a few of the latest versions that can run on SP4 or SP5, for example. Art S. Kagel Axel Sander wrote: > > Grraaaah, Informix and NT, still trying... > > I reinstalled the IDS Server, setup a completely new NT Server with no > other applications - just to be sure - and still have no success. The > installation is set up with all default values then offers to start the IDS > server but this fails. *NO* messages in the event viewer and just a start > and stop hint in the dbserver.log. Starting the service with "-iy" gives > the error message "Error 2140 internal NT error"... great...really :-((( > > Any hints for me? > > Desperately Axel
On Thu, 26 Aug 1999 12:14:18 -0400, "Art S. Kagel" <kagel@bloomberg.net>
wrote:
>Post version info. What IDS version, including maintenance version (ie
>like 7.30TC2) and WinNT version and Service Packs. For one thing there
>are only a few of the latest versions that can run on SP4 or SP5, for
>example.
>
>Art S. Kagel
This was my 2nd posting, so it seems, the first with all version info got
lost:
:I just tried to install an IDS Workgroup 7.30 TC9 on Win NT 4.0 SP 4. This
:is my first attempt on using IDS on an NT machine.
: ... and more ...
I finally solved this problem , thanks for all hints:
I started the DOS console for my server and did an "oninit -v" and got the
message "Server can only started by user informix" (This message is in the
event log, too, but I didn't check the security section.). Stupid thing, I
*am* logged in as 'informix'. Even the installation program found out,
there was an existing user 'informix'. I created this user before starting
the installation (The installation guide is not very clear on this point:
page 3 says: "check that user 'informix' is a member of the administrators
group", page 13 says: "The installation program now displays a page that
asks you to specify the password for user 'informix'. ... If the account
does not exist, the installation program creates the account" !!)
And then the solution hit my mind and I banged my head on the desk several
times: I created the user 'Informix' with an uppercase 'I' as the first
letter. The NT login is not case sensitive, the installation program seems
to do a case insensitive search, too. *But the service is doing an exact
match and fails* ..sigh!
I fixed this and my server starts...phew (now I got my first *really* bug
with IECC)
Axel - looking for a new desk (and maybe a new head, too ;-)
BTW: is there any informix mail address where you can drop hints or bugs?
Axel Sander wrote: > > On Thu, 26 Aug 1999 12:14:18 -0400, "Art S. Kagel" <kagel@bloomberg.net> > wrote: > > >Post version info. What IDS version, including maintenance version (ie > >like 7.30TC2) and WinNT version and Service Packs. For one thing there > >are only a few of the latest versions that can run on SP4 or SP5, for > >example. > > > >Art S. Kagel > > This was my 2nd posting, so it seems, the first with all version info got > lost: > > :I just tried to install an IDS Workgroup 7.30 TC9 on Win NT 4.0 SP 4. This > :is my first attempt on using IDS on an NT machine. > : ... and more ... Ah, I missed it anyway. > I finally solved this problem , thanks for all hints: Great! I'll have to remember this one! [SNIP] > times: I created the user 'Informix' with an uppercase 'I' as the first > letter. The NT login is not case sensitive, the installation program seems > to do a case insensitive search, too. *But the service is doing an exact > match and fails* ..sigh! [SNIP] BTW: is there any informix mail address where you can drop hints or bugs? You can open a support case from the Informix WEB site if you are a support customer with a TechInfo Center login (free). Tech support will escalate the case to a bug report if they find it warranted, reproduceable and not already fixed in later versions. Art S. Kagel