"Not implemented yet" error
Posted in 2000
Topics: General Discussion
If anyone have seen this error, would you, please help me out:
- [Informix][Dynamic Server 2000][content] SQL Error (-999) : Not
implemented yet.
Error comes out when I am trying to run select on two identical (replicated
tables) on two different servers ( one is a backup server).
SQL looks like this:
select * from db1@server1:tab1 a where a.tab1id not in ( select tab1id fromdb1@server2:tab1);
All other tables in this database are fine.
Any ideas, please...
Elena.
e-mail: ekorol@styleclick.com
IDS2000 error messages, in case of SQL referencing multiple servers, do leave
something to be desired.
For example, if the column names are not specified correctly (typos), one
could get errors as follows
9931: Byte and Text datatypes in row and collection types not allowed.
999: Not implemented yet.
217: Column (talid) not found in any table in the query (or SLV is undefine
999 usually occurs when the column in the remote database has been specified
incorrectly. 9931 & 217 occur when the mistake is made on the local database.
Further, the error message also seems to depend on how the optimizer executes
the query. For example,
select * from db1@server1:tab1 a where a.tab1id not in ( select tab1id fromdb1@server2:tab1);
is equivalent to
select a.* from db1@server1:tab1 a
where not exists (
select 1 from db1@server2:tab1 b
where a.tab1id = b.tab1id);
But, the error messages, in case of an incorrect column name, differ.
Of course, its eminently possible that there are other reasons for which the
999 is being spouted out. If you do find something else, please let us all
know.
Rudy
Elena Korol wrote:
> If anyone have seen this error, would you, please help me out:
>
> - [Informix][Dynamic Server 2000][content] SQL Error (-999) : Not
> implemented yet.
>
> Error comes out when I am trying to run select on two identical (replicated
> tables) on two different servers ( one is a backup server).
> SQL looks like this:
> select * from db1@server1:tab1 a where a.tab1id not in ( select tab1id from> db1@server2:tab1);
>
> All other tables in this database are fine.
>
> Any ideas, please...
>
> Elena.
>
> e-mail: ekorol@styleclick.com
This is a big big big problem we found out with IDS2000 (9.21)
It seems to be involved with "new" datatypes BLOB (also called "smartblob"):
if remote access points to a table which has a BLOB column, the server
returns "not implemented yet" error. Our technical support answered us (an
official answer, it can be said) that, simply, this functionality is not yet
implemented (!) and it will be not before 9.30 (late 2001).
We could say, thus, that Informix released some brand new datatypes, but you
hardly can access them (only if you are strictly in locale!)
Last but not least : this very huge problem is not mentioned at all in the
release notes, nor in the product documentation.
Elena Korol ha scritto nel messaggio <8vcd25$oo1$1@news.xmission.com>...
>
>If anyone have seen this error, would you, please help me out:
>
>- [Informix][Dynamic Server 2000][content] SQL Error (-999) : Not
>implemented yet.
>
>Error comes out when I am trying to run select on two identical (replicated
>tables) on two different servers ( one is a backup server).
>SQL looks like this:
>select * from db1@server1:tab1 a where a.tab1id not in ( select tab1id from>db1@server2:tab1);
>
>All other tables in this database are fine.
>
>Any ideas, please...
>
>Elena.
>
>e-mail: ekorol@styleclick.com
>
>
>