help-cannot get database up
Posted in 2000
Topics: Storage & Space Management
online.log : i/o error 'read' : expect 4096 actual -1 addr 0x0 errno 5 retrys2 i/o error, Primary chunk '/dev/rlv00' -- offline i/o read() chunk 1, pagenum 0, pagecnt 1 --> errno = 5 INFORMIX-online must abort root chunk down. * Sent from RemarQ http://www.remarq.com The Internet's Discussion Network * The fastest and easiest way to search and participate in Usenet - Free!
Man I hate those errno-5 errors. They don't really tell you very much. I wish that OS errors could be a bit more specific. OK - here's the situation. Actually if you are going to get this type of problem, the point that you got it is probably the best place of all. You were in the probess of reading the reserved pages while bringing up the server. Since you were unable to read the reserved pages, you did not actually issue any changes to any physical disk. That might be a blessing because if the physical disk is still there, then you should be able to come back up once the OS issue is resolved. You need to contact tech support. They will attempt to see if the root chunk is accessable or not, probably by using 'dd'.. This might be a faulty controller card, but it could be a head crash. If it is a faulty controller issue, then repairing the controller should be fairly easy. If it is a head crash, then you will be facing a restore onto a replaced disk. PTI-Kathy wrote: > online.log : > i/o error 'read' : expect 4096 actual -1 addr 0x0 errno 5 retrys2 > i/o error, Primary chunk '/dev/rlv00' -- offline > i/o read() chunk 1, pagenum 0, pagecnt 1 --> errno = 5 > INFORMIX-online must abort root chunk down. > > * Sent from RemarQ http://www.remarq.com The Internet's Discussion Network * > The fastest and easiest way to search and participate in Usenet - Free! -- Madison Pruet =========================================== Enterprise Replication Product Developement Dallas, Texas Informix Software ===========================================