Run out of locks !
Posted in 2000
Topics: Error Codes & Troubleshooting, Migration, Import/Export & Data Conversion, Platform-Specific Issues
Hi all: I kept getting SQL error -240 which is ISAM error -121 for Standard Engine 7.24 on HP-UX 11.0 when I tried to delete rows from a single table. But if I lock the table first, then the problem is gone. I figured the problem could arise from running out of the lock limit that Engine set, so I called Informix tech support. But they said there is nothing I can do to increase the lock limit since this is SE ! Then I turned to HP tech support, they suggested several changes on kernel configuration parameter including nflocks, nfile, ninode and maxdsiz. Well, it didn't work either. I don't think that's a right approach because I 'm dealing with single file only. This is really driving me nuts because I don't have this problem on SCO Unix. I have only few days left to do data migration from SCO to HP but now I am stuck. If changing the program syntax is the only thing I can do, then I have A BUNCH of programs need to be done within 120 hours. *** SIGH *** Any help will appreciate
Havey, You have to design your programs in such a way that it uses minimum no of locks. You can do this either by locking the table (if possible) and using Page level locking. Also see if you can set isolation level to dirty read. If you're using cursors then dump the table into temp table and then use that temp table to buidl the cursor that way your original table is not locked. You have to weigh between default locking for the table.If the table is volatile then it should have row level locking but if generally queryable then leave it at page level. SE doesn't have configuration parameters so it has to be enforced manually. Vivek Chaudhary On Wed, 26 Apr 2000 10:14:27 -0700, "Havey Chen" <harvey@laloo.com> wrote: > >Hi all: > >I kept getting SQL error -240 which is ISAM error -121 for Standard Engine >7.24 on HP-UX 11.0 when I tried to delete rows from a single table. But if >I lock the table first, then the problem is gone. > >I figured the problem could arise from running out of the lock limit that >Engine set, so I called Informix tech support. But they said there is >nothing I can do to increase the lock limit since this is SE ! Then I >turned to HP tech support, they suggested several changes on kernel >configuration parameter including nflocks, nfile, ninode and maxdsiz. Well, >it didn't work either. I don't think that's a right approach because I 'm >dealing with single file only. > >This is really driving me nuts because I don't have this problem on SCO >Unix. I have only few days left to do data migration from SCO to HP but now >I am stuck. If changing the program syntax is the only thing I can do, then >I have A BUNCH of programs need to be done within 120 hours. *** SIGH *** > >Any help will appreciate >
Related threads
- Re(2): Write cache hits slipping !
- same View fails to run under IDS 10
- number of extents
- ONCONFIG file only for server or for informix client