Red Hat Linux IDS Installation Problems
Posted in 1999
Topics: Installation, Setup & Upgrades, Connectivity: ODBC / JDBC / .NET, Networking & sqlhosts Configuration, Platform-Specific Issues
Hi all,
I'm a long time SE user, new to online.
The problem I'm having:
I initialize with oninit -i, then
onstat -m give me these errors
04:38:09 Building 'sysmaster' database ...
04:38:16 Error building 'sysmaster' database.
04:38:16 See '/tmp/buildsmi.4347'.
Our System info:
Red Hat Linux V6.0
Engine: 7.3.UC7-2
/usr/informix/sqlhosts: tin_ids sesoctcp tin.bdsn.com ids1
/etc/services: ids1 1537/tcp #Informix IDS
The problem seems to be that the scripts that build the sysmaster database
won't find the server. They only refer to the database name.
If I run 'isql cms', the system responds with 'database not found or no
system permission'.
If I run 'isql cms@tin_ids', it opens the database just fine.
Any ideas?
Thanks in advance
Have you set the INFORMIXSERVER environment variable to point to the
servername, thus:
export INFORMIXSERVER=tin_ids
Do this in the engine's environment as well and shutdown and restart.
The sysmaster build will be attempted again. If if fails run the
$INFORMIXDIR/lib/buildsmi script by hand, it usually works that way in
the rare instance that it fails during the boot.
Art S. Kagel
Craig Bellusci wrote:
>
> Hi all,
>
> I'm a long time SE user, new to online.
>
> The problem I'm having:
> I initialize with oninit -i, then
> onstat -m give me these errors>
> 04:38:09 Building 'sysmaster' database ...
> 04:38:16 Error building 'sysmaster' database.
> 04:38:16 See '/tmp/buildsmi.4347'.>
> Our System info:
> Red Hat Linux V6.0
> Engine: 7.3.UC7-2
> /usr/informix/sqlhosts: tin_ids sesoctcp tin.bdsn.com ids1
> /etc/services: ids1 1537/tcp #Informix IDS
>
> The problem seems to be that the scripts that build the sysmaster database
> won't find the server. They only refer to the database name.
>
> If I run 'isql cms', the system responds with 'database not found or no
> system permission'.
> If I run 'isql cms@tin_ids', it opens the database just fine.
>
> Any ideas?
>
> Thanks in advance
Hi Art,
Thanks for replying.
Yes, I have the INFORMIXSERVER variable set. I can build and work with
databases through isql or dbaccess. I just have to make certain to use
dbname@tin_ids instead of just dbname. I edited the files
$INFORMIXDIR/etc/buildsmi and $INFORMIXDIR/etc/bldutil.sh to have all
references to databases add the @tin_ids, and the sysmaster database built
just fine. (Thanks for that hint Rick!)
Now that the sysmaster database is built properly, I thought the other
problem(s) I'm having would go away, but they haven't. I rcp'd a couple of
things over that work on our 7.2 SE running on an IBM AIX computer. Neither
works on the Linux IDS. The first one is a dbexport from the SE. It fails at
different points each time, but always with the same error.
create table "informix".cs_claim
(
rpt_unit_id char(5),
case_id char(10),
event_date date
);
*** put loadcur
25580 - System error occurred in network function.
*** database
404 - The cursor or statement is not available.
*** database
349 - Database not selected yet.
The other one is from an sql script run from choose--run within isql or
dbaccess run as user informix. It fails with:
CREATE PROCEDURE sp_xmit_cl(c_table CHAR(18), c_rpt_unit CHAR(5),
c_case CHAR(10), c_ser_no INTEGER,
c_old_rec_date DATE, c_new_rec_date DATE,
c_action CHAR(2))
DEFINE c_payor CHAR(10); -- We find the payor, and put in here
# ^
# 201: A syntax error has occurred.
Both the dbimport and the sql script work properly on the SE/IBM
combination.
Thanks,
Craig
Art S. Kagel <kagel@bloomberg.net> wrote in message
news:376827CD.60D6C39@bloomberg.net...
> Have you set the INFORMIXSERVER environment variable to point to the
> servername, thus:
>
> export INFORMIXSERVER=tin_ids>
> Do this in the engine's environment as well and shutdown and restart.
> The sysmaster build will be attempted again. If if fails run the
> $INFORMIXDIR/lib/buildsmi script by hand, it usually works that way in
> the rare instance that it fails during the boot.
>
> Art S. Kagel
>
> Craig Bellusci wrote:
> >
> > Hi all,
> >
> > I'm a long time SE user, new to online.
> >
> > The problem I'm having:
> > I initialize with oninit -i, then
> > onstat -m give me these errors> >
> > 04:38:09 Building 'sysmaster' database ...
> > 04:38:16 Error building 'sysmaster' database.
> > 04:38:16 See '/tmp/buildsmi.4347'.> >
> > Our System info:
> > Red Hat Linux V6.0
> > Engine: 7.3.UC7-2
> > /usr/informix/sqlhosts: tin_ids sesoctcp tin.bdsn.com ids1
> > /etc/services: ids1 1537/tcp #Informix IDS
> >
> > The problem seems to be that the scripts that build the sysmaster
database
> > won't find the server. They only refer to the database name.
> >
> > If I run 'isql cms', the system responds with 'database not found or no
> > system permission'.
> > If I run 'isql cms@tin_ids', it opens the database just fine.
> >
> > Any ideas?
> >
> > Thanks in advance
On Wed, 16 Jun 1999 14:57:34 -0700, "Craig Bellusci" <craig@bdsn.com> wrote: >Our System info: > Red Hat Linux V6.0 > Engine: 7.3.UC7-2 > /usr/informix/sqlhosts: tin_ids sesoctcp tin.bdsn.com ids1 > /etc/services: ids1 1537/tcp #Informix IDS From other posts, it sounds like you solved your problem. However, I did want to point out that your sqlhosts should be using a protocol of "onsoctcp" not "sesoctcp" (which specifies an SE server). Dave