Error -172
Posted in 2018
Topics: Error Codes & Troubleshooting, Connectivity: ESQL/C, 4GL & Embedded SQL, Transactions, Locking & Isolation
Hi all,
with one of our 4gl-programs we occaisonally get the following errors:
Program stopped at
"//home/projekte/qualifiziert/qualifiziert_5.0/qual_del.4gl", line number 1606.
Date: 13.07.2018 Time: 19:43:30
Program error at "//home/projekte/qualifiziert/qualifiziert_5.0/qual_del.4gl",
line number 1606.
SQL statement error number -244.
Could not do a physical-order read to fetch next row.
SYSTEM error number -172.
ISAM error: Unexpected internal errorSQL statement error number -244.
Could not do a physical-order read to fetch next row.
SYSTEM error number -172.
ISAM error: Unexpected internal error
finderr 244
expr: syntax error
-244 Could not do a physical-order read to fetch next row.
The database server cannot read the disk page that contains a row of a
table. Check the accompanying ISAM error code for more information. A
hardware problem might exist, or the table or index might have been corrupted.
If the query was using the dirty read isolation level, this error code may be
normal behavior caused by reading data that was in a temporarily inconsistent
state from a concurrent update on the same data.
Unless the ISAM error code or an operating-system message points to another
cause, run the oncheck utility (secheck with IBM Informix SE or tbcheck with
IBM Informix OnLine) to check and repair table and index.
finderr 172
expr: syntax error
-172 ISAM error: Unexpected internal error.
You encountered an unanticipated internal event. Consult the online.log
to see if the diagnostics preserved any additional information
regarding this event. If the error recurs, refer to your Administrator's
Guide to acquire additional diagnostics. Contact IBM Technical Support
with the diagnostic information.
There are no messages in online.log.
What can we do to find the reason for the error -172.
TIA,
Reinhard.
Sorry, I forgot: 12.10.FC10 on Solaris10 Sparc64, update from 12.10.FC4W1XB 3 weeks ago.
Sorry again, found these messages in the online.log of the second database server that is part of the distributed transaction. The program fills tables in the second database server from data of the first server. 07/13/18 19:43:11 Logical Log 780080 Complete, timestamp: 0xe875d6dc. 07/13/18 19:43:12 Logical Log 780080 - Backup Started 07/13/18 19:43:12 Assert Failed: ls_next: pagenum = 794305 < first_lpage; lsbufp = 13382bdb0 07/13/18 19:43:12 IBM Informix Dynamic Server Version 12.10.FC10AEE 07/13/18 19:43:12 Who: Session(1406782, autoqual@B60DBS0S, 20654, 1195056b8) Thread(1447651, srvinfx, 12a0afb48, 11) File: rslight.c Line: 856 07/13/18 19:43:12 Action: Please notify IBM Informix Technical Support. 07/13/18 19:43:12 stack trace for pid 21050 written to /var/tmp/informixdump/af.1acbe4af 07/13/18 19:43:12 See Also: /var/tmp/informixdump/af.1acbe4af, shmem.1acbe4af.0 07/13/18 19:43:13 Logical Log 780080 - Backup Completed 07/13/18 19:43:30 ls_next: pagenum = 794305 < first_lpage; lsbufp = 13382bdb0 07/13/18 19:43:32 Logical Log 780081 Complete, timestamp: 0xe87d4190. I will open a PMR in parallel.