ISQL cannot connect to Dbserver error -930
Posted in 2007
User on IDS 10 UC6 (SUSE 9) could run ISQL 7.3 fine over a shared-memory (onipcshm) server, but got error -930 after switching INFORMIXSERVER/DBSERVERNAME to a TCP (onsoctcp) server needed for HDR. Art Kagel explained ISQL installed in a separate directory picks up its own connection library that lacks network support; putting the engine's lib directory first in LD_LIBRARY_PATH fixed it (and DBSERVERALIASES can keep a shm connection for local clients). This worked. A follow-up on automatic client failover was answered: use DBPATH, or an sqlhosts group entry containing both HDR nodes and connect via the group name, noting failover only occurs at connect time.
Auto-generated by DrWatson from the posts below — may be imperfect; read the full thread.
Topics: Networking & sqlhosts Configuration
Hi All, I am facing some problem with ISQL 7.3. currently i am using ids10 UC6 on SUSE 9 ES following is the problem. ISQL is working fine when i am using onipcshm instance as INFORMIXSERVER and DBSERVERNAME, as HADR requires onsoctcp instance, the moment i Change the instance name in INFORMIXSERVER and DBSERVERNAME i am not able to use isql to connect the database. it is throwing error -930. can some one help me in this. and also let me know whether isql only connects using shared memory instance if no please let me know any modification that has to be made. Thanks Deepak Biswas
First, HDR doesn't prevent you from having a shared memory connection, it just needs a networked connection for itself. You can use DBSERVERALIASES to set up a shared memory connection for ISQL and other local clients to use as their INFORMIXSERVER value and set the DBSERVERNAME to the networked connection name for HDR and use that on the secondary to refer to the primary. As to why ISQL isn't using the networked connection successfully, have you installed ISQL in a different directory than the engine? If so, you're probably using ISQL's default connection library which IB does not support networks. If so, just put the engine install directory's lib subdir first in LD_LIBRARY_PATH, that should fix the secondary problem. Art S. Kagel ----- Original Message ----- From: Deepak Biswas <ids@iiug.org> At: 8/15 4:11:49 Hi All, I am facing some problem with ISQL 7.3. currently i am using ids10 UC6 on SUSE 9 ES following is the problem. ISQL is working fine when i am using onipcshm instance as INFORMIXSERVER and DBSERVERNAME, as HADR requires onsoctcp instance, the moment i Change the instance name in INFORMIXSERVER and DBSERVERNAME i am not able to use isql to connect the database. it is throwing error -930. can some one help me in this. and also let me know whether isql only connects using shared memory instance if no please let me know any modification that has to be made. Thanks Deepak Biswas ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.
Hi ART KAGEL, Thanks a lot for the input it's working fine now. can you help me out by giving some information on how can we automatically redirect client when one instance is down in HADR.
Have a look at the Fine HDR Manual. It walks through setting up a group in sqlhosts, to which both nodes belong, you then connect to the group and allow the engine to decide who is awake enough to take your call. j. -----Original Message----- From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org]On Behalf Of DEEPAK BISWAS Sent: Thursday, August 16, 2007 2:09 AM To: ids@iiug.org Subject: Re:ISQL cannot connect to Dbserver error -930 [9797] Hi ART KAGEL, Thanks a lot for the input it's working fine now. can you help me out by giving some information on how can we automatically redirect client when one instance is down in HADR. **************************************************************************** *** Forum Note: Use "Reply" to post a response in the discussion forum.
Please let me know how do i redirect clients automatically in case i am using HADR setup.
DEEPAK BISWAS wrote: > Please let me know how do i redirect clients automatically in case i am using > HADR setup. > It's been absolute ages since I've been able to answer a technical question so effectively: RTFM. -- This message has been scanned for viruses and dangerous content by OpenProtect(http://www.openprotect.com), and is believed to be clean.
HADR (DB2) or HDR (IDS) ? For HDR on IDS9.4 and up, create a group entry in the SQLHOST file, pla= ce the two nodes comprising the HDR pair into the same group, and then reference the server by the group name instead of the server name. If = you are using JAVA, you will need to use the service number rather than the= service name in the sqlhost file. As an example.... group_1 group - - inst1_prim onsoctcp primaryMachine 10234 g=3Dgroup_1 inst1_sec onsoctcp secondaryMachine 10234 g=3Dgroup_1 Then when you connect to a database (myDB) instead of issueing the connection request to "myDB@primaryMachine", you would issue the reques= t to "myDB@group_1". I don't know the rules for setting up JDBC to use the= sqlhost file to resolve the connection string address, but I do know th= at it is documented. This technique will cause the connect to be made to the primary node, t= hus if a failover should occur, you would still be connected to the current= primary machine. M.Pruet = "DEEPAK BISWAS" = <deepak.biswas19@ = gmail.com> = To Sent by: ids@iiug.org = ids-bounces@iiug. = cc org = Subj= ect Re:ISQL cannot connect to Dbserv= er 08/17/2007 06:05 error -930 [9804] = AM = = = Please respond to = ids@iiug.org = = = Please let me know how do i redirect clients automatically in case i am= using HADR setup. ***********************************************************************= ******** Forum Note: Use "Reply" to post a response in the discussion forum. =
You can either set DBPATH to the alternate server or set INFORMIXSERVER to an sqlhosts group containing the two HDR servers with the primary listed in the group first. Note, IDS client failover happens at connect time. Existing sessions will fail and those clients will have to reconnect. If they are services or long running tasks with prepared statements and cursors, all prepared statements and cursors have to be recreated after reconnecting to the back up server. Art S. Kagel ----- Original Message ----- From: Deepak Biswas <ids@iiug.org> At: 8/17 7:05:54 Please let me know how do i redirect clients automatically in case i am using HADR setup. ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.