Translating with DrWatson… this can take a few seconds the first time.
This is a genuine, complex translation. DrWatson protects commands, error codes, and log output while naturally translating the surrounding text. It’s translated once and saved.
Art S. Kagel — — source: Usenet: comp.databases.informix
Anand Iyer wrote:
> I have 2 informix instance (IDS 9.30 UC3 & IDS 9.40 UC 2)
>
> MY QUERY IS THE BUFWAITS VALUE OF THE FIRST INSTANCE IS VERY HIGH AS
> COMPARED TO THE SECOND INSTANCE.
>
> DOES THIS PROBLEM WILL BE RECITIFED BY INCREASING THE LOGFILES VALUE IN
> ONCONFIG , OR DO I NEED TO LOOK OUT FOR SOMEOTHER PARAMETER
>
> attaching the onstat -p output of IDS 9.30 UC3Profile
> dskreads pagreads bufreads %cached dskwrits pagwrits bufwrits %cached
> 2383589 18542774 2115624270 99.89 3564883 7238757 142643416 97.50
<SNIP>
> bufwaits lokwaits lockreqs deadlks dltouts ckpwaits compress seqscans
> 7985532 140951 3969872588 2 0 5008 1951805 408539429
<SNIP>
This is just volume related. Everything is normal. If you calculate the
Bufwaits ratio for this server it is < 5 which is a perfectly healthy value.
If you have performance problems, bufwaits is not it. Bufwaits is higher
for this instance because the activity volume is 4 times higher and likely
there are fewer users connected doing simultaneous work. Bufwaits are
caused by multiple sessions needing to move a disk page into the cache or to
create a new page in cache and either having to wait for a buffer to be
released by another session or for the LRU containing the selected buffer to
reuse was latched by another session doing the same thing to another page
managed by that LRU queue.
Art S. Kagel
We use strictly necessary cookies to make this site work. With your
consent we’d also use optional cookies for analytics and marketing. You can accept all,
reject all, or choose. Read our Cookie Policy.