RE: On the behalf of another hapless soul, v.5.10 issue
Posted in 2000
This sounds like an OS tcp configuration problem, the users
that can't reconnect are problem being blocked in some sort
of FINWAIT type problem, what are you seeing on the netstat
when this occurs and what are your kernel tcp settings
Paul Watson
WF Software Ltd
Tel: +44 1436 674729
Fax: +44 1436 678693
www.wfsoftware.com/informix
> -----Original Message-----
> From: Impy [mailto:wlinden@stritch.edu.spam@me.not]
> Sent: Friday, August 18, 2000 04:41
> To: informix-list@iiug.org
> Subject: On the behalf of another hapless soul, v.5.10 issue
>
>
> Informix 5.10.UC1 and Sco Unix Unix 3.2.
>
> Under the Informix command "tbstat -u", a maximum of 300
> active sessions
> allowed. At month-end, 220+ active sessions at is reached
> any given time.
> The problem is that once we reach 220 or more sessions, we
> start receiving
> tcp/ip connection errors, example as follows "Unable to
> connect to Elite TCP
> server" most likely cause: service (eiselbs) at port address
> 8007 is not
> running onhost (elite1) at IP address 204.120.117.23",
> sometimes followed by
> the error message "TCP/Sockets error during function connect () Error:
> WSAECONNREFUSED (10061) Connection refused"
>
> Most users receiving these errors cannot reestablish connection to the
> server until we reboot Informix.
> The OLTP application (Elite) employs the winsock tcp/ip protocol.
> We tell users to limit their access, but still run into this
> problem every
> other month.
>
> Any suggestions/feedback would be greatly appreciated.
>
> Version 5.10.UC1
> #*************************************************************
> *************
> #
> # INFORMIX SOFTWARE, INC.
> #
> # Title: tbconfig.std
> # Sccsid: %W% %G% %U%
> # Description: INFORMIX-OnLine Configuration Parameters
> #
> #*************************************************************
> *************
>
> # Root Dbspace Configuration
>
> ROOTNAME rootdbs # Root dbspace name
> ROOTPATH /dev/rootdbs # Path for device containing> root dbspace
> ROOTOFFSET 0 # Offset of root dbspace into device
> (Kbytes)
> ROOTSIZE 1000000 # Size of root dbspace (Kbytes)>
> # Disk Mirroring Configuration
>
> MIRROR 0 # Mirroring flag (Yes = 1, No = 0)
> MIRRORPATH # Path for device containing> root dbspace
> mirror
> MIRROROFFSET 0 # Offset into mirror device (Kbytes)>
> # Physical Log Configuration
>
> PHYSDBS rootdbs # Name of dbspace that
> contains physical log
> PHYSFILE 20000 # Physical log file size (Kbytes)>
> # Logical Log Configuration
>
> LOGFILES 23 # Number of logical log files
> LOGSIZE 10000 # Size of each logical log
> file (Kbytes)>
> # Message Files
>
> MSGPATH /elite/work/logs/online.log # OnLine message
> log pathname
> CONSOLE /dev/tty01 # System console message pathname>
> # Archive Tape Device
>
> #TAPEDEV /dev/null # Archive tape device pathname
> TAPEDEV /dev/rStp1 # Archive tape device pathname
> TAPEBLK 20 # Archive tape block size (Kbytes)
> TAPESIZE 11700000 # Max amount of data to put
> on tape (Kbytes)>
> # Logical Log Backup Tape Device
>
> LTAPEDEV /dev/rStp0 # Logical log tape device pathname
> LTAPEBLK 20 # Logical log tape block size (Kbytes)
> LTAPESIZE 11700000 # Max amount of data to put> on log tape
> (Kbytes)
>
> # Identification Parameters
>
> SERVERNUM 1 # Unique id associated with> this OnLine
> instance
> DBSERVERNAME ONLINE_LIVE # Unique name of this OnLine instance>
> # Shared Memory Parameters
>
> RESIDENT 0 # Forced residency flag (Yes
> = 1, No = 0)> USERS 300 # Maximum number of concurrent user
> processes
> TRANSACTIONS 300 # Maximum number of
> concurrent transactions
> LOCKS 190000 # Maximum number of locks> #BUFFERS 64000 # Maximum number of shared
> memory buffers
> BUFFERS 100000 # Maximum number of shared> memory buffers
> TBLSPACES 3000 # Maximum number of active tblspaces
> CHUNKS 50 # Maximum number of chunks
> DBSPACES 20 # Maximum number of dbspaces
> and blobspaces
> PHYSBUFF 32 # Size of physical log
> buffers (Kbytes)
> LOGBUFF 32 # Size of logical log buffers (Kbytes)> LOGSMAX 40 # Maximum number of logical log files
> CLEANERS 8 # Number of page-cleaner processes
> SHMBASE 0x80000000 # Shared memory base address
> CKPTINTVL 300 # Checkpoint interval (in seconds)
> LRUS 8 # Number of LRU queues
> LRU_MAX_DIRTY 10 # LRU modified begin-cleaning limit
> (percent)
> LRU_MIN_DIRTY 5 # LRU modified end-cleaning
> limit (percent)
> LTXHWM 50 # Long TX high-water mark (percent)
> LTXEHWM 60 # Long TX exclusive high-water mark
> (percent)>
> # Machine- and Product-Specific Parameters
>
> DYNSHMSZ 0 # Dynamic shared memory size (Kbytes)
> GTRID_CMP_SZ 32 # Number of bytes to use in GTRID
> comparision
> DEADLOCK_TIMEOUT 60 # Max time to wait for lock> in distributed
> env.
> TXTIMEOUT 300 # Transaction timeout for I-STAR (in
> seconds)> SPINCNT 0 # No. of times process tries for latch
> STAGEBLOB # Reserved for INFORMIX-OnLine/Optical
>
> # System Page Size
>
> BUFFSIZE 2048 # Page size (do not change!)
>
>
>
>
>
>