Unable to bind to the port
Posted in 2015
Topics: High Availability & Replication, Networking & sqlhosts Configuration, Platform-Specific Issues
Hi,
Informix 11.7.FC8
HP-UX 11.31
I am setting up an SDS server. The primary starts successfully but when I run
the oninit command on a SDS server I get the following error:
"Assert Warning: Unable to bind to the port (9999) on the host (999.99.9.99)
for the server (primary)."
I have checked the sqlhosts and /etc/services files on both servers(primary
and sds).
Wat could be the problem ?
Most likely something is already using that port on the box.
Run the following grep'ing for the port you are trying to use for the SDS
server:
netstat -n -a | grep \\\\.9999
Art
Art S. Kagel, President and Principal Consultant
ASK Database Management
www.askdbmgt.com
Blog: http://informix-myview.blogspot.com/
Disclaimer: Please keep in mind that my own opinions are my own opinions
and do not reflect on the IIUG, nor any other organization with which I am
associated either explicitly, implicitly, or by inference. Neither do
those opinions reflect those of other individuals affiliated with any
entity with which I am affiliated nor those of the entities themselves.
On Thu, Aug 20, 2015 at 7:27 AM, FLIP VAN WYNGAARDT <flipv@raf.co.za> wrote:
> Hi,
>
> Informix 11.7.FC8
> HP-UX 11.31
>
> I am setting up an SDS server. The primary starts successfully but when I
> run
> the oninit command on a SDS server I get the following error:
>
> "Assert Warning: Unable to bind to the port (9999) on the host
> (999.99.9.99)
> for the server (primary)."
>
> I have checked the sqlhosts and /etc/services files on both servers(primary
> and sds).
>
> Wat could be the problem ?
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--089e01184e480fc657051dbddc88
Usually the port number is locked by the OS. Depending on how you confi=
gure
access you may try another port number but there may be some dependenci=
es
which makes this not a viable solution. Else I will bounce the OS to
release the port number. First, check with your admin to see if there i=
s
another way to free the port number besides bouncing the OS. I had that=
issue many times here on Solaris and HP. The admin ended up rebooting t=
he
OS each time.
jp
=
From: "FLIP VAN WYNGAARDT" <flipv@raf.co.za> =
=
To: ids@iiug.org =
=
Date: 08/20/2015 08:28 AM =
=
Subject: Unable to bind to the port [35616] =
=
Sent by: ids-bounces@iiug.org =
=
Hi,
Informix 11.7.FC8
HP-UX 11.31
I am setting up an SDS server. The primary starts successfully but when=
I
run
the oninit command on a SDS server I get the following error:
"Assert Warning: Unable to bind to the port (9999) on the host
(999.99.9.99)
for the server (primary)."
I have checked the sqlhosts and /etc/services files on both servers(pri=
mary
and sds).
Wat could be the problem ?
***********************************************************************=
********
Forum Note: Use "Reply" to post a response in the discussion forum.
=