Threads from 2015
Browse by month: Jan · Feb · Mar · Apr · May · Jun · Jul · Aug · Sep · Oct · Nov · Dec
Re: ISM recycling
Hello: If some has this doubt. ISM doesn't delete any file inside operating system, just update records in informix database. So if you need to delete old backups from your disk use onsmsync to sync your backup policies with sysdbase and them delete or move any old files from op…
How to know the current isolation level in ESQL/C?
please see the subject.…
How to determine most recent access to a database
We have an informix instance with 11 databases and it's been live since 2002. The application team that uses them have no recollection for what 4 of the databases are used for and how long it's been since they've been updated or accessed. How can I determine how recent any of the…
systabinfo ti_flags and index partition
Greetings. Solaris 10, IDS 11.5 I am trying to write a utility to examine some internal structures within sysmaster. Specifically, a query concentrating on systabnames and systabinfo. I need to treat index partitions differently from a table partition. But how do I tell the dif…
Migrate from IDS 11.50.UC6 to 11.70.FC8W1
Migrate from IDS 11.50.UC6 (32-bit) to 11.70.FC8W1 (64-bit) Hi All, We are planning to migrate from 11.50.UC6 to 11.70.FC8W1 on RedHat Linux (uname m => x86_64) server. When we referred the IBM Informix Migration Guide Version 11.70; came across our special requirement that i…
ISM recycling
Hello, Everyone. I'm testing IDS, ISM and onbar. Today I'm able to do : backup, restore it, add volumes to ISM, remove volumes to it, add user to ISM, delete user from ISM, mount volumes, umount volumes, add device remove devices But I'm not to able to get retention po…
860: A fragmented object must have more than one f
Hi, This is regarding table fragmentation in informix 11.70 FC7 running on AIX 6.1. Every year end we have a procedure to create additional dbspace and allocate a new fragmentation for the next txndate on that new dbspace. i.e tablename - historytable new dbspace (for next yea…
Enterprise Replication initial load performance
Informix 11.70 FC7 - AIX 1.Is there a method to use HPL (High Performance Loader)and avoid having to CDR SYNC or CDR CHECK ? 2.and/or what configuration parameters should we tune for higher throughput? 390,000,000 row table with a single index, the primary key. cdr sync …
Saving/Restoring dbspace(s) only
Hi to all, i work with informix 11.50 and 11.70, and i'm wondering if i can save only one or some dbspaces and restore them ? thanks in advance…
howto free space on ism mounted device
Hello: Is there any way to delete onbar backups? My device is near out of space. I tried to set retention days to 10 days ism_config -retention 10 and do onsmsync with no sucess. May I restart ism daemon after change retention days? Thnak you. --94eb2c062a4cf7701405277e93…
SDS_ENABLE is not set error after server restart
Hi all, Informix 11.10 We are moving to new servers and while I have time I wanted to set up an HDR pair to test failover back and forth before I put these into production. From our existing primary, I did a level 0 dump over the wire to the new server. ontape -s -L 0 -F -t S…
onstat -d
I am sure it must exist Does someone have a script to give a pretty layout of onstat -d ............. The dbspace, and following that the chunks belonging to that dbspace ? My company decided not to stick to naming conventions, and now I am trying to match dbspaces with chunks …
Migration data error
Hi Gurus, Just want to ask what do you mean by this error. this happens during migration from one box to another. Cannot update system catalog (sysdefaults). [Failed SQL: ALTER TABLE dbname.message ADD comment1 LVARCHAR(4000)] IDS 11.7 Thank you in advance.…
Admin tools available
We're going to be implementing multi-tenant instances. The schema will all be in sync and the same so we're going to have to update them all at one time. I have been asked to find a product that will do this rather than write a script to do it. For example I will have instance th…
Disable Triggers
Hi, We are running Informix 11.70.FC7. Is there a way to disable triggers on a table for a specific session and not for all sessions? As user Informix we need to do monthly processing to delete/archive older records from tables however we do not want the triggers on the tables …
Network traffic usage
Hi, I have some problems with some clients working over slower lines, I would like to have one idea about traffic that occurs over my database connections on easy way. Like MegaBytes on real time, I have used wireshark but it just gives individual packets but I need to have info…
Chunks Down Help
IDS: 7.31.UC5 OS: MPRAS We had an earlier disk outage, which took one of our DBspaces down. They fixed the disk issue, I hope and rebooted the server, but the chucks are still in down status. I've tried the following, but doesn't work: SMP500-4:/usr/informix [13575] onspaces -…
Number of bit map pages to be logged in critcal se
Folks, IDS 12.10 FC4. Any comments on the following info ? Thanks Frank 7:47:44 Logical Log 149588 Complete, timestamp: 0xf7354a06. 17:47:50 CDR Spool transaction queue completed 17:50:54 Physical Logging during partition extend: Number of bit map pages to be logged in critc…
unable to delete rows on ph_alert and ph_alerts
Hello I'm trying to delete rows in ph_alert table doing this sql command: delete from ph_alerts; (I know this delete every row in the table) In this table there is just 6 rows belonging to 2014, but when i do this i get the next mesage "Could no delete a row, ISAM error not fo…
Performance issue
Hi, I have a performance problem, when I Launch a workload batch which do many updates on a huge table, it work well but when I launch in parrallel an other batch wich delete many rows from an other partionned table, the perfomance for the first batch slow down dramaticaly, so wh…
Migrate 11.7 Informix database to an other server
Hi, I have a huge informix 11.7 database on a Windows 2008 r2 (more than 1.5 TB), I have installed an other empty database with the same driver and the same strutcure of chunks and dbsapce and also onconfig, I planify to replicate this database on the second server, I'm wondering…
Fwd: OPDBMS feedback for Gartner
(sorry if this shows up as duplicate, but my first attempt doesn't seem to have arrived) Folks, Gartner has opened the Pandora box.... You can now provide feedback on your favorite RDBMS. Please see this blog entry from Gartner's VP Merv Adrian: http://blogs.gartner.com/merv-a…
new features about dynamic parameter added in 12.1
HI, I checked new feature of V 12.1 in the information center , and kown added some parameter that can be changed dynamicly, but information center don't list those parameters , could anyone provide those parameter list can be changed dynamicly in v 12.1? but can't changed dynam…
GSKit fix
Hi, IBM has just put out a security advisory about GSKit: http://www-01.ibm.com/support/docview.wss?uid=swg21971857 Has anyone else noticed that: 1. All download links take you to the same version, although what this is can vary. First of all I got Linux x86_64 but now I cons…
Long checkpoint
Hi iiug team, May i ask your help on how can i trap or any utilities available to trap what is causing the long checkpoint in my production db. It is running IDS 11.7FCx in AIX 7. This doesn't happened before just started last month and it's not consistently showing. Here are t…
oninit taking ages
Hi all, before I post a PMR: did anyone see an informix instance take 25mn to start ? 25 minutes was with 12.10FC4 on a linux/red hat VMWare (big server according to the vendors) With 12.10FC5W1, i had to wait 46 mn before deciding to kill oninit. I am using huge pages and RESI…
onstat -g ses - getting the pid
I am running 11.50.FC7 on Solaris 10 Sparc. I have a couple of tables that are locked. I am trying to see what is locking them. I ran onstat -g sql to determine some ids that were associated with the tables. I then ran onstat -g ses to get the pid of the session. For these par…
IIUG 2016 Update and Final Call for Speakers
If you haven't heard, IIUG 2016 will be in Jacksonville, FL USA May 4 to May 8, 2016 at the Sawgrass Marriott Golf Resort and Spa. Early Registration includes a $275 discount off the regular registration price and ends February 4, 2016. Register for IIUG 2016 at http://www.iiug…
IDS Evaluation License time limit
Hello, I've been doing some evaluation/testing with a 11.70 IDS demo Enterprise version on a linux box. And from the begining, I've got regular messages on the time limit period of that version. But now, my evaluation/testing is not finished yet and the free license is about to…
Performance impact of SQLTRACE
Hi all, Pretty much still an informix newbie but I've searched and haven't found an answer. On Informix 11.10, is there a significant performance impact to turning on global SQLTRACE through onconfig? We've got problem queries that need to be addressed and it seems like this mi…
question about enable compression
HI, I could do online repack and online shrink with below script. 1,running a program to do the insert for the user table; 2,execute function task(enable compression,testab,'userdb',informix); 3,execute function task(table repack',testab,'userdb',informix); 4,execu…
sysadmin:mon_users table too large
I have an IDS 12.10.FC4W1WE server. I noticed that the sysadmin:mon_users table has been allocated 5.0GB of space which seems excessive given there are only 32445 rows in the table. How can I safely decrease the size of this table? The sysadmin database is in the rootdbs to add t…
What to learn about the New Informix Toys and Tool
Folks, Our Next Webcast is New Informix Toys and Tools - NoSQL, Mongodb Support, Data Streams with Node-RED and new useful features and utilities by Tom Beebe With the emergence of 'Internet of Things' (IoT) we are all collecting more data than ever. Every company wants to get …
How To Load Data to table with large unl file
Hello, what is the best way to load data to informix tablea (running on windows) from large unl file (40GB) and record count around 80000000. any one has script to load data ? Thanks Pushpa…
240 Could not delete a row
Hi, I have a big problem with an Informix 11.7 nologing database. I have an Etl job wich run every day for archiving the online datas to the archive database, the job extract the online datas from a table in order to load this datas to a huge partionned archive table, but before …
End chunk mirror on two serves doing er
Hello: Which one is the best way to end chunk mirroring on two database servers? Maybe, end chunk mirror for root space on slave server and them on master server? And end chunk mirror for other space as final stage. Thank you. --001a113ecbee87c9c5052616cb37…
RE: Re: onstat -g iof sanity check [36143]
John what version of 11.70 did the onstat -g ioh come in?? Bruce Simms Data Base Services TALX, Provider of Equifax Workforce Solutions 2330 Ball Drive St. Louis, MO 63146 Phone (314) 214-7703 Cell (314) 496-6883 FAX (314) 983-3238 Bruce.Simms@Equifax.com IBM Champions -----Or…
Block vs. RAW
I'm setting up 12.10 on RHEL 6.7. Disks are on a SAN box. I'm using block devices and performance seems to be OK. Then I was thinking about using RAW (character devices) instead. Then I found this: https://access.redhat.com/solutions/183943?tour=6 <quote> Root Cause Raw devic…
Interoperability / support for Informix with Mirth
Hello Team, My team is working on connecting " Mirth Connect 3.0.3 " to IBM Informix v12.10. As we work through the process, we would like to hear it from you experts, if you have come across with Interoperability / Support information for Informix with Mirth Connect. If Yes, ca…
mt_shm_remove: WARNING: may not have removed all/c
Hi, Good Day, one of our informix instance went down and cannot be initialized. Upon checking the log file here is what we gathered, we even tried bouncing the server to no avail. Part of the initialization process succeeded up until ReadAhead Daemon Initializing 8 flushers...…
onstat -g iof sanity check
onstat -g iof output ... The "avg. time" field (under each chunk) is in milliseconds, correct? So a value of 0.0860 = 86ms? I'm seeing some shocking numbers but want to confirm first. IO/s vs. service times are inverted, which would make sense. What are some baseline metrics fo…
Error 1265
Informix 11.70.FC5GE OS: Linux openSUSE 11.3 (x86_64) Every 10 seconds I get message in online.log: 08:44:00 SCHAPI: [post_alarm_message 0-580664] Error -1265 Overflow occurred on a datetime or interval operation. 08:44:10 SCHAPI: [post_alarm_message 0-580664] Error -1265 Overf…
stupid onbar/onsmsnyc question time
HPUX 11.31 (11iv3) BL870C Integrity server IDS 12.10FC5 I have a question on what is the excepted way to delete old backed up log files when using onbar. Due to space limits on the current server we cannot keep more than about X days' worth of old logs. My question is if I use …
Oninit -w
Hello, When I do: ps -eaf | grep oninit I got many "oninit -w" What does "-w" mean? and how do we get this type of flags? Os: Red Hat 6.7 IDS: 11.70.FC8 Thank you! Kern…
after upgrading to 12.1 log back script not workin
HPUX 11.31 (11iv3) HP BL870c Integrity server IDS 12.10.FC5 Friday I upgraded our ERP with the latest-ish opensource products and Informixto IDS 12.10.FC5 and missed the note about ISM_DATA_POOL and ISM_LOG_POOL being removed. Silly me listened to our ERP that there is nothing e…
RE: after upgrading to 12.1 log back script not wo
Well, maybe more of the psm is setup than I first thought, I found the onpsm command and did a list of the devices, objects and pools. Since I'm getting objects I assume the logs are being backed up, but because of something when I do a onstat -l the logs do not show they are bac…
Best value for parameter STACKSIZE
Hi, Recently, I have an error in one of the our instances: Assert Failed: Thread stack overflow detected. The origin was an extensive query with a lot of joins. I know that the parameter STACKSIZE is related to this error. I changed the default value 64 (for 64-bit), to 128. M…
Best value for parameter STACKSIZE
Hi, Recently, I have an error in one of the our instances: Assert Failed: Thread stack overflow detected. The origin was an extensive query with a lot of joins. I know that the parameter STACKSIZE is related to this error. I changed the default value 64 (for 64-bit), to 128. M…
Possible bug in dbcopy
Hi, Yesterday, I did a "dbcopy" of some tables of one database to another (same structures) The execution raises this error on a table: Error fetching row! Code=-1263, ISAM=0. Here is the dbschema: create table "sistec".actm_documento ( id_documento serial not null , id_ins…
Utils2_ak update
Folks: I have released an update to the utils2_ak package. The latest release, dated November 25, 2015, is available for download from my website at: http://www.askdbmgt.com/my-utilities.html Art Art S. Kagel, President and Principal Consultant ASK Database Management www.ask…
load-insert with no rollback ?
HI, Folks IDS12.10 FC4 I was loading big amount of data to a table, begin work; lock table hist201511_lin_source in exclusive mode; load from hist_lin_source.data insert into hist201511_lin_source ; commit work; later, it was running of dbspace , and session was terminated by…
ER CDR_QDATA_SBSSPACE
I have ER set up between several systems. They are all Aix 7.1 but the informix versions vary. I have 12.10.fc3, 11.50.fc7, and 11.50.fc4. On the system which has the 11.50.fc4 engine, the dbspace listed in the CDR_QDATA_SBSPACE parameter continues to grow and never seems to be …
track session of memory segment
Hello, i have informix 11.50FC8GE server in there there are some memory segments so i want to track particulate user session or process for those memory segment. what is the best way to track them. memory segment like follows. IBM Informix Dynamic Server Version 11.50.FC8GE -- …
Can not start Informix on Linux
Hi, I have a informix server running on a virtual machine. The host of this VM was hung and I had to restart (that means the VM did a "forced power off"). After the reboot, when I issue the command "oninit -v", this error showed: Opening primary chunks...Bad Primary Chunk '/data…
Next Informix Webcast - New Informix Toys and Tool
Next Webcast Tuesday, December 15th at 2:00pm EST New Informix Toys and Tools - NoSQL, MongoDB Support, Data Streams with Node-RED, and new useful features and utilities - by Tom Beebe With the emergence of the 'Internet of Things' (IoT), more data is being collected than eve…
Unloading blobs to NFS-mounted disk
I was exporting a database (myexport w/External tables) to a NFS-mounted disk. We have one table in the database with roughly 3.2 million rows with one blob column, all together roughly 200GB. The export for this table took about 15 hours. Then I exported it to a local disk and i…
RE: Can VIPs (Virtual IPs) be used for Informix?
IDS: 11.50 OS: Linux Can Informix work with Virtual IP's ? We will have a primary and secondary server, we have different peripheral devices that rely on the primary IP address. If we have to switch from primary to secondary we think this is where the VIP might come into play t…
sysdistrib with dostats
Hi, Sometimes, I have the following error when I run dostats in parallel (all tables, aprox. 3000 tables) 211: Cannot read system catalog (sysdistrib). 144: ISAM error: key value locked How can I set a lock mode in dostats ? Thanks, Roger…
myunload question
Hi. I'm trying to run myunload on a CentOS 6.7 box. I downloaded the newest version (as well as utils_2k) from the archive. The schema builds fine. [informix@restore export]$ time myexport joakolap -p -E -m -u Building schema file myschema -q -d joakolap -l -U=/backup/export/jo…
Hash function in Informix
I am currently implementing a Datavault 2.0 data wareouse on Informix. The methodology uses hashing of a subset of columns to give a key to new versions of rows. Does Informix have a hashing function (MD5 or other)? If not, is there an easy way to implement it in Informix SPL or…
stopping ifxclone
Hi, We are running Informix 11.70.FC7. We started ifxclone to re-setup an RSS server, though we had to stop the RSS server in the middle of the clone. We used onmode -ky to stop the RSS server. However when we try to restart ifxclone again, we get the following error message on …
password is not correct for the database server
Hi, Good Day to everyone let me first give you an idea on our environment before proceeding with the question. We have an informix (11.70 FC7) Production server running in AIX 6.1 which have 3 instances running. We recently add another instance which will cater a new built appli…
onbar Logical restore cannot complete because of e
Hello all, OS: Windows Server 2008 R2 DB: Informix IDS 11.70 FC8GE SM: HP Data Protector 9 We have two separate backup specifications - one for full backups, one for log backups. The instance is configured with environment variable parameter OB2BARLIST poining to the log specif…
Re: Problems with ON-Bar
Gustavo, please take note that your Informix is higly recommended to upgrade, unless you have extended your support, you are at risk in case of a failure. Onbar return codes ranging from 2 to 34 are external errors, from XBSA. Table 1. Common ON-Bar return codesDecimal value ON…
Accessing sequence's currval
Hello everybody, I just want to read a sequence's current value but don't want it to be incremented. Is there a way to access a sequence's currval without first accessing nextval?. Thanks a lot, Juan…
dbimport with or without logging?
Hello, in which cases it's necessary to use the -l option: -when using HDR or Enterprise Replication? -when using smart blobs? Using the -l option just takes longer and can result in long transaction errors. So I'd be happy to know about any disadvantages of not using the -l…
Migration from 11.50 to 11.70
Hi to All i'm planning to migratre from informix ids 11.50 fc9 to 11.70 fc 8 i want to explore the two methods - Migration In place - New Install can you help me or give me some usefuls links please ? Thanks in advance…
cdr define shardCollection
Hey, IBM Informix Dynamic Server Version 12.10.FC4W1XU -- On-Line -- Up 10 days 22:37:40 -- 11778640 Kbytes I tried to create some Shard with ER. Copied an example of informix online_doc and modified it as needed, cdr define shardCollection ds_head_sha noaa:informix.ds_head_sh…
connection Manager
Hi All How exactly connection manager works with ? Can anyone help me configure connection manager, I have heard that it has some bugs, is this so? Thanks Jaya…
Please vote for request: In-Place Alter for varcha
Suggested by Fernando's post I ask for please voting for my request https://www.ibm.com/developerworks/rfe/execute?use_case=viewRfe&CR_ID=41469. It's "Under Consideration" since November 2013 and has 17 votes yet. TIA Reinhard…
Re: Identify the sessions which using all tempspac
No. Please vote on this request: http://www.ibm.com/developerworks/rfe/execute?use_case=viewRfe&CR_ID=77869 It's another attempt after this other one was declined: http://www.ibm.com/developerworks/rfe/execute?use_case=viewRfe&CR_ID=43877 This had 17 votes, and several points …
upgrade from 11.70.FC4 to 12.10.FC4 onconf questio
HPUX 11.31 (11vi3) HP BL870c from 11.70.FC4 to 12.10.FC4 I'm testing our ERP upgrade to IDS 12.1 on our test server and after running the upgrade and checking the differences in the old and new onconf file I got a question or two. The new onconf doesn't have a VPCLASS aio setti…
RE: Problem with sysdate in SPL
Everett: Because CURRENT will return the exact same time everytime it is called within a transaction. This is by ANSI SQL rules. Art On Nov 4, 2015 10:20, "Everett Mills" <Everett.Mills@nationalbeef.com> wrote: > Why not just use this: > > SELECT CURRENT YEAR TO FRACTION FROM …
Identify the sessions which using all tempspaces
Hi, Is there any way (any query/command), to identify the sessions which are trying to use all of the tempspaces? Thank you!!! Pravin Bankar pravinebankar@gmail.com…
Identify the sessions which using all tempspaces
Hi, Is there any way (any query/command), to identify the sessions which are trying to use all of the tempspaces? Thanks a lot!!! Pravin Bankar pravinebankar@gmail.com…
Re: RE: Which session is using the most cpu resour
Thank you Michaelis. I am also looking similar to this scenario. That is how to find sessions which are using more system resources? Here are few sample output based on instruction in your post: Top command: top - 12:59:22 up 318 days, 20:53, 2 users, load average: 3.19, 3.93, …
Problem with sysdate in SPL
Hello everbody We have a problem with sysdate in spl. The fractions of second is same during all executing of store procedure. The version of IDS is 11.50 FC9GE in Solaris Sparc 10. In the onconfig set USEOSTIME in 1. I created a table with camp datetime and two store procedu…
Find table from audit record
Hi all IDS 12.1 We have audit records like this: ONLN|2015-09-30 14:32:05.000|Server|20869|db_server|user|0:INRW:database:-1:10485769:268:: -1 should be a tabid, 10485769 should be a partnum of a fragment. Looked up database:systables, database:sysfragments, sysmaster:systabn…
ALARMPROGRAM: Event Alarms Filtering?
Hello, IDS 11.70 I need to find out if there is a way to force ALARMPROGRAM not to trigger itself whenever certain types of events happen. For example, I am making dbexport backups of all dbs during night, and I need to temporarily stop ER. This event is with type WARNING and …
Problems with ON-Bar
Hello friends! I have a problem running the UN-Bar on my server because it aborts execution immediately. I find errors in the bar_x.log are: 2015-10-28 18:19:41 4156 4516 C:\\\\informix\\\\bin\\\\onbar_d: process exit 149 (0x95) 2015-10-28 18:20:12 1976 4240 C:\\\\informix\\\\bi…
migrating IDS and performance problem
Hi everyone, I am migrating IDS 10.50 FC3 informix DB from one Power6 with AIX 6.1 to another Power8 AIX 7.1 IDS 11.70 FC4. IDS dbspaces are on FC storage EMC VNX5300 with native MPIO drivers I have very strange behavior, I am moving with dbexport and dbimport to the new IDS. Im…
Informix use the wrong index
Hi, I have a view (MyWiew) for 2 large tables (tab1 and tab2), in this view I merge these 2 tables(tab1 and tab2) by "union all", each table has 2 composed indexes, first composed index on columns (Account,Month and year) and second index on just columns (month + year), I'm launc…
Move sysadmin database
Folks, IBM Informix Dynamic Server Version 12.10.FC4W1XU Was testing moving sysadmin database out of root dbs, and saw the following errors( detailed attached), 18:39:37 ERROR(gettab) Estimate FAILED for index 'stores_demo:"informix".raw_container' - rc -1 iserrno 111. 18:39:3…
Performance issue after migrate to IDS from Online
(first of all: I post here because IDS has changed but 4GL no.) Hi All, After migration, the new virtual server shows a no smooth behavior(I don't know how to express it in English) when running 4GL database processes. When we run certain processes, other terminals get stalled …
SPL name from within SPL?
Informix 12.10 Is there a way to determine the name of the stored procedure, from within the stored procedure? Thank you. DG…
Doubts with ISM and ON-Bar
Dear Friends: I am evaluating backing up my database with Informix Storage Manager and ON-Bar in disk files, and there are some things we would like to consult them, such as: 1 - I see the ON-Bar generates a maximum of 2GB files, is this normal, or I have to change some paramete…
New Oracle course on Informix !!!!!!!
Hi ALL, I just found a nice *new* *Oracle* course. I did not know that Informix was acquired by *Oracle*. At least that is what "CourseMonster.com" is showing on their web site :-) : http://www.coursemonster.com/us/training-course/53146/ Cordialement, Regards, Khaled Benteba…
Which application is making the connection?
I would like a way to set role permissions on connection, based on the application making the connection. For example, if the user connects with Excel I want to set read-only role. If the user connects from the end-user application I would set read-write role. Is there a way to…
SCHAPI: Error -23197 Database locale information m
Hello, we are runnig on IDS 11.70.UC3. I have table with CLOB - for example in database db1 (COLLATE is sk_SK.912): create table abc ( id serial, c clob); There are some data in this table. I need to schedule custom task for periodicaly unload data from this table to filesyste…
Slow instance response and CPU load
We are running informix 12.10.FC4W1@solaris on ORCL,SPARC-T5-2 server, it is observed that many mutex with RR_ID found in onstat -g lmx. onstat -g lmx IBM Informix Dynamic Server Version 12.10.FC4W1 -- On-Line (Prim) -- Up 5 days 02:58:49 -- 2232320 Kbytes Locked mutexes: mid …
Can't compile SQLCMD
I'm struggling to build sqlcmd on Redhat 6.7. RHEL6.7 is shipped with GCC 4.4.7 and I'm getting the error "#pragma GCC Diagnostic not allowed inside functions" (initially this occurs during the compile of ensprintf.c). I have a feeling this might be a bug in GCC 4.4.7. Does anyo…
Could not do a physical ..in a query group by
Hi, I have a query group by on a large table Over 600 Millions rows), the query run over 2 hours and then it generates an error Could not do a physical order to .... My database is an Nolog informix 11.70. on the onstat -u, I have 8 processes run by informix for this query plz h…
dbWorker
Hi, Folks, IDS 12.10 FC4, Linux 6 Any comments on the following job? Seems it take excessive resources ...? Can it be sopped? how to stop? Thanks Frank [informix@ncdopsdba101 info]$ onstat -g ses 4702828 IBM Informix Dynamic Server Version 12.10.FC4W1XU -- On-Line -- Up 9 d…
Slow Bulk Loading problem
Hi, I have a raw fragmented table with 10 indexes, I want to load many files of approx 50 million row each file with external tables, the table now contain 163 Million row, but I remark that it begin loading very fast 8000 row/sec or more and after hours, the loding become too sl…
Webcast on Informix Storage and RAID5 - Doing Stor
Folks, Our next webcast will be by Art Kagel on Informix Storage and the dangers of RAID 5. Informix Storage and RAID5 - Doing Storage the Right Way! by Art Kagel Tuesday, October 20, 2015 at 2:00pm EST Please register Registration at: http://advancedatatools.com/Informix/Next…
Re: run shell script with in informix stored proce
Yes you can. Simple example: Regards, Vaibhav S Dantale IBM Informix CTE Lead Mobile - +91-9503161335 email- vdantale@in.ibm.com Twitter - @dantalevs Blog - http://timeseriesibm.blogspot.in/ (Works better in firefox) From: "PUSHPA KUMARA" <pushpa@cybersoft.lk> To: ids@iiug.org…
Informix and El Capitan
If you use Informix on Mac OS X, be aware that Mac OS X 10.11 El Capitan has introduced a new core feature called System Integrity Protection, SIP. One side effect of the rules enforce by SIP is that the GSKit libraries are removed from, and cannot be reinstalled in, /usr/lib. Y…
getGeneratedKeys returns an empty ResultSet
My Java application (a Stateless EJB) is connecting to an Informix database via JDBC. In one sentence: Statement.getGeneratedKeys() is occasionally returning an empty ResultSet, and I'm trying to figure out why. Background: I am keeping track of users' requests regarding orders…
Hyper threading
IDS 12.10.fc5 IDS 9.40.fc5 Aix 6 and 7 We have just moved our Informix systems to a Power 8 system ... previously we were on a Power 7. I remember something from last years conference about Hyper threading ... and if it should be used or not ... but I don't remember .. nor can I …
HDR,RSS and ER
Hello all, I will be implementing ER in the very near future and have an ok grasp on the basics I think. The current setup is with a Primary Node, a Secondary node running an HDR instance, and a Tertiary Node running RSS. The ER configuration will be from the Primary node to the …
New Informix setup
We have some request to migrate 3 informix instance into one box (HP-UX). Is there any better way to do this Thank you very much --001a1140f3cc1422fa0521bb6a16…
Re: Informix Storage and RAID5 - Doing Storage the
HEY! I resemble that remark! Art Art S. Kagel, President and Principal Consultant ASK Database Management www.askdbmgt.com Blog: http://informix-myview.blogspot.com/ Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on the IIUG, nor a…
Informix Storage and RAID5 - Doing Storage the Rig
Folks, Our next webcast will be by Art Kagel on Informix Storage and the dangers of RAID 5. Informix Storage and RAID5 - Doing Storage the Right Way! by Art Kagel Tuesday, October 20, 2015 at 2:00pm EST Please register Registration at: http://advancedatatools.com/Informix/Next…
DELETE SQL & data pages
A customer use IDS 10,he will delete some record for coming insert operation on the same table ,because of the disk utilization probme,customer hasn't enouth disk. He want to know how many data pages could be used for the coming insert operation after he run some delete SQL in th…
JSON via REST on Windows
Hi, in version 12.10 (Innovator-C) is included service for using JSON with Informix IDS. On Windows platform is contained in service name "ol_informix1210_json" and is represented by jsonls.exe process. But when is added configuration parameter "listener.type=rest" into etc/jsonL…
Question for Art Kagel re: latest dostats script
Hi Art, Good day! May i know the latest version of your amazing do_stats script? And where can i get it? Thanks a lot. Ron…
OAT User Question
Morn'n Folks, IDS=11.70.FC8XB8 O/S=AIX 6.1 I am in the predicament of administering Informix on environments that I do not know the informix password on. I do have sudo rights to informix and functions that I need as root. I am setting up OAT and "thought" that by setting ADMIN…
Quick questions on AUS
Hello All, Please help me to clear my doubts on below questions: 1) At any point of time, I want to disable the AUS, if I set the evaluation & refresh task's tk_enable columns from "t" to "f" will be the all or need to do anything for AUS disabling. This is for if unfortunately i…
Suggestions on AUS monitoring
Hi All, I was referring Bens blog on monitoring AUS: https://informixdba.wordpress.com/2015/04/30/experience-with-auto-update-statist ics-aus/ I am trying to gather details on AUS monitoring; apart from below points what else I have to consider for AUS monitoring: 1) The param…
Enable or Apply Auto Update Statistics
Hi All, Here is email communication between Ben and myself. I hope this will help someone who really want to play with AUS feature. -------------------------------------------------------------------------------- ---------------------------------------------------------- Hi Ben…
shared memory issue
Hi I am frequently getting below error, I know I am using workgroup Edition hence there is a limit, Using shared memory... however transaction are so less hence dont expect this error very frequently Warning: The IBM IDS Growth Edition license restriction limits the total share…
Error System Block
Hello Someone knows why this error happens Error: Generic System Block: -1 seconds Thanks for your attention -- Saludos Cordiales Rubén Dután Gerente APLEXT CIA. LTDA. Soluciones AX-ERP & TIC www.aplext.com -- This message has been scanned for viruses and dangerous content b…
Informix for New Database Administers
Folks, I will be teaching our next Informix course, "Informix for Database Administrators", October 12-15, 2015. You can attend the class in person at our Annandale, VA office or online via our WebEx Training Center. This course is for database administrators, programmers, and…
CRITICAL PHYSLOG CHUNK DOWN
Hi, I was working on a new database informix 12 on Windows 2008 r2, I was working in gathering archive datas in this new informix 12 databse, I have not yet take any backup, and I have resize the Physlog to a chunk of 40 Gb, the informix has went down because maybe of the size an…
Setting up SDS cluster
HP-UX B.11.31 IDS 11.70.FC8W1 Setnet 4.10.TC5 Hi All When I start the connection manager and try to connect from a Ilogin I get a -908 error. I have checked the port setting on both client and server match but still get this error. Any advice will be appreciated. thnx…
Update statistics
Hi All, Getting below error: update statistics low using sampling may generate inaccurate index statistics for index 'some column' due to data skew Thanks…
Moving a cooked chunk
Hi, I needed to move the second chunk of the rootdbs in my TEST instance (we run a LIVE and a TEST instance on the same box) It had stupidly been created (by me) in the LIVE filesystem :( After a fair bit of searching it seemed like setting up MIRROR was the best option. I did th…
Informix High Availability
Hello all, I am doing Informix HA Implementation research between "Physical Host + Informix + HDR/SDS" vs "VMWare + Informix + vMotion" Whats your bet and why ? Thanks --001a11c3d08c374d8b051fa1c667…
HDR Secondary - backup question
Solaris 10 IDS 11.50.FC6 Is it possible to take an "ontape" backup of a secondary server while replicating, or do I need to change the secondary server to "Standard" mode to back it up? If I have to change it to "standard", will I be able to change it back to secondary without r…
Change Char to varchar
Hi Friends, I have problem when I changed column type char(10) to varchar(20), if column char is not null the change complete with 10 spaces for records with size less than 10 on column of new type, if column char allow null the change remove spaces(Trim) in column of new type, …
Error -243 Isam -101
Hello, We have a Java batch program that accesses an Informix database. It only does select operations. Every time, after a few hundred selections, it receives sqlerror -243, isam -101. We already added a 'set lock to wait', but no change. Different 'onchecks' on the table that …
cdr_qdata_sbspace
Aix 5.3 IDS 11.50.fc4 I have ER set up between the above system ... and another system Aix 7.1, IDS 12.1.fc5. On the 11.50 system the dbspace defined by the above parameter continues to grow. Seems as if it's not cleaning things up. On the other system that is part of the ER, it…
VMWare ESXi MaxIOSize recommendation?
Hi all, We have several Informix 11.70.FC8GE instances with default block size (4K), running on VMs with Windows 2008 Server, where we are undergoing an performance problem related to high read/write latency between DB servers and SAN. As part of the steps to remedy this, the V…
Creation of missing AUS related tables in sysadmin
Hi All, I want to implement the AUS (Auto Update Stats) feature for my Informix production instance. But before implementing on production box, I need to test it at the test instance. When I gone through AUS related documentation & referred the sysadmin database then found the be…
Informix upgrade path
Hi Guys, Is there anyone aware during upgrade of informix 9.40 to 12.10 is it necessary to make an interim step with upgrading 9.40 to 11.70 then from 11.70 to 12.10. I'm planing to make export/import between 9.40 and 12.10 versions. OS will be different too. If it is relevant it…
RSS server is not active / Can not establish RSS -
Hello all, I followed and have completed all the steps for setting "back", an RSS server with IDS 11.50.FC9 on AIX 6.1. When I issue onmode -d RSS ol_live (Primary) on the backup server, instance log shows : " 13:04:09 DR: Secondary to Secondary 13:04:09 DR: new type = RSS 13:0…
Problem with time
Good Morning I have the following configuration: UnixWare 7.1.4 (virtualized with VMware) Informix Dynamic Server Version 7.30.UC2 I have a problem with time with informix 4gl, if running the program below, in random situations what happens is that the time is the same for about…
PERFORMANCE between TCPIP and IPCSHM CONNECTION
HI, With IPCSHM connecton ,the performance should be better tan tcpip connection. Do anyboddy do the PERFORMANCE testing between TCPIP(client run on another machine) and IPCSHM CONNECTION? How about the testing result in the real case? thanks for your time.…
S.O.S....Upgrade from 11.50.FC9W2X8 to 12.10.FC4 i
Hi Guys! There was a typo in the first email ( after the upgrade of IDS12.10.FC= 4W1 must be read as "after the upgrade of IDS11.50.FC8W2X8 on AIX 7.1 to IDS12.10.FC4W1". I have just upgraded from AIX 6.1 to AIX 7.1....and I had also upgraded= IDS from 11.50.FC9W2X8 after the O…
RE: S.O.S....Upgrade from 11.50.FC9W2X8 to 12.....
What about permissions on the oninit binary? Do they look like: -rwsr-sr--. 1 root informix 25199626 Jun 8 17:18 oninit We have had a similar issue when these were not correct. ________________________________________ From: ids-bounces@iiug.org [ids-bounces@iiug.org] on behalf…
Partnership with ARM for IoT
http://uk.businessinsider.com/ibm-and-arm-partner-for-iot-domination-2015-9?r=US &IR=T#ixzz3khLhabNx And we know which enterprise grade database works on ARM devices :) Regards -- Fernando Nunes Portugal http://informix-technology.blogspot.com My email works... but I don't che…
Top 10 Enterprise Database Systems to Consider in
Informix makes a top 10 list. http://www.serverwatch.com/server-trends/slideshows/top-10-enterprise-databa se-systems-to-consider-2015.html Oracle SQL Server DB2 Sybase Postgress MariaDB MySQL Teradata Informix Another IBM product in the list, IBM offers a range of Inf…
Oat replicate doesn't sync
Hi, I'm using Oat to replicate a table of a database. It starts ok, but then It send this message: Warning: replicate is not in sync. I check all the parents table and all are in sync. What else could be avoid I can sync this table ? Thanks in advance.…
SDK degrades IDS
When Web Server connect With SDK client, the IDS degrade. I configure the NETTYPE soctcp,2,600,NET NETTYPE ipcshm,2,500,CPU I need know what happen and if I reconfigure another parameters…
Turning on logging for DDL and DML
IDS 11.70.FC7Solaris 10 Sparc Can someone send me a link on how to set up DDL and DML logging and how to monitor it? Is there a way to get it to overwrite the logs to limit the size? Larry…
Re: Informix - Free version
Sorry Frank, Innovator-C v11.70 & 12.10 DOES have a storage limit if you want to be compliant with your license. The limit, as stated before is 8GB on disk. Here's the link to the official "Unofficial" feature and restriction page: http://www.ibm.com/developerworks/data/library/…
Re: Informix - Free version
http://www-03.ibm.com/software/sla/sladb.nsf/lilookup/8F57D029D9FE93F085257D8F00 7B6A4A?OpenDocument Regards On Mon, Aug 31, 2015 at 11:20 PM, Frank Langelage <frank@lafr.de> wrote: > There is no limit in data storage for Innovator-C. And there never was > one. I'm using it for…
Re: Informix - Free version
I'm pretty sure there is a limit at 8GB storage, on free Informix on Linux OS since version 12.10. Look at: http://www.ibm.com/developerworks/data/library/techarticle/dm-0801doe/ Maybe IBM forgot to limit free version on Solaris ? :) I'll try Linux version 12.10.FC5IE ... On …
Long transactions monitor and Statistics
Hello all, IDS 12.10.FC1WE on Solaris 10 9/10 s10s_u9wos_14a The monitoring we use for Informix in our environment detected that certain session is being rolled back due to occupying more log space than defined in LTXEHWM parameter. So far so good, the engine successfully did a…
Data Dictionary
Do you know of a good Data Dictionary software package? Or, if you know a format that works well for you, and don't mind sharing, that would be useful as well. Thanks, Steve…
SQL error using JDBC
This seems to be related to using the JDBC driver and a particular field name in a table. For example, just trying to create a simple query.... The following query works fine: select id from sens But trying to select a field called 't' fails: select t from sens We tried severa…
Informix - Free version
Can anyone send me the link to the free version of Informix for small users, and maybe a link to the stipulations on using the software? This is for a business of around 5 users and 100-200MB database. Larry…
Informix 11.50 FC9 Migrate to a newer version ?
Hi to All Our main application uses an Informix database (11.50 FC9) installed on AIX 5.3 TL 12. I know that the AIX version is not supported, so we will migrate to version 6.1 in the first instance (Q1/2016) and then to version 7 (Q1/2017). My question : Informix 11.50 FC9 is …
Twitter - Informix has enhanced it's licensing mod
Just see on twitter: #Informix <https://twitter.com/hashtag/Informix?src=hash> has enhanced its licensing model to meet market and customer demands. Learn more here http://ibm.co/1pGXm2v <http://t.co/0nottlV0Ad> Regards, David.…
27001: Read error occurred during connection
Hi Guys i have this problem with 1170FC8 in HP-UX 11.23 PA-RISC i start my instance fine and run a dbimport, few minutes later instance is frozen, i try access to dbaccess and i get this error "27001: Read error occurred during connection attempt. Somebody can help me?…
27001: Read error occurred during connection
Hi Guys i have this problem with 1170FC8 in HP-UX 11.23 PA-RISC i start my instance fine and run a dbimport, few minutes later instance is frozen, i try access to dbaccess and i get this error "27001: Read error occurred during connection attempt. Somebody can help me?…
listener-thread: err = -951
IDS 11.7FC8 HP-UX 11.31 We have set up a completely new server(hardware&OS) and installed IDS 11.7FC8. When the users try to log on we get the following error in the online.log: " listener-thread: err = -951: oserr = 0: errstr = user@server : Incorrect password or user ".......…
Problem with select count(*) in 11.70
Anybody knows details about this APAR ? : IC89479: COUNT (*) VS ACTUAL SELECT * RETURNS DIFFERENT RESULTS I have a case where a select count(*) incorrectly displays 0 records. This problem occurs within a esql/c program in certain circumstances we could not establish. I think…
Informix temp spaces
Hello everyone I have Informix 11.7 with UNBUFFER databases. I'm playing with informix temp dbspaces. I have create 8 temp dbspaces 4 are createt with "T" flag and 4 without, like regular dbspace. All 8 dbspaces are added in DBSPACETEMP on onconfig file. While monitoring temp…
Update statistics - which tables?
I am trying to develop a script that I can run on a database that will recommend which tables in a database that should have statistics updated. I have looked at the contents of sysdistrib / systables and sysindices but I can't quite work out the sort of SQL I would need to get …
Down Chunk/Warm Restore
I have a chunk that is down but the dbspace isnt. It was, but I warm restored it, although the chunk is still down. Id like to force a warm restore of this dbspace since the system catalogs are corrupt as well. Its a small database so I can reload the whole thing, but tryin…
Graphic tool
Hi, Do you know a tool to view the database in a graphic mode ? Thanks in advance. Enviado desde mi iPhone…
Shared file system
Informix 11.7FC8 HP UX 31.1 I am setting up an SDS server but need some guidance: The Informix manuals specifies a "shared file system" for setting up an SDS server. My understanding is that I don't have to create any db spaces on the secondary server. Does this mean that the s…
Informix Authentication failure with Hp-Unix
IDS 12.10.FC4W1X3 on HP-Unix B.11.31 U ia64 (configured to work in trusted mode, NO shadowing) This issue is pertianing to connection with one of the sds nodes I am facing a very weird issue of connectivity with one of the java application trying to connect to informix database…
Unable to bind to the port
Hi, Informix 11.7.FC8 HP-UX 11.31 I am setting up an SDS server. The primary starts successfully but when I run the oninit command on a SDS server I get the following error: "Assert Warning: Unable to bind to the port (9999) on the host (999.99.9.99) for the server (primary)."…
License information
Hi All, Can anyone help me to find licensable Informix components under the processor value unit metric. Currently Im using the following: cat $INFORMIXDIR/etc/*-cr | grep -v "Copy" Is this command right one to find all licensed components under PVU? Thanks in advance.…
How to Get "SQL" statement in running session
Hello ? How are you ? How to Get "SQL" statement in running session without "SQL TRACE ON" ? Our customer want to get "SQL" history to get Top N SQL . They are developing to gather Informix DBMS log and OS log's history these day. They use Informix 11.5 version. In case of Ko…
dbschema output wrong by Not Null Columns
Hello, Ifx: 11.70.UC7W3 / 12.10.UC4W1 (Both Versions with same behaviour by the following problem) OS: SLES11 SP3 the dbschema-Tool delivers wrong output. When we do a "dbschema -ss -d DB -t TAB" not all "not null-Columns" where displayed with the "not null"-clause (All columns …
TimeSeries vs InfluxDB vs OpenTSDB vs KairosDB
Hi , Before anything, this is an area where today I have no experience and want to try learn something. I'm looking for a dashboard tool and found one , open source and appear be very cool , grafana.org It's work with TimeSeries database as datasources. What isn't surprise , In…
Re: How can I resize a chunk?
Since version 11.70 you can enlarge a chunk by doing the following: dbaccess sysadmin <<EOF EXECUTE FUNCTION task("modify chunk extendable on", 1); -- 1 means chunk number in onstat -d EXECUTE FUNCTION task("modify chunk extend", 1, "400 MB"); -- extend chunk#1 by 400 megabytes …
COMMIT WORK, LRU's and Checkpoints.
I wonder if someone could explain what happens when a commit work occurs in terms of the buffer cache? The SQL Manual for COMMIT WORK has the following sentence: "The database server takes the required steps to make sure that all modifications that the transaction makes are comp…
Informix leads the G2 Crowd rankings for relationa
Folks: The crowd-rating site G2 Crowd has published its first Relational Database Ranking Grid and Informix is on top! https://www.g2crowd.com/categories/relational-databases If you haven't ranked Informix on G2 Crowd yet, please do so. Let's keep our favorite database at the …
Session "Waiting on a transaction"
Hello, I'm using Wildfly application server (JEE server) together with Informix 12.10.FC5 as the database on Oracle Solaris SPARC 10. It's using distributed (XA) transaction using 2 databases on the same instance in this case. On start up the server gets stuck at some point and …
Different output of onstat -g opn in version 11.70
Hi, I have noticed that the ouput of onstat -g opn is different according version of informix server: Versión 11.50 (FC8) and 12.1 (FC4) show the output in the following format: tid rstcb isfd op_mode op_flags partnum ucount ocount lockmode 78 0x0000000044d76768 267 0x00060000…
Springs mybatis + informix clob insert
Hello ~ Informix Colleague Does anybody know about Springs mybatis + informix clob insert sample? Our customer reveiced -841 error when they insert clob data. Is it same to JDBC clob insert source ? -841 Name must start with a letter or "_" and contain letters, digits, or "_". …
spatial data blade come with 11.50.UC9
It been so long since I installed Informix I cant remember if the spatial datablade is installed when Informix 11.50.UC9 on Linux is installed . Does any one know please.…
indexes in smi table
The sysmaster:systabnames and sysmaster:systabinfo provide information across all databases however not whether the object is an index or not. Is it possible to find this information within the smi interface? Ie without using sysindexes. Informix 11.7 XC8…
RE: Rebuilding the sysadmin
IDS 11.50 Solaris 10 - Sparc Can someone walk me through rebuilding the sysadmin database? LArry…
ph_alert
Frequently, the following large volume of ER error message flooded our ph_alert table space. Can we control to ignore such type ER of error message for ph_alert ( Do not insert these millions of rows into ph_alert) Thanks Frank id 3582026 alert_task_id 15 alert_task_seq 358117…
ER - Data consolidation
Hi all, I'm trying to setup a ER with 4 Onlines in a data-consolidation model. The documentation is not so clear with more than 2 onlines .... The goal is to have something like this : A-| ||->C B-|->D C consolidates some of A+B D replicates some of B I'm able to set the repl…
WARNING: temporary DBspace tmp_4k_dbs is full
Hi, We are running informix version 11.7 dataserver on AIX 6. We have two dbspaces listed in our DBSPACETEMP onconfig parameter in the following order : tmp_4k_dbs,tmp_dbs. Both dbpsaces are 4k page size. From time to time we encounter the following message "WARNING: temporary …
Table Privileges
IDS 11.70.FC8 Which system table stores these privileges ? User Select Update Insert Delete Index Alter public All All Yes Yes Yes Yes "This email is confidential. If you have received it in error, you are on notice of its status. Please notify us immediately by reply email a…
Quitar CR/LF de campo char o varchar
Hola necesito quitar de campos varchar y char los caracteres especiales CR/LF en Oracle y sqlserver tengo la funcion chr pero en informix sql no encuentro su equivalente alguien tubo este problema? Queiro ejecutar un sql en informix como el siguiente. update nombre_tabla set no…
Locks not releasing & oncheck
Hi All, We have a problem that even has IBM scratching its head: All of a sudden (no server updates, no code releases, etc), one of our instances is processing transactions VERY SLOWLY, and causing a lot of rollbacks and lock timeouts. Informix 11.50.FC6 running on Solaris 10 …
Modifying a primary key on er
Hi, I need to alter a primary key of a table that is on an enterprise replication, so I used the next command: cdr alter --on db:owner.table And it works well, then I use the alter command and it works great, the table was altered. After that I execute the next command; cdr alter…
Re: RE: Number of bit map pages to be logged in c.
We got the same message. And DO NOT know this message with ? >Hi, >We are also encountering the same message. >What does this error message mean ? >Thank you…
Informix 11.70 support end of life
Hi all, can anyone know when is support End of Life date for Informix 11.70 and 11.50. is there any announcements ? Thanks in advance for information!…
Process exited with return code 0
Folks, IDS12.10 FC4, Redhead Linux. I believed I saw this error before and can not recall its answer or explanation. /usr/informix/etc/alarmprogram.sh is the original script( no touched). It was quite before, just started to complain two days ago after the instance bounce . Ot…
AUTO: Viviana Gomez/ARSA está ausente de la oficin
Estar=E9 ausente de la oficina hasta el 03/08/2015. Por favor, por temas de base de datos contactar a Horacio Churata int 3828 o a Miguel Fusek. Nota: Esta es una respuesta autom=E1tica a su mensaje "Post a review of Informix [35532]" enviado el: 07/27/2015 20:18:24. Esta es l…
Post a review of Informix
Please go to this site, login using google or LinkedIn and review our favorite database! Vote for Informix. http://database-management.softwareinsider.com/ Art Art S. Kagel, President and Principal Consultant ASK Database Management www.askdbmgt.com Blog: http://informix-myvi…
Growth Edition x WorkGroup Edition
Hy, everyone. Is there a big diferencie between Growth Edition x WorkGroup Edition in 11.7 FC8 for Linux ? Is it the same binary file ? Thanks a lot André Luiz Rufino > To: ids@iiug.org > From: tom@advancedatatools.com > Subject: Informix Fantasy (American) Football League - 2…
Informix Fantasy (American) Football League - 2015
This year we are bringing back the (Un)official IIUG fantasy football league. If you would be interested in joining please email me off-list. We had a great group of folks playing last year, it was won by Arman Prescott after a very close playoff bracket. For those that have no…
SSL Performance
We are in the process of implementing SSL in transit encryption for IDS 11.7. We are testing on a few servers, and there is an obvious performance drop when using onsocssl. I have tried implementing more VPs to boost performance, but it has a minimal effect. The primary data we n…
output of cdr stats rec
Can some one explain the line form the doc example, , Server Repl Txn Ins Del Upd Last Target Apply Last Source Commit 144 9371650 11 0 0 220 2005/03/30 09:36:25 2005/03/30 09:36:25 Txn column is 11, but Upd column is 220. What does 220 mean? ( number of transactions? if yes, …
statistics on system catalog tables
Hi, I want to migrate one instance informix from 11.50 FC8 to 11.70 FC8W1. In the section "Completing required post-migration tasks" of thge Migration Guide, says: Update statistics on some system catalog tables after migrating After migrating successfully to Informix Version …
12.10 From 11.50 Using 40% More Space
Migrating from 11.50 FC6 to 12.10 FC5 AIX 7.1 and noticed after importing the database with dbimport that the storage space used on the 12.10 instance increased by more than 40 percent. The export did not specify extent sizes (-ss option) for the tables. Any ideas why this might…
Moving System Tables
Hi, We are running Informix 11.70.FC6. Is there a way to rebuild some system tables in a database. Basically, looking to move some tables like sysdistrib, syscolumns, sysprocedures, sysprocbody, sysfragments etc... as they are residing in a chunk that I need to drop. It is not t…
I'm tweeting about Informix!
FYI, I'm now on Twitter and tweeting about Informix: https://twitter.com/IngeHalilovic Also, check out my blog about Informix doc: www.ibm.com/developerworks/mydeveloperworks/blogs/idsdoc…
widows batch file for informix Update statistcs
Hello, does any one has windows batch file(script) to run update statistics and need to run it with schedule task. Thanks…
How many rows of data are in the entire database
IDS 11.50.FC7 Solaris 10 - 64 bit Is there a way to approximate how many rows of data are in an entire database? I am not so much concerned about sizes, or what kind of data is in the tables. I just need to know the total number of rows in all the tables combined. (I know...weir…
Odd one
Folks: I have a temp table that I create in one of my tools. A query against that temp table uses rowids. If there are more than one temp dbspace listed in DBSPACETEMP the temp table is apparently being created fragmented across the multiple temp dbspaces because the query retur…
ER replicate compressed tables
Folks, IDS12.10 FC4 If a table is replicated, How would it impact ER performance ( positively or negatively or ..) if we compress the table? Another question, If the table is compressed at one site only, ER will send the compressed data in the format in logical log and do un-c…
Disabling constraints
Hi, I need tu upload to tables, without cheking constraints, so I use the Set constraints for tabName disabled, but got an the error 892 "cannot disable object objectname due the other active objects usong". Is there an statement to disable temporaly all constrainst and later ena…
He's Back, Better and Bold
I wanted to take this opportunity to welcome back to the Informix team someone, who has helped many of us out through out the years. It is with great pleasure that I welcome back Jonathan Leffler to the IBM/Informix family! John F. Miller III STSM, Lead Architect miller3@us.ibm.…
Informix Performance Tuning Course by Lester Knuts
Folks, We still have a 1 spaces left for this class. Art Kagel and I will be teaching the Advanced Informix Classes together, July 20-23, 2015. Would you like to know how Art does an Informix health check? Or, how I do an Informix performance review? This course is for you, we o…
onsmsync
Hi all, I am interested in anyone's experiences with onsmsync as I am having fairly fundamental troubles with this utility. As I understand it two things onsmsync can do are: 1. Synchronise the sysutils database and emergency boot file (ixbar) with the storage manager. This is…
uploading tables
Hi, I need to upload some tables to a database. but some of them has foreing keys, so I need to check the estructure of these tables to know the order to I have to upload them. Is there a easier way to know the correct order to upload the tables on a database ?? Thanks in adva…
Fragmentation Fundamental Question
This seems like a ridiculously simple situation but not seeing the expected behavior with respect to number of scan threads. I expect 3, but only getting 1. IDS 11.5.FC8; cpuvps 16; MAX_PDQPRIORITY 100; Fragments 3 30M row table fragmented by RR. Only getting 1 scan thread on …
Cast CLOB
Hi! Version 11.70.FC8. I am trying to cast a CLOB to a LVARCHAR. The engine allows the cast but the result is strange. I have a column in a table that displays as "0005" (using Server Studio for retrivial) when it is a CLOB, when I cast it to a LVARCHAR it displays as "0100000…
opentable memory leak
I recently upgraded to 12.10.FC5WE on Linux and appear to be running into IT03031: OPENTABLE MEMORY OF A SESSION CAN GROW AND CAN LEAD TO OVERLY LARGER MEMORY CONSUMPTION AND POSSIBLY TO MEMORY FRAGMENTATION or possibly IT03000 as I've also seen it referenced. onstat -g ses <s…