RE: IP aliases and socket connections
Posted in 2000
First of all, Telnet also runs on top of socket's. Perhaps the INFORMIX listener is trying to do a reverse lookup, and gets the ..114.5 IP instead of ..114.2 What is in your sqlhost file.? Put in IP addresses and not hostnames, same with port numbers. This will remove any IP+PORT_NUM lookups INFORMIX have to do. If that does not work, try to add ..114.5 and ..114.2 listeners in the sqlhost file. -----Original Message----- From: Neil Truby [mailto:ntruby@netcomuk.co.uk] Sent: Monday, September 04, 2000 9:41 PM To: informix-list@iiug.org Subject: IP aliases and socket connections Informix IDS 9.20 on HP-UX 11.0 We've moved some our systems from one UNIX server ("perky") to a more powerful one ("archer"). The IP address of perky was 193.118.114.2, and of archer 193.118.114.5. In order to avoid widespread changes on the client systems, we configured the ethernet port of archer to have an IP alias of 193.118.114.2, as well its primary address of 193.1118.114.5. perky was re-configured to have a completely new address of 193.118.114.4. This worked a treat for the majority of applications; those using telnet. All connected seamlessly to archer. However, none of the ODBC or other sockets connections would work. All fail with error 908 "cannot connect to database server". If client changes are made to change the hostname to 193.118.114.5, rather than 193.118.114.2, the applications work fine. Does anyone have any idea why the telnet connections work fine with the IP address, but the sockets connections don't? thanks Neil