Logical Logs help
Posted in 2000
Hi, I have a problem with an Informix On-Line 5.0 running on a DEC OSF/1. Sometimes when many users make transactions, the tbinit crashes and he cannot recover when bringing server on-line (daemon died). tblog reports an "invalig log type" at a certain log number, and on-line log file reports after a "lock table overflow" an error like this : log error 'logread() - logsearch() FAILED' us ..... pid ...... ecc ... Online aborting and when restarting with tbmonitor, the server doesn't start up because daemon died. It seems like daemon was killed when some transactions are running. So, I wish to flush only the logical log where the error occours (or all logical logs involved by transactions that caused the crash) bringing logical logs at a certain log-id. Is it possible to do this ? Are there some tools to flush logical logs ? Thank you very much for help !! bye Fabio