Re: Someone have a technique to alter tables with FK ?
Posted in 2012
Hi Marco, At the first time no, we do not have any ER or secondaries. I active a RSS (not updatable, just a stand by instance) a moth ago , so the last situation (week ago) I have the RSS active (and the problem is with alter table add check constraint and create trigger, not create index online) The relationship of the tables and the DDL executed: - tableA - create index online over tableA, fields X,Y - tableB , have FK, add constraint ( foreing key (Z) references tableA) - User insert into tableB ... -710 occur. If you have access, you can see the original schema and errors sent by me : PMR 23072,228,631 , message date aug/1/2011 15:49 Cesar On 3/5/2012 07:32, Marco Greco wrote: > > > On 02/05/12 18:29, Cesar Inacio Martins wrote: >> Hi Marco, >> >> Thank you for your answer. >> >> My big problem is not able to reproduce this behave. I try sometimes >> and every >> time just works... >> >> On the last 12 months , we already suffer with this problem at least >> 6 times. >> The last time was one week ago. >> >> I have pretty sure at least 3 times we just create a new index or >> drop/recreate some index over a table, never change they columns. >> Other we add a new columns and the last we add a new constraint and >> new trigger. >> >> To discovery what happens, I tried keep the focus at the most "simple" >> situation what is create a new index (online) and where is more >> reasonable not >> affect others tables thru they FK... >> >> When this problem start, I not confirm is 100% of the applications >> and user, >> but is a lot because the application log start to fill with errors >> -710 and >> the tels start to ring here.... and when this occur, do not matter >> what the >> user does, when they start a new session, the -710 will popup... >> > > That is definitely incorrect - you should not get -710 persistently, > dropping and recreating an index is definitely covered by > AUTO_REPREPARE, new sessions should not see the -710. > This said - I need a bit of a handle on this in order to be able to > investigate it - you should at least tell me I execute statement A on > table X and statement B using table Y fails with a -710. Here's the > schema for X & Y, and their relationship is... (PK/FK, or X used by a > stored procedure called by a trigger on on Y or...) > > Quick Q - do you use ER or updatable secondaries?