Nigel Campbell (nigelc@Cognos.COM) wrote:
: During testing, I ran into repeated 710 errors (running Online 7.10UC1 on SUN)
: for no apparent reason (that is, no tables are being renamed etc as 710
: implies).
-710 occurs when the version of a table has changed since the time a statement
was prepared, eg. if you PREPARE a UPDATE against a table, and before
executing it, someone ALTERs the table, or creates a trigger against it. Many
things you wouldn't necessarily think of will change the version of the table.
Also, sporadic -710 errors have been seen as the result of bug 40976 "SPORADIC
-206 AND -111 ERRORS WHEN SELECTING FROM A DATABASE OTHER THAN THE CURRENT
DATABASE" (even though -710 isn't mentioned), fixed in 7.11.UC1 and later.
June
---- June Tong Informix Software ----
---- Senior Consultant (415) 926-6140 ----
---- International Support junet@informix.com ----
---- Location-du-jour: Menlo Park ----