bcheck and retrurned value in index b-tree
Posted in 2008
Hello, Under Solaris 10 and 9, we are using a product which use an IBM C-ISAM database to store a lot of data. We had some problem with a database, some crash due to a database corruption and impossibility to our software to replay a record on the database, so the server was unable to update the database... ANYWAY ! When i run : bcheck <file> where file is an entity of the database, i don't have an error but the index b-tree is high. In this exemple, the index b-tree = 11 : <a number> index node(s) used -- 11 index b-tree level(s) used i d'ont know why, but after some weeks of investigation, the editor of the software and IBM for the database believe that the problem occur when the index b-tree exceeds 10. i am not a DBA and i know nothing about C-ISAM database, but could you give me your opinion please ? What does it mean to have an big value of index b-tree ? Thank You very much. Regards Rahan