Re: URGENT ! Help required to explain error message -408
Posted in 1997
> tony@potala.zynet.co.uk (Tony Haslam) writes:
> For some reason I am obtaining error number -408 "Invalid message type
> received from the sqlexec process" at different sql statements in my
> code. The system is using a really old version of Informix 4GL -
> version 2, and the standard database engine. The code has been running
> perfectly happily for several years. Now, for some reason, a change
> has occurred which has caused this error code to be generated.
We used to get the same with SE4 and 4GL4 on SCO. We finally traced it to a bug in SE. The 4GL code was
dropping the index on a table, deleting all rows, inserting new rows and finally re-creating the index. Somehow,
in a system catalog (I cannot remember which one, it was a very long time ago), a column indicating the
number of indexes was ending up with a value of -1.
We solved the problem by directly updating the column in the catalog before the drop index and before the
create index statement.
Bashar Chalabi
Card Tech Ltd