IP aliases and socket connections
Posted in 2000
Topics: Connectivity: ODBC / JDBC / .NET, Platform-Specific Issues, Versions, Editions & End-of-Life
Informix IDS 9.20 on HP-UX 11.0 We've moved some our systems from one UNIX server ("perky") to a more powerful one ("archer"). The IP address of perky was 193.118.114.2, and of archer 193.118.114.5. In order to avoid widespread changes on the client systems, we configured the ethernet port of archer to have an IP alias of 193.118.114.2, as well its primary address of 193.1118.114.5. perky was re-configured to have a completely new address of 193.118.114.4. This worked a treat for the majority of applications; those using telnet. All connected seamlessly to archer. However, none of the ODBC or other sockets connections would work. All fail with error 908 "cannot connect to database server". If client changes are made to change the hostname to 193.118.114.5, rather than 193.118.114.2, the applications work fine. Does anyone have any idea why the telnet connections work fine with the IP address, but the sockets connections don't? thanks Neil
Just walked straight into something similar, check what the host in the sqlhosts file refers to, you'll probably find it points to another IP. brett > Informix IDS 9.20 on HP-UX 11.0 > > We've moved some our systems from one UNIX server ("perky") to a more > powerful one ("archer"). The IP address of perky was 193.118.114.2, and of > archer 193.118.114.5. In order to avoid widespread changes on the client > systems, we configured the ethernet port of archer to have an IP alias of > 193.118.114.2, as well its primary address of 193.1118.114.5. perky was > re-configured to have a completely new address of 193.118.114.4. > > This worked a treat for the majority of applications; those using telnet. > All connected seamlessly to archer. However, none of the ODBC or other > sockets connections would work. All fail with error 908 "cannot connect to > database server". If client changes are made to change the hostname to > 193.118.114.5, rather than 193.118.114.2, the applications work fine. > > Does anyone have any idea why the telnet connections work fine with the IP > address, but the sockets connections don't? > > thanks > Neil > > >
The answer is that the sqlhosts entry for the services using 193.118.114.2 needs to refer to a host associated in the /etc/hosts table with that IP address, not with 193.118.114.5 as I had it. thanks Neil Neil Truby <ntruby@netcomuk.co.uk> wrote in message news:8p0u3e$kun$1@taliesin2.netcom.net.uk... > Informix IDS 9.20 on HP-UX 11.0 > > We've moved some our systems from one UNIX server ("perky") to a more > powerful one ("archer"). The IP address of perky was 193.118.114.2, and of > archer 193.118.114.5. In order to avoid widespread changes on the client > systems, we configured the ethernet port of archer to have an IP alias of > 193.118.114.2, as well its primary address of 193.1118.114.5. perky was > re-configured to have a completely new address of 193.118.114.4. > > This worked a treat for the majority of applications; those using telnet. > All connected seamlessly to archer. However, none of the ODBC or other > sockets connections would work. All fail with error 908 "cannot connect to > database server". If client changes are made to change the hostname to > 193.118.114.5, rather than 193.118.114.2, the applications work fine. > > Does anyone have any idea why the telnet connections work fine with the IP > address, but the sockets connections don't? > > thanks > Neil > >
Presuming The ODBC is set on a win95/98 workstation and using informix odbc Note that the odbc needs to define 3 things host name,database server name, and the database name -are they the same as the 2nd server also may be you need to check the sqlhosts file in the workstations informix /etc directory "Neil Truby" <ntruby@netcomuk.co.uk> wrote in message news:8p0u3e$kun$1@taliesin2.netcom.net.uk... > Informix IDS 9.20 on HP-UX 11.0 > > We've moved some our systems from one UNIX server ("perky") to a more > powerful one ("archer"). The IP address of perky was 193.118.114.2, and of > archer 193.118.114.5. In order to avoid widespread changes on the client > systems, we configured the ethernet port of archer to have an IP alias of > 193.118.114.2, as well its primary address of 193.1118.114.5. perky was > re-configured to have a completely new address of 193.118.114.4. > > This worked a treat for the majority of applications; those using telnet. > All connected seamlessly to archer. However, none of the ODBC or other > sockets connections would work. All fail with error 908 "cannot connect to > database server". If client changes are made to change the hostname to > 193.118.114.5, rather than 193.118.114.2, the applications work fine. > > Does anyone have any idea why the telnet connections work fine with the IP > address, but the sockets connections don't? > > thanks > Neil > >