Re: sqlcode < 100
Posted in 1993
In article <1n12h9INNbhe@emory.mathcs.emory.edu> lei@mtcdev.MEDIATECH.COM (Charles Lei) writes: >We're running SCO Unix 3.2.4 on 486 PCs with the 4.1 SE and 4.1 I-Net, >plus 4.0 RDS front ends. > >All of a sudden we're getting a series of repetitive sqlerrs. This started >happening immediately after we altered an unique index to start accepting >duplicate values. Did this really have anything to do with these problems? It can change your locking requirements, yes. >Its looks like we need bump up some of our kernal parameters, but can >someone tell us which ones? > >Here is an excerpt from our errlog: > Date: 03/02/1993 Time: 16:01:23 > Program error at "ad_field.4gl", line number 110. > SQL statement error number -242. > Could not open database table (root.stiinvtr). > SYSTEM error number -113. > Date: 03/02/1993 Time: 16:01:22 > Program error at "fg_mesg.4gl", line number 138. > SQL statement error number -211. > Cannot read system catalog (systables). > SYSTEM error number -46. > ... Looks like you are running out of record locks in the kernel (-46 == ENOLCK). Try bumping up FLCKREC in your kernel configuration (/etc/conf/cf.d/stune). >Since we're running I-Net, I would assume that these errors are >caused by the parameters on the database server. We should therefore >bump up the kernal parameters there, is this the correct assumption? Yes. >Thanks in advance for any replies... >Charles Lei >Mediatech, Inc. -- Alan Denney aland@informix.com {pyramid|uunet}!infmx!aland We'll sue your drummer in perfect four/four time We'll sue your manager for his last thin dime We'll sue your record label, hey now ain't this fun We'll sue your best friend if you still have one It ain't no crime, 'cause I'm a rock and roll lawyer -- "Rock and Roll Lawyer", Austin Lounge Lizards