Re: WHY index can corrupted???
Posted in 2003
miyaki wrote: > Hi all, > > OS : Sun Solaris 2.7 > IDS : 7.31.UD5 <snip> > > Anybody knows the reason that may cause the index > corruption??? > > Appreciate for the comments. > > TIA, > MIyaki We use similar hardware and OS in a very high volume db application. We used caching RAID disk controllers that would corrupt data long after it had given IO complete to Solaris and Informix. So neither the OS nor the db engine had anyway to handle a hardware corruption at a later time. At the time we were using controllers with 128MB cache in RAID 1+0 config. Somehow, the hardware would write corrupt data with correct parity, and the mirror manager would not know which image was correct. Hence index failures. Normally we would find out about corruption when doing backups. The only way to cure the problem was to get rid of the caching controllers. We now use RAID 5 which is slower but can self heal from intermittent disk failures. Thus, we have less performance but no more corruption for the past 2 years. Just one more experience. Bob B