7.31 crash problems
Posted in 2000
Topics: Installation, Setup & Upgrades, Storage & Space Management, Error Codes & Troubleshooting, Server Administration, Transactions, Locking & Isolation, Logging & Checkpoints, Networking & sqlhosts Configuration, Migration, Import/Export & Data Conversion, Versions, Editions & End-of-Life
Greetings from a long-time lurker!
I upgraded from IDS 7.31.UC2 to IDS 7.31.UC6A Dec 9, 2000 on our HPUX 11.0 N-Class server. This upgrade was performed to alleviate some bugs which occasionally crashed a server. Since the "bug-fix" upgrade, we have seen some noticeable slow-downs in VB retrieval jobs and have had several hard crashes during the past 5 days. The first crash occured when we were using HPL to unload data (simple select), and the second crash occured during a select with a union clause. Neither select should have been overly taxing on any system. It seems the cause of the first crash was caused by an invalid mutex type (through HPL) and the second caused by an mt_ex_os error.
Informix Tech Support has been contacted and is "looking" at the dumps. My question to the group is 2-fold. (1) since I see nothing about these problems in the Tech Info Center, are these specific to my location or is this a known bug and (2) would it be in my best interest to fallback to 7.31.UC2 ASAP?
Any information will be greatly appreciated.
Thanks.
John
======== slices from af files ===========
Dec 15, 2000
09:42:51 Informix Dynamic Server Version 7.31.UC6A Software Serial Number AAC
#J923245
09:42:51 Assert Failed: Invalid Mutex Type
09:42:51 Who: Session(356009, informix@moe, 7977, -912843464)
Thread(366466, ulstrm_1.0, c9f1412c, 3)
File: mt.c Line: 6630
09:42:51 Stack for thread: 366466 ulstrm_1.0
Assertion Failure Type: CRASH
Host Name: moe
Database Server Name: lawprd01_1
Time of failure: Fri Dec 15 09:42:52 EST 2000
AF file: /tmp/af.9b6a2deb
Shared memory file: None
System Blocking: OFF
09:42:51 Assert Failed: Invalid Mutex Type
09:42:51 Informix Dynamic Server Version 7.31.UC6A
09:42:51 Who: Session(356009, informix@moe, 7977, -912843464)
Thread(366466, ulstrm_1.0, c9f1412c, 3)
File: mt.c Line: 6630
===========------------- - - - - - -
/opt/informix/bin/onstat -g sql 356009:
Informix Dynamic Server Version 7.31.UC6A -- On-Line -- Up 5 days 13:59:26 --
1299720 Kbytes
Sess SQL Current Iso Lock SQL ISAM F.E.
Id Stmt type Database Lvl Mode ERR ERR Vers
356009 SELECT yccdbs DR Wait 0 0 7.31
Last parsed SQL statement :
select * from rapluchg for read only
Dec 19, 2000
14:11:40
14:11:40 Informix Dynamic Server Version 7.31.UC6A Software Serial Number AAC
#J923245
14:11:40 Assert Failed: Exception Caught. Type: MT_EX_OS, Context: mem
14:11:40 Who: Session(89227, jlw11@moe, 4158, -704215640)
Thread(93077, sqlexec, d74a1c60, 1)
File: mtex.c Line: 330
14:11:40 Action: Please notify Informix Technical Support.
14:11:40 Stack for thread: 93077 sqlexec
---------------------------------
Begin System Alarm Program Output
---------------------------------
Assertion Failure Type: FAILURE
Host Name: moe
Database Server Name: lawprd01_1
Time of failure: Tue Dec 19 14:11:42 EST 2000
AF file: /tmp/af.6f7db2eb
Shared memory file: None
System Blocking: OFF
===========------------- - - - - - -
/opt/informix/bin/onstat -g sql 89227:
Informix Dynamic Server Version 7.31.UC6A -- On-Line -- Up 1 days 16:15:30 --
1315720 Kbytes
Sess SQL Current Iso Lock SQL ISAM F.E.
Id Stmt type Database Lvl Mode ERR ERR Vers
89227 SELECT prod CR Not Wait 0 0 7.31
Current SQL statement :
select a.customer, c.r_name as name, c.addr1, c.addr2, c.city, c.state,
c.zip, a.contact, a.phone_nmbr phone from arcustomer a, custdesc c,
arcustflds f where c.cust_group = 'YCC ' and a.company = 1 and
f.company = 1 and a.customer = c.customer and a.customer = f.customer
and f.cust_user6[9]='Y' and a.customer not in ( select s.customer
from shipto s, ycshipflds f where s.company=1 and
f.company=1 and s.customer=147 and s.customer=f.customer
and s.ship_to=f.ship_to and f.cust_user2[9]="Y" ) union
select s.customer, s.r_name, s.addr1, s.addr2, s.city, s.state,
s.zip, f.cust_user6 contact, f.cust_user7 phone --select s.* from
shipto s, ycshipflds f where s.company=1 and
f.company=1 and s.customer=147 and s.customer=f.customer
and s.ship_to=f.ship_to and f.cust_user2[9]="Y"
======= onconfig =========
# Root Dbspace Configuration
ROOTNAME rtlaw001_dbs # Root dbspace name
ROOTPATH /dev/vg_ifmx00/u063.chk # Path for device containing root dbspace
#ROOTPATH /dev/vg_ifmx0/u001.chk # Path for device containing root dbspace
ROOTOFFSET 0 # Offset of root dbspace into device (Kbytes)
ROOTSIZE 150000 # Size of root dbspace (Kbytes)
# Disk Mirroring Configuration Parameters
MIRROR 1 # Mirroring flag (Yes = 1, No = 0)
MIRRORPATH /dev/vg_ifmx00/u086.chk
#MIRRORPATH /dev/vg_ifmx0/u002.chk
# Path for device containing mirrored root
MIRROROFFSET 0 # Offset into mirrored device (Kbytes)
# Physical Log Configuration
PHYSDBS pllaw001_dbs # Location (dbspace) of physical log
PHYSFILE 25000 # Physical log file size (Kbytes)
# Logical Log Configuration
LOGFILES 100 # Number of logical log files#LOGSIZE 1500 # Logical log size (Kbytes)
LOGSIZE 25000 # Logical log size (Kbytes)
# Diagnostics
MSGPATH /opt/informix/lawprd01.log # System message log file path
CONSOLE /opt/informix/lawprd01.console # System console message path
#ALARMPROGRAM /opt/informix/etc/log_full_lawprd.sh # Alarm program path
ALARMPROGRAM /opt/informix/etc/log_full.sh # Alarm program path
# System Archive Tape Device
TAPEDEV /dev/rmt/c4t1d0BEST # Tape device path (DLT7000)
TAPEBLK 64 # Tape block size (Kbytes)
TAPESIZE 68000000 # Maximum amount of data to put on tape (Kbytes)
# Log Archive Tape Device
LTAPEDEV /dev/rmt/c5t2d0BESTn # Tape device path (DLT7000)
LTAPEBLK 64 # Log tape block size (Kbytes)
LTAPESIZE 68000000 # Max amt of data to put on log tape (Kbytes)
# Optical
STAGEBLOB # INFORMIX-OnLine/Optical staging area
# System Configuration
SERVERNUM 3 # Unique id corresponding to a OnLine instance#SERVERNUM 1 # Unique id corresponding to a OnLine instance
DBSERVERNAME lawprd01_1 # Name of default database server
DBSERVERALIASES lawprd01_2 # List of alternate dbservernames
DEADLOCK_TIMEOUT 60 # Max time to wait of lock in distributed env.
RESIDENT 1 # Forced residency flag (Yes
In article <91qk62$aq0$1@news.xmission.com>, John Coyle <Jfc@yankeecandle.com> writes > >Greetings from a long-time lurker! > >Informix Tech Support has been contacted and is "looking" at the dumps. My >question to the group is 2-fold. (1) since I see nothing about these problems >in the Tech Info Center, are these specific to my location or is this a known >bug and (2) would it be in my best interest to fallback to 7.31.UC2 ASAP? > >Any information will be greatly appreciated. >Thanks. >John > We need the stack traces from the af files to be able to help! 7.31.UC2 has problems altering tables 7.31.UC4 appears to be stable. 7.31.UC5 has optimizer problems 7.31.UC6 can fail to rollback large index builds resulting in a server which will not start 7.31.UC7 ?? not played with! I would try 7.31.UC7 or UC4 > > >John F. Coyle >Senior Database Administrator >Yankee Candle Co. >jfc@yankeecandle.com > -- David Williams
David Williams wrote:
>
> In article <91qk62$aq0$1@news.xmission.com>, John Coyle
> <Jfc@yankeecandle.com> writes
> >
> >Greetings from a long-time lurker!
> >
> >Informix Tech Support has been contacted and is "looking" at the dumps. My
> >question to the group is 2-fold. (1) since I see nothing about these problems
> >in the Tech Info Center, are these specific to my location or is this a known
> >bug and (2) would it be in my best interest to fallback to 7.31.UC2 ASAP?
> >
> >Any information will be greatly appreciated.
> >Thanks.
> >John
> >
> We need the stack traces from the af files to be able to help!
>
> 7.31.UC2 has problems altering tables
> 7.31.UC4 appears to be stable.
> 7.31.UC5 has optimizer problems
> 7.31.UC6 can fail to rollback large index builds resulting in a
> server which will not start
> 7.31.UC7 ?? not played with!
>
> I would try 7.31.UC7 or UC4
Versions before 7.31UC6X4 are still marking index pages with the wrong flag
when a node is split. Newly created indexes are OK but they go bad over
time. Versions before 7.31UC4 create incorrectly flagged index pages in
oncheck (engine created indexes are OK) as well.
IDS 7.31 is looking almost as bad as 7.1x! Maybe they'll get UC8 right.
Art S. Kagel
Related threads
- Posting from the Informix-list
- Migrating from IDS 9.40.UC6 to 11.50.UC3
- Ip for a network session
- questions onstat -g