Re: oninit failure
Posted in 1998
Happened here when stream pipe connections are set up.
To use IPC with stream pipe, the nettype field in the sqlhosts file
entry
must be set to "onipcstr".
also an AIX system
Jo'o Carvalho wrote:
> Hi all !
>
> There is a story that I would like to share:
>
> After a system crash, in wich the server 'misterously'
> stoped due to a still unknown problem, the oninit command
> failled and was impossible to start online. The last error reported
> in the log was 25572 (Network driver cannot bind a name to the port).
>
> After som time of panic, and with Informix technical assistance,
> the error was solved: it seems that some Informix temporary files
> needed to be deleted after the system crash and before oninit
> in order to initialize.
>
> It was a IBM Aix machine with Informix 7.24 (I'm not 100% sure).
>
> I was not directly involved, so I'm not aware of all the details, but
> it was not the first time that I've heard this kind of 'error'.
>
> Can anyone explain thys behaviour? Is it usual?
>
> Help apreciated in advance.
>
> Joao Carvalho
> joao.s.carvalho@mail.telepac.pt