Re: oninit failure
Posted in 1998
Jo'o Carvalho wrote:
>
> Hi all !
>
> There is a story that I would like to share:
>
> After a system crash, in wich the server 'misterously'
> stoped due to a still unknown problem, the oninit command
> failled and was impossible to start online. The last error reported
> in the log was 25572 (Network driver cannot bind a name to the port).
>
> After som time of panic, and with Informix technical assistance,
> the error was solved: it seems that some Informix temporary files
> needed to be deleted after the system crash and before oninit
> in order to initialize.
>
> It was a IBM Aix machine with Informix 7.24 (I'm not 100% sure).
>
> I was not directly involved, so I'm not aware of all the details, but
> it was not the first time that I've heard this kind of 'error'.
>
> Can anyone explain thys behaviour? Is it usual?
I presume you are referring to the files in /INFORMXTMP. If IDS crashes,
or the machine crashes, it is quite possible for files to be left in
this directory. IDS then fails to initialise. Removing the files solves
the problem. In fact putting the command:
rm -f /INFORMIXTMP/*
in your rc2.d script is not uncommon.
It is usual after a crash, especially if you are using stream pipes.
Cheers,
--
Mark.
+----------------------------------------------------------+-----------+
|Mark D. Stock - Informix SA http://www.informix.com |//////// /|
|mailto:mdstock@informix.com FAQ http://www.iiug.org |///// / //|
| +-----------------------------------+//// / ///|
| Tel: +27 11 807 0313 |If it's slow, the users complain. |/// / ////|
| Fax: +27 11 807 2594 |If it's fast, the users keep quiet.|// / /////|
|Cell: +27 83 250 2325 |Therefore, "No news: travels fast"!|/ ////////|
+----------------------+-----------------------------------+-----------+