Use of Interval Datatype
Posted in 2008
Topics: Storage & Space Management, Server Administration
Am I being a bit stupid with this......
Informix 9.40.FC8X3
Solaris 9
I have a table
create table stathist
(
rec_no serial not null,
log_date date not null,
log_time datetime hour to minute,
run_date date not null,
server_name char(18) not null,
db_name char(18) not null,
table_name char(18) not null,
elapsed interval hour to fraction(3)
) extent size 1024 next size 128 lock mode page;
Nice and simple so far so I thought
I have some data
0|01/04/08|11:19:03|31/03/08|server_name|db_name|tabname1|00:00:02.327|
0|01/04/08|11:19:03|31/03/08|server_name|db_name|tabname2|00:00:00.586|
0|01/04/08|11:19:03|31/03/08|server_name|db_name|tabname3|28:50:52.828|
I run dbaccess to load this data into above table, it fails with
Database selected.
1264: Extra characters at the end of a datetime or interval.
847: Error in load file line 1.
Error in line 1Near character position 62
Database closed.
Anyone got an idea where I'm going wrong? All I want is to keep a history of how long dostats took to run on each table
Regards
Colin
There are 10 types of people in the world, those that understand binary and those that don't
_________________________________________________________________
The next generation of Windows Live is here
http://www.windowslive.co.uk/get-live
On 1 Apr, 12:04, Colin Dawson <cjd_1...@hotmail.com> wrote:
> Am I being a bit stupid with this......
>
Yep
> Informix 9.40.FC8X3
> Solaris 9
>
> I have a table
>
> create table stathist
> (
> rec_no serial not null,0|
> log_date date not null,
01/04/08|
> log_time datetime hour to minute,
11:19:03|
This is an hour to second value trying to go into an hour to minute
column