tbinit Error
Posted in 1999
Topics: Installation, Setup & Upgrades
Hi all, I am using informix online 5.01 for SCO UNIX, there is an error when I re-install the informix online. When I call the tbinit, the following error exist: tbinit: shmat[EINVAT][22]: shared memory base address illegal using 0x80480000, use 0x80800000 tbinit: fetal error in shared memory creation. I know it is due to the base address parameter declared in the file tbconfig.std, but this file is work before the re-installation. Do anyone know what I can do now? Thank you in advcance. Thomas Tsang
check the file: ~INFORMIXDIR/release/(blah...blah...blah)/ONLINE_5.01 or something similar. It should be a readme that tells what your shared memory parameters (/etc/system) file should look. Check and make sure the two look the same. I had the exact same problem with Online 7.2 on Sun Solaris 2.6. If this does not work, check the Answers Online or other documentation for information on Shared Memory parameters. Best of luck. Kevin p.s. I imagine you will have to reboot after making changes to the /etc/system file and make sure you leave a backup copy of /etc/system in the directory as well. Thomas Tsang wrote: > Hi all, > > I am using informix online 5.01 for SCO UNIX, there is an error when > I re-install the informix online. When I call the tbinit, the following > error exist: > > tbinit: shmat[EINVAT][22]: shared memory base address illegal using > 0x80480000, use 0x80800000 > tbinit: fetal error in shared memory creation. > > I know it is due to the base address parameter declared in the file > tbconfig.std, but this file is work before the re-installation. Do > anyone know what I can do now? Thank you in advcance. > > Thomas Tsang
Thomas Tsang wrote: > I am using informix online 5.01 for SCO UNIX, there is an error when > I re-install the informix online. When I call the tbinit, the following > error exist: > > tbinit: shmat[EINVAT][22]: shared memory base address illegal using > 0x80480000, use 0x80800000 > tbinit: fetal error in shared memory creation. > > I know it is due to the base address parameter declared in the file > tbconfig.std, but this file is work before the re-installation. Do > anyone know what I can do now? Thank you in advcance. Actually, it's usually due to wanting more shared memory than your kernel is configured for. Check out my FAQ at http://www.geocities.com/SiliconValley/Bridge/4578/faq.html June -- june_t@hotmail.com Grounded in Palo Alto, living on M&M's (plain)