Restore table level
Posted in 2011
Topics: Backup & Restore, Error Codes & Troubleshooting, Licensing & Editions
Hy everyone,
I'm trying to restore a table from a archive made using ontape utility.
My archive've beensent to filesystem backup
My schema file
create table "suporte".parm_comercial
(
cod_parametro char(8) not null ,
dados_parametro char(80) not null
);
create table "suporte".parm_comercial2
(
cod_parametro char(8) not null ,
dados_parametro char(80) not null
);
insert into "suporte".parm_comercial2 select * from "suporte".parm_comercial ;
env | grep AC_
AC_CONFIG=/informix/IDS/etc/ac_config.parm_comercial
My AC_CONFIG file contains
#**************************************************************************
#
# Licensed Material - Property Of IBM
#
# "Restricted Materials of IBM"
#
# IBM Informix Dynamic Server
# (c) Copyright IBM Corporation 1996, 2004 All rights reserved.
#
# Title: ac_config.std
# Description:
# Default ac_config.std for archecker archive utility
#
#**************************************************************************
AC_STORAGE /logical
AC_MSGPATH /logical/ac_msg.log
AC_TAPEBLOCK 1024 KB
and the archecker line command
archecker -tX -f /home/informix/MKI/restable/tabela.sql
It did return to me:
STATUS: Arguments [-tX -f /home/informix/MKI/restable/tabela.sql]
STATUS: AC_STORAGE /logical
STATUS: AC_MSGPATH /logical/ac_msg.log
STATUS: AC_VERBOSE off
STATUS: AC_TAPEDEV /archive/wurth4_1_L0
STATUS: AC_TAPEBLOCK 1024 KB
STATUS: AC_LTAPEDEV /logical/
STATUS: AC_LTAPEBLOCK 1024 KB
STATUS: AC_SCHEMA /home/informix/MKI/restable/tabela.sql
TIME: [2011-05-02 12:25:28] All old validation files removed.
ERROR: "CONNECT TO" failed
ERROR: -27000: (rgetlmsg() returned -1227)
ERROR: Failed to connect to sysutils (-1)
CRITICAL ERROR: Connection to the database server 'logixd350' has failed
(SQLCODE: -27000).
ERROR: Failed in log cleanup
CRITICAL ERROR: Unable to initialize resources
STATUS: archecker completed Setup pid = 3929 exit code: 3
Did I miss anything?Thanks a lot.
André
Andre, you didn´t specify your engine version and arch (always
recommended) ok?
1) is this tapeblk the same as your backup uses? It seems very large for
a regular backup, isn´t it? (1MB)?
Obs: Here we use 64 KB for regular backups, and I used 62 KB for TLR
operations.
2) I should recommend you to put your table owners, I had some issues
regarding this, here....
HOpe it helps.
Best regards.
Em 02/05/2011 11:27, André Luiz Rufino escreveu:
> Hy everyone,
>
> I'm trying to restore a table from a archive made using ontape utility.
>
> My archive've beensent to filesystem backup
>
> My schema file
>
> create table "suporte".parm_comercial
> (
>
> cod_parametro char(8) not null ,
>
> dados_parametro char(80) not null
> );
>
> create table "suporte".parm_comercial2
> (
>
> cod_parametro char(8) not null ,
>
> dados_parametro char(80) not null
> );
>
> insert into "suporte".parm_comercial2 select * from "suporte".parm_comercial
;
>
> env | grep AC_
> AC_CONFIG=/informix/IDS/etc/ac_config.parm_comercial
>
> My AC_CONFIG file contains
>
> #**************************************************************************
> #
> # Licensed Material - Property Of IBM
> #
> # "Restricted Materials of IBM"
> #
> # IBM Informix Dynamic Server
> # (c) Copyright IBM Corporation 1996, 2004 All rights reserved.
> #
> # Title: ac_config.std
> # Description:
> # Default ac_config.std for archecker archive utility
> #
> #**************************************************************************
> AC_STORAGE /logical
> AC_MSGPATH /logical/ac_msg.log
> AC_TAPEBLOCK 1024 KB
>
> and the archecker line command
>
> archecker -tX -f /home/informix/MKI/restable/tabela.sql
>
> It did return to me:
>
> STATUS: Arguments [-tX -f /home/informix/MKI/restable/tabela.sql]
> STATUS: AC_STORAGE /logical
> STATUS: AC_MSGPATH /logical/ac_msg.log
> STATUS: AC_VERBOSE off
> STATUS: AC_TAPEDEV /archive/wurth4_1_L0
> STATUS: AC_TAPEBLOCK 1024 KB
> STATUS: AC_LTAPEDEV /logical/
> STATUS: AC_LTAPEBLOCK 1024 KB
> STATUS: AC_SCHEMA /home/informix/MKI/restable/tabela.sql
> TIME: [2011-05-02 12:25:28] All old validation files removed.
> ERROR: "CONNECT TO" failed
> ERROR: -27000: (rgetlmsg() returned -1227)
> ERROR: Failed to connect to sysutils (-1)
> CRITICAL ERROR: Connection to the database server 'logixd350' has failed
> (SQLCODE: -27000).
> ERROR: Failed in log cleanup
> CRITICAL ERROR: Unable to initialize resources
> STATUS: archecker completed Setup pid = 3929 exit code: 3
>
> Did I miss anything?Thanks a lot.
>
> André
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--
Alexandre Marini
Tecnologia da Informação - DBA
msn: alexandre_marini@hotmail.com
SEFAZ-MS / SGI-UGSR / Sistemas IBM-Informix
Cert-Info-Mgmt_color <Cert-Info-Mgmt_color.jpg>
IBM Certified System Administrator - Informix Dynamic Server V10 / V11
See you at
<http://www.iiug.org/conf/2011/iiug/>
I believe you are missing a database statement for
both the the destination table and source table. While
they can be one in the same database they can also
be different. If they are different, you will have to ensure
that your insert/select statement reference the correct
databases.
Updated archive command file which uses a single database
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D
database dbsname;create table "suporte".parm_comercial
(
cod_parametro char(8) not null ,
dados_parametro char(80) not null
);
create table "suporte".parm_comercial2
(
cod_parametro char(8) not null ,
dados_parametro char(80) not null
);
insert into "suporte".parm_comercial2 select * from
"suporte".parm_comercial ;
John F. Miller III
STSM, Embedability Architect
miller3@us.ibm.com
503-578-5645
IBM Informix Dynamic Server (IDS)
ids-bounces@iiug.org wrote on 05/02/2011 08:27:54 AM:
> From:
>
> "Andr=E9 Luiz Rufino" <andre_rufino@msn.com>
>
> To:
>
> ids@iiug.org
>
> Date:
>
> 05/02/2011 08:29 AM
>
> Subject:
>
> Restore table level [23569]
>
> Sent by:
>
> ids-bounces@iiug.org
>
> Hy everyone,
>
> I'm trying to restore a table from a archive made using ontape utilit=
y.
>
> My archive've beensent to filesystem backup
>
> My schema file
>
> create table "suporte".parm_comercial
> (
>
> cod_parametro char(8) not null ,
>
> dados_parametro char(80) not null
> );
>
> create table "suporte".parm_comercial2
> (
>
> cod_parametro char(8) not null ,
>
> dados_parametro char(80) not null
> );
>
> insert into "suporte".parm_comercial2 select * from
> "suporte".parm_comercial ;
>
> env | grep AC_
> AC_CONFIG=3D/informix/IDS/etc/ac_config.parm_comercial
>
> My AC_CONFIG file contains
>
>
#**********************************************************************=
****
> #
> # Licensed Material - Property Of IBM
> #
> # "Restricted Materials of IBM"
> #
> # IBM Informix Dynamic Server
> # (c) Copyright IBM Corporation 1996, 2004 All rights reserved.
> #
> # Title: ac_config.std
> # Description:
> # Default ac_config.std for archecker archive utility
> #
>
#**********************************************************************=
****
> AC_STORAGE /logical
> AC_MSGPATH /logical/ac_msg.log
> AC_TAPEBLOCK 1024 KB
>
> and the archecker line command
>
> archecker -tX -f /home/informix/MKI/restable/tabela.sql
>
> It did return to me:
>
> STATUS: Arguments [-tX -f /home/informix/MKI/restable/tabela.sql]
> STATUS: AC_STORAGE /logical
> STATUS: AC_MSGPATH /logical/ac_msg.log
> STATUS: AC_VERBOSE off
> STATUS: AC_TAPEDEV /archive/wurth4_1_L0
> STATUS: AC_TAPEBLOCK 1024 KB
> STATUS: AC_LTAPEDEV /logical/
> STATUS: AC_LTAPEBLOCK 1024 KB
> STATUS: AC_SCHEMA /home/informix/MKI/restable/tabela.sql
> TIME: [2011-05-02 12:25:28] All old validation files removed.
> ERROR: "CONNECT TO" failed
> ERROR: -27000: (rgetlmsg() returned -1227)
> ERROR: Failed to connect to sysutils (-1)
> CRITICAL ERROR: Connection to the database server 'logixd350' has fai=
led
> (SQLCODE: -27000).
> ERROR: Failed in log cleanup
> CRITICAL ERROR: Unable to initialize resources
> STATUS: archecker completed Setup pid =3D 3929 exit code: 3
>
> Did I miss anything?Thanks a lot.
>
> Andr=E9
>
>
>
***********************************************************************=
********
> Forum Note: Use "Reply" to post a response in the discussion forum.=
>=
not sure if will work...
try set INFORMIXSERVER to a SOC connection / alias.
On 2/5/2011 12:27, André Luiz Rufino wrote:
> Hy everyone,
>
> I'm trying to restore a table from a archive made using ontape utility.
>
> My archive've beensent to filesystem backup
>
> My schema file
>
> create table "suporte".parm_comercial
> (
>
> cod_parametro char(8) not null ,
>
> dados_parametro char(80) not null
> );
>
> create table "suporte".parm_comercial2
> (
>
> cod_parametro char(8) not null ,
>
> dados_parametro char(80) not null
> );
>
> insert into "suporte".parm_comercial2 select * from "suporte".parm_comercial
;
>
> env | grep AC_
> AC_CONFIG=/informix/IDS/etc/ac_config.parm_comercial
>
> My AC_CONFIG file contains
>
> #**************************************************************************
> #
> # Licensed Material - Property Of IBM
> #
> # "Restricted Materials of IBM"
> #
> # IBM Informix Dynamic Server
> # (c) Copyright IBM Corporation 1996, 2004 All rights reserved.
> #
> # Title: ac_config.std
> # Description:
> # Default ac_config.std for archecker archive utility
> #
> #**************************************************************************
> AC_STORAGE /logical
> AC_MSGPATH /logical/ac_msg.log
> AC_TAPEBLOCK 1024 KB
>
> and the archecker line command
>
> archecker -tX -f /home/informix/MKI/restable/tabela.sql
>
> It did return to me:
>
> STATUS: Arguments [-tX -f /home/informix/MKI/restable/tabela.sql]
> STATUS: AC_STORAGE /logical
> STATUS: AC_MSGPATH /logical/ac_msg.log
> STATUS: AC_VERBOSE off
> STATUS: AC_TAPEDEV /archive/wurth4_1_L0
> STATUS: AC_TAPEBLOCK 1024 KB
> STATUS: AC_LTAPEDEV /logical/
> STATUS: AC_LTAPEBLOCK 1024 KB
> STATUS: AC_SCHEMA /home/informix/MKI/restable/tabela.sql
> TIME: [2011-05-02 12:25:28] All old validation files removed.
> ERROR: "CONNECT TO" failed
> ERROR: -27000: (rgetlmsg() returned -1227)
> ERROR: Failed to connect to sysutils (-1)
> CRITICAL ERROR: Connection to the database server 'logixd350' has failed
> (SQLCODE: -27000).
> ERROR: Failed in log cleanup
> CRITICAL ERROR: Unable to initialize resources
> STATUS: archecker completed Setup pid = 3929 exit code: 3
>
> Did I miss anything?Thanks a lot.
>
> André
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
Perfect Cesar. I just export the DBSERVERNAME like INFORMIXSERVER and
everything was fine. Thanks a lot......
> To: ids@iiug.org
> From: cesar_inacio_martins@yahoo.com.br
> Subject: Re: Restore table level [23572]
> Date: Mon, 2 May 2011 12:03:14 -0400
>
> not sure if will work...
>
> try set INFORMIXSERVER to a SOC connection / alias.
>
> On 2/5/2011 12:27, André Luiz Rufino wrote:
> > Hy everyone,
> >
> > I'm trying to restore a table from a archive made using ontape utility.
> >
> > My archive've beensent to filesystem backup
> >
> > My schema file
> >
> > create table "suporte".parm_comercial
> > (
> >
> > cod_parametro char(8) not null ,
> >
> > dados_parametro char(80) not null
> > );
> >
> > create table "suporte".parm_comercial2
> > (
> >
> > cod_parametro char(8) not null ,
> >
> > dados_parametro char(80) not null
> > );
> >
> > insert into "suporte".parm_comercial2 select * from
"suporte".parm_comercial
> ;
> >
> > env | grep AC_
> > AC_CONFIG=/informix/IDS/etc/ac_config.parm_comercial
> >
> > My AC_CONFIG file contains
> >
> > #**************************************************************************
> > #
> > # Licensed Material - Property Of IBM
> > #
> > # "Restricted Materials of IBM"
> > #
> > # IBM Informix Dynamic Server
> > # (c) Copyright IBM Corporation 1996, 2004 All rights reserved.
> > #
> > # Title: ac_config.std
> > # Description:
> > # Default ac_config.std for archecker archive utility
> > #
> > #**************************************************************************
> > AC_STORAGE /logical
> > AC_MSGPATH /logical/ac_msg.log
> > AC_TAPEBLOCK 1024 KB
> >
> > and the archecker line command
> >
> > archecker -tX -f /home/informix/MKI/restable/tabela.sql
> >
> > It did return to me:
> >
> > STATUS: Arguments [-tX -f /home/informix/MKI/restable/tabela.sql]
> > STATUS: AC_STORAGE /logical
> > STATUS: AC_MSGPATH /logical/ac_msg.log
> > STATUS: AC_VERBOSE off
> > STATUS: AC_TAPEDEV /archive/wurth4_1_L0
> > STATUS: AC_TAPEBLOCK 1024 KB
> > STATUS: AC_LTAPEDEV /logical/
> > STATUS: AC_LTAPEBLOCK 1024 KB
> > STATUS: AC_SCHEMA /home/informix/MKI/restable/tabela.sql
> > TIME: [2011-05-02 12:25:28] All old validation files removed.
> > ERROR: "CONNECT TO" failed
> > ERROR: -27000: (rgetlmsg() returned -1227)
> > ERROR: Failed to connect to sysutils (-1)
> > CRITICAL ERROR: Connection to the database server 'logixd350' has failed
> > (SQLCODE: -27000).
> > ERROR: Failed in log cleanup
> > CRITICAL ERROR: Unable to initialize resources
> > STATUS: archecker completed Setup pid = 3929 exit code: 3
> >
> > Did I miss anything?Thanks a lot.
> >
> > André
> >
> >
> >
>
*******************************************************************************
> > Forum Note: Use "Reply" to post a response in the discussion forum.
> >
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>