Re: unloading data into a file up to 2GB only?
Posted in 2003
Try spillting your unload query into multiple files. For example if there is any year data or by month ,this would help in overcoming the 2GB limitation. Thanks Venkatesh >>> miyaki <lcib@yahoo.com> 04/29/03 02:18AM >>> Dear all, OS = Solaris 2.7IDS = 7.31.UC2 I have a table with more than 23 mil of records and I try to unload all the data into a file. The unloading process was failed when the file size reach 2GB. I was hitting the same error when using the HPL to unload from the same table. Initially I thought the file system that store the unloading file was not able to handle any large file with more than 2GB. But, I was wrong when I'm able to write a file that close to 2.5GB using a shell script in the same file system. The current value of the ulimit -d output is set to unlimited. I can say that the current setting of my OS is able to support any file that more than 2GB. I think most likely the problem might be caused by Informix. Is it a limitation of Informix? Any resolution or workaround methods? Please advise. Thanks in advance. Regards,Miyaki --------------------------------- Do you Yahoo!? The New Yahoo! Search - Faster. Easier. Bingo.